summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6d1787bbf7..c6dca2874f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2372,14 +2372,14 @@ manipulate such data.")
 (define-public ocaml-mtime
   (package
     (name "ocaml-mtime")
-    (version "1.4.0")
+    (version "2.0.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://erratique.ch/software/mtime/releases/"
+              (uri (string-append "https://erratique.ch/software/mtime/releases/"
                                   "mtime-" version ".tbz"))
               (sha256
                (base32
-                "1xy6lg52n2zynp4p164ym9j0f1b95j5n4bi5y4mbdrry9w99h32m"))))
+                "1ss4w3qxsfp51d88r0j7dzqs05dbb1xdx11hn1jl9cvd03ma0g9z"))))
     (build-system ocaml-build-system)
     (native-inputs
      (list ocamlbuild opam))
@@ -2847,7 +2847,7 @@ to which allows adding and looking up bindings in a type safe manner.")
 (define ocaml-eio
   (package
     (name "ocaml-eio")
-    (version "0.7")
+    (version "0.8.1")
     (home-page "https://github.com/ocaml-multicore/eio")
     (source
      (origin
@@ -2857,7 +2857,7 @@ to which allows adding and looking up bindings in a type safe manner.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256 (base32
-                "118raxdwv6pn5b152ffdhmwdi0l4wlwflcj2nmckfmm7v1z2fq4s"))))
+                "02q9i5wbb2497vd4ypc9d9p4zi3lmx0rsv8faiy7h8dnnzbjjf4z"))))
     (build-system dune-build-system)
     (arguments `(#:package "eio"))
     (propagated-inputs (list ocaml-bigstringaf
@@ -2871,7 +2871,10 @@ to which allows adding and looking up bindings in a type safe manner.")
                              ocaml-hmap
                              ocaml-mtime
                              ocaml-odoc))
-    (native-inputs (list ocaml-astring ocaml-crowbar ocaml-alcotest))
+    (native-inputs (list ocaml-astring
+                         ocaml-crowbar
+                         ocaml-alcotest
+                         ocaml-mdx))
     (synopsis "Effect-based direct-style IO API for OCaml")
     (description "This package provides an effect-based IO API for multicore
 OCaml with fibers.")
@@ -2897,7 +2900,7 @@ OCaml with fibers.")
 (define-public ocaml-uring
   (package
     (name "ocaml-uring")
-    (version "0.4")
+    (version "0.5")
     (home-page "https://github.com/ocaml-multicore/ocaml-uring")
     (source
       (origin
@@ -2907,7 +2910,7 @@ OCaml with fibers.")
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256 (base32
-                 "0k70y7nb2wrk2yql0pwnrhsp1x7k9ld4gd8iihbv6r34kcm3a5m1"))))
+                 "0ygx8v01bb5808wy6nppg40h1ns8b1f2l585lwc4389z4wrppk95"))))
     (build-system dune-build-system)
     (propagated-inputs
      (list ocaml-cstruct