summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9c0ab94f3e..11389440dc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -249,6 +249,17 @@ functional, imperative and object-oriented styles of programming.")
              (lambda _
                ;; Specifying '-j' at all causes the build to fail.
                (zero? (system* "make" "world.opt"))))
+           ,@(if (string=? "aarch64-linux" (%current-system))
+               ;; Custom configure script doesn't recongnize aarch64.
+               '((replace 'configure
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (mandir (string-append out "/share/man")))
+                      (invoke "./configure"
+                              "--prefix" out
+                              "--mandir" mandir
+                              "-host" "armv8l-unknown-linux-gnu")))))
+               '())
            (replace 'check
              (lambda _
                (with-directory-excursion "testsuite"
@@ -261,7 +272,7 @@ functional, imperative and object-oriented styles of programming.")
 (define-public ocaml-4.07
   (package
     (inherit ocaml-4.02)
-    (version "4.07.0")
+    (version "4.07.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -270,7 +281,7 @@ functional, imperative and object-oriented styles of programming.")
                     "/ocaml-" version ".tar.xz"))
               (sha256
                (base32
-                "03wzkzv6w4rdiiva20g5amz0n4x75swpjl8d80468p6zm8hgfnzl"))))
+                "1f07hgj5k45cylj1q3k5mk8yi02cwzx849b1fwnwia8xlcfqpr6z"))))
     (arguments
      (substitute-keyword-arguments (package-arguments ocaml-4.02)
        ((#:phases phases)
@@ -487,7 +498,7 @@ syntax of OCaml.")
 (define-public camlp5
   (package
     (name "camlp5")
-    (version "7.06")
+    (version "7.07")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/camlp5/camlp5/archive/rel"
@@ -495,7 +506,7 @@ syntax of OCaml.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "08kr0h2rq3jh3kzqh5f6pr589bqw3y76z8k59ad2kdh50fjgp8xy"))))
+                "148r6p93xlxi6v7kbsqv8i70r6av04cyn0109pwss5xj6fw97i52"))))
     (build-system gnu-build-system)
     (inputs
      `(("ocaml" ,ocaml)))
@@ -617,7 +628,7 @@ the OCaml core distribution.")
 (define-public coq
   (package
     (name "coq")
-    (version "8.8.1")
+    (version "8.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/coq/coq/archive/V"
@@ -625,7 +636,7 @@ the OCaml core distribution.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "13cyvbg8cgqkg9wz0ax7jq03srj9k0lyvny97fcka4ai1zrzwln8"))))
+                "0i2hs0i6rp27cy8zd0mx7jscqw5cx2y0diw0pxgij66s3yr47y7r"))))
     (native-search-paths
      (list (search-path-specification
             (variable "COQPATH")