summary refs log tree commit diff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 8f66b07527..7e424dd185 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -45,7 +46,8 @@
                 "07anqypf7c719x9y683qz65cxllmzlgmlab2hlahrqcj4bq2k99c"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("--disable-static")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'remote-dangling-symlink
            (lambda _
@@ -100,6 +102,26 @@ IPv4 and IPv6.  ONC RPC is notably used by the network file system (NFS).")
 universal addresses.")
     (license bsd-3)))
 
+(define-public rpcsvc-proto
+  (package
+    (name "rpcsvc-proto")
+    (version "1.4")
+    (home-page "https://github.com/thkukuk/rpcsvc-proto")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append home-page "/releases/download/v" version
+                                  "/rpcsvc-proto-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
+    (build-system gnu-build-system)
+    (synopsis "RPCSVC protocol definitions")
+    (description
+     "This package provides @code{rpcsvc} @file{protocol.x} files and headers
+that are not included with the @code{libtirpc} package.  Additionally it
+contains @command{rpcgen}, which is used to produce header files and sources
+from the protocol files.")
+    (license bsd-3)))
 
 (define-public libnsl
   (package
@@ -115,6 +137,15 @@ universal addresses.")
                (base32
                 "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--disable-static")
+       #:phases (modify-phases %standard-phases
+                  (add-before 'bootstrap 'gettextize
+                    (lambda _
+                      ;; Regenerate the bundled Makefile.in.in to avoid a
+                      ;; "gettext infrastructure mismatch" because the
+                      ;; existing version was generated by an older gettext.
+                      (invoke "gettextize" "-f"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)