summary refs log tree commit diff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index 14ff13c038..c58bdb1dfc 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -75,12 +75,12 @@ IPv4 and IPv6.  ONC RPC is notably used by the network file system (NFS).")
     (license bsd-3)))
 
 (define-public libtirpc/hurd
-  (package
-    (inherit libtirpc)
+  (package/inherit libtirpc
     (name "libtirpc-hurd")
     (source (origin (inherit (package-source libtirpc))
-                    (patches (search-patches "libtirpc-hurd.patch"
-                                             "libtirpc-hurd-client.patch"))))
+                    (patches (append (origin-patches libtirpc)
+                                     (search-patches "libtirpc-hurd.patch"
+                                                     "libtirpc-hurd-client.patch")))))
     (arguments
      (substitute-keyword-arguments (package-arguments libtirpc)
        ((#:configure-flags flags ''())