summary refs log tree commit diff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index de8239b7fe..aa51520654 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,6 +58,7 @@
 
 (define-public openldap
   (package
+   (replacement openldap/fixed)
    (name "openldap")
    (version "2.4.47")
    (source (origin
@@ -110,6 +112,13 @@
    (license openldap2.8)
    (home-page "https://www.openldap.org/")))
 
+(define openldap/fixed
+  (package
+    (inherit openldap)
+    (source
+      (origin (inherit (package-source openldap))
+              (patches (search-patches "openldap-CVE-2020-12243.patch"))))))
+
 (define-public nss-pam-ldapd
   (package
     (name "nss-pam-ldapd")