summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm263
1 files changed, 263 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 91686441ba..39584d566f 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -25,6 +25,41 @@
                 #:select (asl2.0))
   #:use-module (guix packages))
 
+(define-public python-debtcollector
+  (package
+    (name "python-debtcollector")
+    (version "0.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/d/debtcollector/"
+               "debtcollector-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0amlcg5f98lk2mfzdg44slh1nsi2y4ds123g5d57376fjk2b3njd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-wrapt" ,python-wrapt)))
+    (inputs
+      `(("python-babel" ,python-babel)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests.
+        ("python-oslotest" ,python-oslotest)))
+    (home-page "http://www.openstack.org/")
+    (synopsis
+      "Find deprecated patterns and strategies in Python code")
+    (description
+      "This package provides a collection of Python deprecation patterns and
+strategies that help you collect your technical debt in a non-destructive
+manner.")
+    (license asl2.0)))
+
+(define-public python2-debtcollector
+  (package-with-python2 python-debtcollector))
+
 (define-public python-mox3
   (package
     (name "python-mox3")
@@ -139,7 +174,147 @@ and sensible default behaviors into your setuptools run.")
 (define-public python2-pbr
   (package-with-python2 python-pbr))
 
+(define-public python-requests-mock
+  (package
+    (name "python-requests-mock")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/r/requests-mock/"
+             "requests-mock-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0gmd88c224y53b1ai8cfsrcxm9kw3gdqzysclmnaqspg7zjhxwd1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-requests" ,python-requests)
+        ("python-six" ,python-six)))
+    (inputs
+      `(("python-mock" ,python-mock)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)))
+    (home-page "https://requests-mock.readthedocs.org/")
+    (synopsis "Mock out responses from the requests package")
+    (description
+      "This module provides a building block to stub out the HTTP requests
+portions of your testing code.")
+    (license asl2.0)))
+
+(define-public python2-requests-mock
+  (package-with-python2 python-requests-mock))
+
+(define-public python-stevedore
+  (package
+    (name "python-stevedore")
+    (version "1.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/s/stevedore/stevedore-"
+             version
+             ".tar.gz"))
+       (sha256
+         (base32
+          "149pjc0c3z6khjisn4yil3f94qjnzwafz093wc8rrzbw828qdkv8"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-six" ,python-six)))
+    (inputs
+      `(("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests
+        ("python-docutils" ,python-docutils)
+        ("python-mock" ,python-mock)
+        ("python-oslotest" ,python-oslotest)
+        ("python-sphinx" ,python-sphinx)))
+    (home-page "https://github.com/dreamhost/stevedore")
+    (synopsis "Manage dynamic plugins for Python applications")
+    (description
+      "Python makes loading code dynamically easy, allowing you to configure
+and extend your application by discovering and loading extensions (“plugins”)
+at runtime.  Many applications implement their own library for doing this,
+using __import__ or importlib.  stevedore avoids creating yet another extension
+mechanism by building on top of setuptools entry points.  The code for managing
+entry points tends to be repetitive, though, so stevedore provides manager
+classes for implementing common patterns for using dynamically loaded
+extensions.")
+    (license asl2.0)))
+
+(define-public python2-stevedore
+  (package-with-python2 python-stevedore))
+
 ;; Packages from the Oslo library
+(define-public python-oslo.config
+  (package
+    (name "python-oslo.config")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/o/oslo.config/oslo.config-"
+             version
+             ".tar.gz"))
+       (sha256
+         (base32
+          "13r778jfb0fhna37c2pd1f2xipnsbd7zli7qhn96acrzymrwj5k1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-netaddr" ,python-netaddr)
+        ("python-six" ,python-six)
+        ("python-stevedore" ,python-stevedore)))
+    (inputs
+      `(("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests
+        ("python-oslo.i18n" ,python-oslo.i18n)
+        ("python-mock" ,python-mock)
+        ("python-oslotest" ,python-oslotest)
+        ("python-testscenarios" ,python-testscenarios)))
+    (home-page "https://launchpad.net/oslo")
+    (synopsis "Oslo Configuration API")
+    (description
+      "The Oslo configuration API supports parsing command line arguments and
+.ini style configuration files.")
+    (license asl2.0)))
+
+(define-public python2-oslo.config
+  (package-with-python2 python-oslo.config))
+
+(define-public python-oslo.context
+  (package
+    (name "python-oslo.context")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/o/oslo.context/"
+             "oslo.context-" version ".tar.gz"))
+       (sha256
+        (base32
+         "16wr9qrkc3lb94ssb14qid4liza66x316fvzjw0izg67h1a0fm86"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-babel" ,python-babel)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests.
+        ("python-oslotest" ,python-oslotest)))
+    (home-page "http://launchpad.net/oslo")
+    (synopsis "Oslo context library")
+    (description
+      "The Oslo context library has helpers to maintain useful information
+about a request context.  The request context is usually populated in the WSGI
+pipeline and used by various modules such as logging.")
+    (license asl2.0)))
+
+(define-public python2-oslo.context
+  (package-with-python2 python-oslo.context))
+
 (define-public python-oslo.i18n
   (package
     (name "python-oslo.i18n")
@@ -177,6 +352,45 @@ in an application or library.")
 (define-public python2-oslo.i18n
   (package-with-python2 python-oslo.i18n))
 
+(define-public python-oslo.serialization
+  (package
+    (name "python-oslo.serialization")
+    (version "1.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/o/oslo.serialization/"
+             "oslo.serialization-" version ".tar.gz"))
+       (sha256
+        (base32
+         "00qaxg155s61ylh4fqc7m5fh0gijf33khhai9xvcsc9k106i3c9c"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-iso8601" ,python-iso8601)
+        ("python-netaddr" ,python-netaddr)
+        ("python-oslo.utils" ,python-oslo.utils)
+        ("python-simplejson" ,python-simplejson)
+        ("python-six" ,python-six)
+        ("python-pytz" ,python-pytz)))
+    (inputs
+      `(("python-babel" ,python-babel)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests.
+        ("python-mock" ,python-mock)
+        ("python-oslo.i18n" ,python-oslo.i18n)
+        ("python-oslotest" ,python-oslotest)))
+    (home-page "http://launchpad.net/oslo")
+    (synopsis "Oslo serialization library")
+    (description
+      "The oslo.serialization library provides support for representing objects
+in transmittable and storable formats, such as JSON and MessagePack.")
+    (license asl2.0)))
+
+(define-public python2-oslo.serialization
+  (package-with-python2 python-oslo.serialization))
+
 (define-public python-oslotest
   (package
     (name "python-oslotest")
@@ -214,3 +428,52 @@ and better support for mocking results.")
 
 (define-public python2-oslotest
   (package-with-python2 python-oslotest))
+
+(define-public python-oslo.utils
+  (package
+    (name "python-oslo.utils")
+    (version "2.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/o/oslo.utils/oslo.utils-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "11b073gblhzkxhi1j6sqk3apq2ll8xhi9h9g9kxzx9dycqdq0qp0"))
+        (snippet
+         '(begin
+            ;; FIXME: setuptools fails to import this file during the test
+            ;; phase.
+            (delete-file "oslo_utils/tests/test_netutils.py")))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-debtcollector" ,python-debtcollector)
+        ("python-oslo.i18n" ,python-oslo.i18n)
+        ("python-iso8601" ,python-iso8601)
+        ("python-monotonic" ,python-monotonic)
+        ("python-netaddr" ,python-netaddr)
+        ("python-netifaces" ,python-netifaces)
+        ("python-pytz" ,python-pytz)
+        ("python-six" ,python-six)))
+    (inputs
+      `(("python-babel" ,python-babel)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests.
+        ("python-oslotest" ,python-oslotest)
+        ("python-mock" ,python-mock)
+        ("python-mox3" ,python-mox3)
+        ("python-testscenarios" ,python-testscenarios)))
+    (home-page "http://launchpad.net/oslo")
+    (synopsis "Oslo utility library")
+    (description
+      "The @code{oslo.utils} library provides support for common utility type
+functions, such as encoding, exception handling, string manipulation, and time
+handling.")
+    (license asl2.0)))
+
+(define-public python2-oslo.utils
+  (package-with-python2 python-oslo.utils))