summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index bc16d142ef..f7e025041d 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -607,35 +607,37 @@ for debugging, and better support for mocking results.")
 (define-public python-oslo.utils
   (package
     (name "python-oslo.utils")
-    (version "3.36.2")
+    (version "4.12.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "oslo.utils" version))
         (sha256
           (base32
-           "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
+           "0kfgr6lr3r34nzmkvnyywr0x3lkwpwy35m1dj4rkk3ydqvi1xaip"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests? (invoke "stestr" "run")))))))
     (propagated-inputs
       (list python-debtcollector
             python-oslo.i18n
             python-iso8601
-            python-monotonic
             python-netaddr
             python-netifaces
+            python-pbr
+            python-packaging-next
             python-pyparsing
-            python-pytz
-            python-six))
+            python-pytz))
     (native-inputs
-      (list python-pbr
-            ;; Tests.
-            python-bandit
-            python-ddt
+     ;; For tests.
+      (list python-ddt
+            python-eventlet
             python-fixtures
-            python-oslo.config
             python-oslotest
-            python-mock
-            python-testrepository
+            python-stestr
             python-testscenarios
             python-testtools))
     (home-page "https://launchpad.net/oslo")