summary refs log tree commit diff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm44
1 files changed, 16 insertions, 28 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 6e78f45e14..756db94144 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages package-management)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages)
   #:use-module (guix build-system meson)
@@ -37,7 +38,7 @@
 (define-public granite
   (package
     (name "granite")
-    (version "5.5.0")
+    (version "6.2.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -46,24 +47,16 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "13qfhq8xndikk6kmybibs6a4ddyp6mhvbsp2yy4qr7aiiyxf7mna"))))
+                "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'disable-icon-cache
-           (lambda _
-             (setenv "DESTDIR" "/")
-             #t)))))
-    (inputs
-     `(("glib" ,glib)
-       ("gtk" ,gtk+)
-       ("libgee" ,libgee)))
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("gobject-introspection" ,gobject-introspection)
-       ("pkg-config" ,pkg-config)
-       ("vala" ,vala)))
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'disable-icon-cache
+                    (lambda _
+                      (setenv "DESTDIR" "/"))))))
+    (inputs (list glib gtk+ libgee))
+    (native-inputs (list gettext-minimal gobject-introspection pkg-config
+                         python vala))
     (home-page "https://github.com/elementary/granite")
     (synopsis "Library that extends GTK with common widgets and utilities")
     (description "Granite is a companion library for GTK+ and GLib.  Among other
@@ -115,7 +108,7 @@ desktop.")
 (define-public sideload
   (package
     (name "sideload")
-    (version "1.1.1")
+    (version "6.0.2")
     (source
      (origin
        (method git-fetch)
@@ -125,27 +118,22 @@ desktop.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0mlc3nm2navzxm8k1rwpbw4w6mv30lmhqybm8jqxd4v8x7my73vq"))))
+         "0abpcawmmv5mgzk2i5n9rlairmjr2v9rg9b8c9g7xa085s496bi9"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
-       #:configure-flags (list (string-append "-Dflatpak="
-                                              (assoc-ref %build-inputs "flatpak")
-                                              "/include"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'install 'set-environment-variables
            (lambda _
              ;; Disable compiling schemas and updating desktop databases
-             (setenv "DESTDIR" "/")
-             #t))
+             (setenv "DESTDIR" "/")))
          (add-after 'install 'install-symlinks
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin/io.elementary.sideload"))
                     (link (string-append out "/bin/sideload")))
-               (symlink bin link)
-               #t))))))
+               (symlink bin link)))))))
     (inputs
      `(("flatpak" ,flatpak)
        ("glib" ,glib)
@@ -153,13 +141,13 @@ desktop.")
        ("gtk" ,gtk+)
        ("hicolor-icon-theme" ,hicolor-icon-theme)
        ("libgee" ,libgee)
+       ("libhandy" ,libhandy)
        ("libostree" ,libostree)
        ("libxml2" ,libxml2)))
     (propagated-inputs
      ;; Sideload needs these in the environment to fetch data securely from
      ;; Flatpak remotes.
-     `(("gnupg" ,gnupg)
-       ("gpgme" ,gpgme)))
+     (list gnupg gpgme))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")