summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm52
1 files changed, 25 insertions, 27 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9ea1ce00a5..f5f301308a 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -352,32 +352,30 @@ applications, there is xclip integration." )
     (license license:gpl3+)))
 
 (define-public ssh-to-age
-  (let* ((commit "37365ce80fa64d8794855ec3c63cc9a071799fea")
-         (revision "0"))
-    (package
-      (name "ssh-to-age")
-      (version (git-version "1.0.2" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/Mic92/ssh-to-age")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1fk2vxa854jnnffcw4q3vm1445jk1ck1v3p4mr9fh04yz06g7d28"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/Mic92/ssh-to-age/cmd/ssh-to-age"
-         #:unpack-path "github.com/Mic92/ssh-to-age"))
-      (inputs (list go-golang-org-x-crypto
-                    go-filippo-io-edwards25519
-                    go-filippo-io-age))
-      (home-page "https://github.com/Mic92/ssh-to-age")
-      (synopsis "Convert SSH @code{ed25519} keys to @code{age} keys.")
-      (description "This package provides a simple command-line tool to
+  (package
+    (name "ssh-to-age")
+    (version "1.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Mic92/ssh-to-age")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09rhga9iqmyyq8pkprydy8y15qhzqvbpgzvs681rcyllf8szrj73"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/Mic92/ssh-to-age/cmd/ssh-to-age"
+       #:unpack-path "github.com/Mic92/ssh-to-age"))
+    (inputs (list go-golang-org-x-crypto
+                  go-filippo-io-edwards25519
+                  go-filippo-io-age))
+    (home-page "https://github.com/Mic92/ssh-to-age")
+    (synopsis "Convert SSH @code{ed25519} keys to @code{age} keys.")
+    (description "This package provides a simple command-line tool to
 convert SSH @code{ed25519} keys to @code{age} keys.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public yapet
   (package
@@ -634,7 +632,7 @@ through the pass command.")
   (package
     (inherit password-store)
     (name "pass-age")
-    (version "1.7.4a0")
+    (version "1.7.4a1")
     (source
      (origin
        (method git-fetch)
@@ -643,7 +641,7 @@ through the pass command.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "17899whffnpqqx9x1nx2b8bfxbxlh1pwlglqa0kznl0cn6sb37ql"))))
+        (base32 "0g8x2zivid18qf1czq1yqychmbdzxzs83rg8a5b392m2rzxlrx08"))))
     (build-system copy-build-system)
     (arguments
      '(#:modules