summary refs log tree commit diff
path: root/gnu/packages/patches/aegis-constness-error.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/aegis-constness-error.patch')
-rw-r--r--gnu/packages/patches/aegis-constness-error.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/patches/aegis-constness-error.patch b/gnu/packages/patches/aegis-constness-error.patch
new file mode 100644
index 0000000000..2a6c9d2c37
--- /dev/null
+++ b/gnu/packages/patches/aegis-constness-error.patch
@@ -0,0 +1,12 @@
+Fixes a fatal constness error with g++ 4.8.2.
+--- aegis-4.24/common/ac/string/memmem.cc	2008-03-14 07:19:27.000000000 +0100
++++ aegis-4.24/common/ac/string/memmem.cc	2014-01-26 11:17:58.000000000 +0100
+@@ -182,7 +182,7 @@
+ 
+     // Use optimizations in memchr when possible.
+     if (needle_len == 1)
+-        return memchr(haystack, *needle, haystack_len);
++        return (void *) memchr(haystack, *needle, haystack_len);
+ 
+     // Minimizing the worst-case complexity:
+     // Let n = haystack_len, m = needle_len.