summary refs log tree commit diff
path: root/gnu/packages/patches/bsdiff-CVE-2014-9862.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/bsdiff-CVE-2014-9862.patch')
-rw-r--r--gnu/packages/patches/bsdiff-CVE-2014-9862.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/bsdiff-CVE-2014-9862.patch b/gnu/packages/patches/bsdiff-CVE-2014-9862.patch
new file mode 100644
index 0000000000..7aab818090
--- /dev/null
+++ b/gnu/packages/patches/bsdiff-CVE-2014-9862.patch
@@ -0,0 +1,15 @@
+diff --git a/bspatch.c b/bspatch.c
+index 8d95633..ab77722 100644
+--- a/bspatch.c
++++ b/bspatch.c
+
+@@ -187,6 +187,10 @@
+ 		};
+ 
+ 		/* Sanity-check */
++		if ((ctrl[0] < 0) || (ctrl[1] < 0))
++			errx(1,"Corrupt patch\n");
++
++		/* Sanity-check */
+ 		if(newpos+ctrl[0]>newsize)
+ 			errx(1,"Corrupt patch\n");