summary refs log tree commit diff
path: root/gnu/packages/patches/clitest-grep-compat.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/clitest-grep-compat.patch')
-rw-r--r--gnu/packages/patches/clitest-grep-compat.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/clitest-grep-compat.patch b/gnu/packages/patches/clitest-grep-compat.patch
new file mode 100644
index 0000000000..8707c35e3e
--- /dev/null
+++ b/gnu/packages/patches/clitest-grep-compat.patch
@@ -0,0 +1,27 @@
+Suppress a warning from grep which causes tests to fail.
+
+Taken from upstream pull request:
+
+  https://github.com/aureliojargas/clitest/pull/54
+
+diff --git a/test/inline-match-egrep.sh b/test/inline-match-egrep.sh
+--- a/test/inline-match-egrep.sh
++++ b/test/inline-match-egrep.sh
+@@ -42,7 +42,7 @@ $ printf ' \t  \t\t   \n'       #=> --egrep ^ 	  		   $
+ # egrep regexes. You'll need to test in your system if that's the
+ # case. I recommend using a literal tab to avoid problems.
+ 
+-$ printf 'may\tfail'            #=> --egrep ^may\tfail$
++$ printf 'may\tfail'            #=> --egrep ^may\\tfail$
+ $ printf 'may\tfail'            #=> --egrep ^may[\t]fail$
+ $ printf 'will\tmatch'          #=> --egrep ^will	match$
+ 
+@@ -51,7 +51,7 @@ $ printf 'will\tmatch'          #=> --egrep ^will	match$
+ # These tests will fail:
+ 
+ $ printf 'will\nfail'           #=> --egrep will.*fail
+-$ printf 'will\nfail'           #=> --egrep will\nfail
++$ printf 'will\nfail'           #=> --egrep will\\nfail
+ 
+ # If one line of a multiline results matches, the test is OK
+