summary refs log tree commit diff
path: root/gnu/packages/patches/cpio-gets-undeclared.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/cpio-gets-undeclared.patch')
-rw-r--r--gnu/packages/patches/cpio-gets-undeclared.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/patches/cpio-gets-undeclared.patch b/gnu/packages/patches/cpio-gets-undeclared.patch
new file mode 100644
index 0000000000..bc34de6455
--- /dev/null
+++ b/gnu/packages/patches/cpio-gets-undeclared.patch
@@ -0,0 +1,45 @@
+This patch is needed to allow builds with newer versions of
+the GNU libc (2.16+).
+
+The upstream fix was:
+
+  commit 66712c23388e93e5c518ebc8515140fa0c807348
+  Author: Eric Blake <eblake@redhat.com>
+  Date:   Thu Mar 29 13:30:41 2012 -0600
+
+      stdio: don't assume gets any more
+
+      Gnulib intentionally does not have a gets module, and now that C11
+      and glibc have dropped it, we should be more proactive about warning
+      any user on a platform that still has a declaration of this dangerous
+      interface.
+
+      * m4/stdio_h.m4 (gl_STDIO_H, gl_STDIO_H_DEFAULTS): Drop gets
+      support.
+      * modules/stdio (Makefile.am): Likewise.
+      * lib/stdio-read.c (gets): Likewise.
+      * tests/test-stdio-c++.cc: Likewise.
+      * m4/warn-on-use.m4 (gl_WARN_ON_USE_PREPARE): Fix comment.
+      * lib/stdio.in.h (gets): Make warning occur in more places.
+      * doc/posix-functions/gets.texi (gets): Update documentation.
+      Reported by Christer Solskogen.
+
+      Signed-off-by: Eric Blake <eblake@redhat.com>
+
+This patch just gets rid of the offending part.
+
+--- cpio-2.11/gnu/stdio.in.h-orig	2012-11-25 22:17:06.000000000 +0400
++++ cpio-2.11/gnu/stdio.in.h		2012-11-25 22:18:36.000000000 +0400
+@@ -135,12 +135,6 @@
+                  "use gnulib module fflush for portable POSIX compliance");
+ #endif
+ 
+-/* It is very rare that the developer ever has full control of stdin,
+-   so any use of gets warrants an unconditional warning.  Assume it is
+-   always declared, since it is required by C89.  */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)