summary refs log tree commit diff
path: root/gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch')
-rw-r--r--gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch b/gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch
new file mode 100644
index 0000000000..88b2e7f25a
--- /dev/null
+++ b/gnu/packages/patches/crypto++-fix-dos-in-asn.1-decoders.patch
@@ -0,0 +1,65 @@
+From 3d9181d7bdd8e491f745dbc9e34bd20b6f6da069 Mon Sep 17 00:00:00 2001
+From: Gergely Nagy <ngg@tresorit.com>
+Date: Wed, 14 Dec 2016 13:19:01 +0100
+Subject: [PATCH] Fix possible DoS in ASN.1 decoders (CVE-2016-9939)
+
+---
+ asn.cpp | 10 ++++++++++
+ asn.h   |  2 ++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/asn.cpp b/asn.cpp
+index 297ff010..2e923ef7 100644
+--- a/asn.cpp
++++ b/asn.cpp
+@@ -123,6 +123,8 @@ size_t BERDecodeOctetString(BufferedTransformation &bt, SecByteBlock &str)
+ 	size_t bc;

+ 	if (!BERLengthDecode(bt, bc))

+ 		BERDecodeError();

++	if (bc > bt.MaxRetrievable())

++		BERDecodeError();

+ 

+ 	str.New(bc);

+ 	if (bc != bt.Get(str, bc))

+@@ -139,6 +141,8 @@ size_t BERDecodeOctetString(BufferedTransformation &bt, BufferedTransformation &
+ 	size_t bc;

+ 	if (!BERLengthDecode(bt, bc))

+ 		BERDecodeError();

++	if (bc > bt.MaxRetrievable())

++		BERDecodeError();

+ 

+ 	bt.TransferTo(str, bc);

+ 	return bc;

+@@ -161,6 +165,8 @@ size_t BERDecodeTextString(BufferedTransformation &bt, std::string &str, byte as
+ 	size_t bc;

+ 	if (!BERLengthDecode(bt, bc))

+ 		BERDecodeError();

++	if (bc > bt.MaxRetrievable())

++		BERDecodeError();

+ 

+ 	SecByteBlock temp(bc);

+ 	if (bc != bt.Get(temp, bc))

+@@ -188,6 +194,10 @@ size_t BERDecodeBitString(BufferedTransformation &bt, SecByteBlock &str, unsigne
+ 	size_t bc;

+ 	if (!BERLengthDecode(bt, bc))

+ 		BERDecodeError();

++	if (bc == 0)

++		BERDecodeError();

++	if (bc > bt.MaxRetrievable())

++		BERDecodeError();

+ 

+ 	byte unused;

+ 	if (!bt.Get(unused))

+diff --git a/asn.h b/asn.h
+index ed9de52c..33f0dd09 100644
+--- a/asn.h
++++ b/asn.h
+@@ -498,6 +498,8 @@ void BERDecodeUnsigned(BufferedTransformation &in, T &w, byte asnTag = INTEGER,
+ 	bool definite = BERLengthDecode(in, bc);

+ 	if (!definite)

+ 		BERDecodeError();

++	if (bc > in.MaxRetrievable())

++		BERDecodeError();

+ 

+ 	SecByteBlock buf(bc);

+