summary refs log tree commit diff
path: root/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/emacs-fix-scheme-indent-function.patch')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index 4b7904ea3b..c5a426802c 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
 
 --- a/lisp/progmodes/scheme.el
 +++ b/lisp/progmodes/scheme.el
-@@ -494,6 +494,12 @@ indentation."
-                         (> (length function) 3)
-                         (string-match "\\`def" function)))
-                (lisp-indent-defform state indent-point))
+@@ -482,6 +482,12 @@
+ 			(> (length function) 3)
+ 			(string-match "\\`def" function)))
+ 	       (lisp-indent-defform state indent-point))
 +              ((and (null method)
 +                    (> (length function) 1)
 +                    ;; The '#' in '#:' seems to get lost, not sure why
 +                    (string-match "\\`:" function))
 +               (let ((lisp-body-indent 1))
 +                 (lisp-indent-defform state indent-point)))
-               ((integerp method)
-                (lisp-indent-specform method state
-                                      indent-point normal-indent))
+ 	      ((integerp method)
+ 	       (lisp-indent-specform method state
+ 				     indent-point normal-indent))