summary refs log tree commit diff
path: root/gnu/packages/patches/esmini-no-clutter-log.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/esmini-no-clutter-log.patch')
-rw-r--r--gnu/packages/patches/esmini-no-clutter-log.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/esmini-no-clutter-log.patch b/gnu/packages/patches/esmini-no-clutter-log.patch
new file mode 100644
index 0000000000..0920244f78
--- /dev/null
+++ b/gnu/packages/patches/esmini-no-clutter-log.patch
@@ -0,0 +1,30 @@
+Don't clutter /tmp with logs.
+
+---
+ EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
+index 56c655dc..2750f5a6 100644
+--- a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
++++ b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
+@@ -1013,14 +1013,8 @@ void Logger::OpenLogfile(std::string filename)
+ 		file_.open(filename.c_str());
+ 		if (file_.fail())
+ 		{
+-			const char* filename_tmp = std::tmpnam(NULL);
+-			printf("Cannot open log file: %s in working directory. Trying system tmp-file: %s\n",
+-				SE_Env::Inst().GetLogFilePath().c_str(), filename_tmp);
+-			file_.open(filename_tmp);
+-			if (file_.fail())
+-			{
+-				printf("Also failed to open log file: %s. Continue without logfile, still logging to console.\n", filename_tmp);
+-			}
++			printf("Cannot open log file: %s in working directory. Continuing without logfile, still logging to console.\n",
++				filename.c_str());
+ 		}
+ 	}
+ #endif
+-- 
+2.38.1
+