summary refs log tree commit diff
path: root/gnu/packages/patches/gdb-python-3.7.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gdb-python-3.7.patch')
-rw-r--r--gnu/packages/patches/gdb-python-3.7.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/patches/gdb-python-3.7.patch b/gnu/packages/patches/gdb-python-3.7.patch
deleted file mode 100644
index c51442c8b2..0000000000
--- a/gnu/packages/patches/gdb-python-3.7.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Fix build failure with Python 3.7 and newer.
-
-Taken from this upstream commit, sans ChangeLog update:
-
-https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=aeab512851bf6ed623d1c6c4305b6ce05e51a10c
-
-diff --git a/gdb/python/python.c b/gdb/python/python.c
-index 1805c90..20fc674 100644
---- a/gdb/python/python.c
-+++ b/gdb/python/python.c
-@@ -1667,6 +1667,17 @@ finalize_python (void *ignore)
-   restore_active_ext_lang (previous_active);
- }
- 
-+#ifdef IS_PY3K
-+/* This is called via the PyImport_AppendInittab mechanism called
-+   during initialization, to make the built-in _gdb module known to
-+   Python.  */
-+PyMODINIT_FUNC
-+init__gdb_module (void)
-+{
-+  return PyModule_Create (&python_GdbModuleDef);
-+}
-+#endif
-+
- static bool
- do_start_initialization ()
- {
-@@ -1707,6 +1718,9 @@ do_start_initialization ()
-      remain alive for the duration of the program's execution, so
-      it is not freed after this call.  */
-   Py_SetProgramName (progname_copy);
-+
-+  /* Define _gdb as a built-in module.  */
-+  PyImport_AppendInittab ("_gdb", init__gdb_module);
- #else
-   Py_SetProgramName (progname.release ());
- #endif
-@@ -1716,9 +1730,7 @@ do_start_initialization ()
-   PyEval_InitThreads ();
- 
- #ifdef IS_PY3K
--  gdb_module = PyModule_Create (&python_GdbModuleDef);
--  /* Add _gdb module to the list of known built-in modules.  */
--  _PyImport_FixupBuiltin (gdb_module, "_gdb");
-+  gdb_module = PyImport_ImportModule ("_gdb");
- #else
-   gdb_module = Py_InitModule ("_gdb", python_GdbMethods);
- #endif
--- 
-2.9.3
-