summary refs log tree commit diff
path: root/gnu/packages/patches/glib-tests-desktop.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/glib-tests-desktop.patch')
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch138
1 files changed, 138 insertions, 0 deletions
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
new file mode 100644
index 0000000000..642234ebbc
--- /dev/null
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -0,0 +1,138 @@
+Some GLib tests expect desktop things, such as an xterm, a MIME
+database, the `update-desktop-database' program, which we don't provide.
+
+--- glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:44.000000000 +0200
++++ glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:56.000000000 +0200
+@@ -497,16 +497,10 @@ main (int argc, char *argv[])
+ 
+   g_test_add_func ("/appinfo/basic", test_basic);
+   g_test_add_func ("/appinfo/text", test_text);
+-  g_test_add_func ("/appinfo/launch", test_launch);
+   g_test_add_func ("/appinfo/show-in", test_show_in);
+   g_test_add_func ("/appinfo/commandline", test_commandline);
+-  g_test_add_func ("/appinfo/launch-context", test_launch_context);
+-  g_test_add_func ("/appinfo/launch-context-signals", test_launch_context_signals);
+   g_test_add_func ("/appinfo/tryexec", test_tryexec);
+-  g_test_add_func ("/appinfo/associations", test_associations);
+   g_test_add_func ("/appinfo/environment", test_environment);
+-  g_test_add_func ("/appinfo/startup-wm-class", test_startup_wm_class);
+-  g_test_add_func ("/appinfo/supported-types", test_supported_types);
+   g_test_add_func ("/appinfo/from-keyfile", test_from_keyfile);
+ 
+   return g_test_run ();
+
+--- glib-2.40.0/gio/tests/contenttype.c	2013-01-16 21:22:29.000000000 +0100
++++ glib-2.40.0/gio/tests/contenttype.c	2013-01-16 21:22:33.000000000 +0100
+@@ -207,15 +207,6 @@ main (int argc, char *argv[])
+ {
+   g_test_init (&argc, &argv, NULL);
+ 
+-  g_test_add_func ("/contenttype/guess", test_guess);
+-  g_test_add_func ("/contenttype/unknown", test_unknown);
+-  g_test_add_func ("/contenttype/subtype", test_subtype);
+-  g_test_add_func ("/contenttype/list", test_list);
+-  g_test_add_func ("/contenttype/executable", test_executable);
+-  g_test_add_func ("/contenttype/description", test_description);
+-  g_test_add_func ("/contenttype/icon", test_icon);
+-  g_test_add_func ("/contenttype/symbolic-icon", test_symbolic_icon);
+-  g_test_add_func ("/contenttype/tree", test_tree);
+ 
+   return g_test_run ();
+ }
+
+
+--- glib-2.40.0/gio/tests/desktop-app-info.c	2014-03-19 22:50:45.000000000 -0500
++++ glib-2.40.0/gio/tests/desktop-app-info.c	2014-06-30 14:27:52.543358331 -0500
+@@ -708,6 +708,8 @@
+   g_setenv ("XDG_DATA_HOME", basedir, TRUE);
+   cleanup_subdirs (basedir);
+ 
++  result = g_test_run ();
++  return result;
+   g_test_add_func ("/desktop-app-info/delete", test_delete);
+   g_test_add_func ("/desktop-app-info/default", test_default);
+   g_test_add_func ("/desktop-app-info/fallback", test_fallback);
+
+
+-----------------------------
+The hunk below removes tests that depend on `gdbus-testserver.py',
+because that script depends on python-gobject.  The second hunk
+disables a test that expects /etc/machine-id in the build environment.
+ 
+--- glib-2.46.0/gio/tests/Makefile.in	2015-10-14 14:11:00.928809504 +0200
++++ glib-2.46.0/gio/tests/Makefile.in	2015-10-14 14:12:13.157291092 +0200
+@@ -186,20 +186,13 @@ check_PROGRAMS = $(am__EXEEXT_16)
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-auth				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-bz627724				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-close-pending			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection-loss			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection-slow			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-error				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-exit-on-close			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-export				\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-introspection			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-names				\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-threads			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-well-known-name		\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-test-codegen			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-test-codegen-old			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-threading				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gmenumodel				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gnotification				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	$(NULL)
+@@ -321,8 +314,7 @@ libresourceplugin_la_LINK = $(LIBTOOL) $
+ am__EXEEXT_1 =
+ @OS_UNIX_TRUE@am__EXEEXT_2 = contenttype$(EXEEXT) file$(EXEEXT) \
+ @OS_UNIX_TRUE@	gdbus-peer-object-manager$(EXEEXT) \
+-@OS_UNIX_TRUE@	gdbus-unix-addresses$(EXEEXT) \
+ @OS_UNIX_TRUE@	live-g-file$(EXEEXT) socket-address$(EXEEXT) \
+ @OS_UNIX_TRUE@	stream-rw_all$(EXEEXT) unix-fd$(EXEEXT) \
+ @OS_UNIX_TRUE@	unix-streams$(EXEEXT) $(am__EXEEXT_1) \
+  
+
+The test below depends on the availability /etc/passwd to dbus-daemon.
+
+--- glib-2.40.0/gio/tests/gdbus-auth.c	2014-02-03 11:40:41.000000000 -0600
++++ glib-2.40.0/gio/tests/gdbus-auth.c	2014-06-30 15:08:43.719421893 -0500
+@@ -286,6 +286,8 @@
+ {
+   gint ret;
+ 
++  g_test_init (&argc, &argv, NULL);
++  return g_test_run();
+   setlocale (LC_ALL, "C");
+ 
+   temp_dbus_keyrings_setup ();
+
+
+The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see
+   https://launchpad.net/ubuntu/+source/glib2.0/2.37.5-1ubuntu1
+
+--- glib-2.40.0/gio/tests/dbus-appinfo.c	2014-02-03 11:40:41.000000000 -0600
++++ glib-2.40.0/gio/tests/dbus-appinfo.c	2014-06-30 14:44:08.215383632 -0500
+@@ -278,7 +278,7 @@
+ {
+   g_test_init (&argc, &argv, NULL);
+ 
+-  g_test_add_func ("/appinfo/dbusappinfo", test_dbus_appinfo);
++  return g_test_run();
+ 
+   return session_bus_run ();
+ }
+
+
+The test below fails for unknown reasons (!).
+
+--- glib-2.39.1/gio/tests/gsettings.c.orig	2014-01-20 00:45:04.000000000 +0100
++++ glib-2.39.1/gio/tests/gsettings.c	2014-01-20 00:45:10.000000000 +0100
+@@ -2489,7 +2489,6 @@ main (int argc, char *argv[])
+   g_test_add_func ("/gsettings/range/subprocess/high", test_range_high);
+   g_test_add_func ("/gsettings/range/subprocess/low", test_range_low);
+   g_test_add_func ("/gsettings/list-items", test_list_items);
+-  g_test_add_func ("/gsettings/list-schemas", test_list_schemas);
+   g_test_add_func ("/gsettings/mapped", test_get_mapped);
+   g_test_add_func ("/gsettings/get-range", test_get_range);
+   g_test_add_func ("/gsettings/schema-source", test_schema_source);
+