summary refs log tree commit diff
path: root/gnu/packages/patches/glibc-CVE-2012-3406.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/glibc-CVE-2012-3406.patch')
-rw-r--r--gnu/packages/patches/glibc-CVE-2012-3406.patch282
1 files changed, 0 insertions, 282 deletions
diff --git a/gnu/packages/patches/glibc-CVE-2012-3406.patch b/gnu/packages/patches/glibc-CVE-2012-3406.patch
deleted file mode 100644
index 9147a2aeee..0000000000
--- a/gnu/packages/patches/glibc-CVE-2012-3406.patch
+++ /dev/null
@@ -1,282 +0,0 @@
-Fix CVE-2012-3406: Stack overflow in vfprintf [BZ #16617]
-
-Note: Here the ChangeLog and NEWS updates are removed from Jeff's
-      patch, since they depend on other earlier commits.
-
-From: Jeff Law <law@redhat.com>
-Date: Mon, 15 Dec 2014 09:09:32 +0000 (+0100)
-Subject: CVE-2012-3406: Stack overflow in vfprintf [BZ #16617]
-X-Git-Url: https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff_plain;h=a3a1f4163c4d0f9a36056c8640661a88674ae8a2
-
-CVE-2012-3406: Stack overflow in vfprintf [BZ #16617]
-
-A larger number of format specifiers coudld cause a stack overflow,
-potentially allowing to bypass _FORTIFY_SOURCE format string
-protection.
-
-(cherry picked from commit a5357b7ce2a2982c5778435704bcdb55ce3667a0)
-(cherry picked from commit ae61fc7b33d9d99d2763c16de8275227dc9748ba)
-
-Conflicts:
-	NEWS
----
-
-diff --git a/stdio-common/Makefile b/stdio-common/Makefile
-index 5f8e534..e5e45b6 100644
---- a/stdio-common/Makefile
-+++ b/stdio-common/Makefile
-@@ -57,7 +57,7 @@ tests := tstscanf test_rdwr test-popen tstgetln test-fseek \
- 	 bug19 bug19a tst-popen2 scanf13 scanf14 scanf15 bug20 bug21 bug22 \
- 	 scanf16 scanf17 tst-setvbuf1 tst-grouping bug23 bug24 \
- 	 bug-vfprintf-nargs tst-long-dbl-fphex tst-fphex-wide tst-sprintf3 \
--	 bug25 tst-printf-round bug26
-+	 bug25 tst-printf-round bug23-2 bug23-3 bug23-4 bug26
- 
- test-srcs = tst-unbputc tst-printf
- 
-diff --git a/stdio-common/bug23-2.c b/stdio-common/bug23-2.c
-new file mode 100644
-index 0000000..9e0cfe6
---- /dev/null
-+++ b/stdio-common/bug23-2.c
-@@ -0,0 +1,70 @@
-+#include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
-+
-+static const char expected[] = "\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55\
-+\n\
-+a\n\
-+abbcd55%%%%%%%%%%%%%%%%%%%%%%%%%%\n";
-+
-+static int
-+do_test (void)
-+{
-+  char *buf = malloc (strlen (expected) + 1);
-+  snprintf (buf, strlen (expected) + 1,
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+	    "%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%\n",
-+	    "a", "b", "c", "d", 5);
-+  return strcmp (buf, expected) != 0;
-+}
-+
-+#define TEST_FUNCTION do_test ()
-+#include "../test-skeleton.c"
-diff --git a/stdio-common/bug23-3.c b/stdio-common/bug23-3.c
-new file mode 100644
-index 0000000..57c8cef
---- /dev/null
-+++ b/stdio-common/bug23-3.c
-@@ -0,0 +1,50 @@
-+#include <stdio.h>
-+#include <string.h>
-+#include <stdlib.h>
-+
-+int
-+do_test (void)
-+{
-+  size_t instances = 16384;
-+#define X0 "\n%1$s\n" "%1$s" "%2$s" "%2$s" "%3$s" "%4$s" "%5$d" "%5$d"
-+  const char *item = "\na\nabbcd55";
-+#define X3 X0 X0 X0 X0 X0 X0 X0 X0
-+#define X6 X3 X3 X3 X3 X3 X3 X3 X3
-+#define X9 X6 X6 X6 X6 X6 X6 X6 X6
-+#define X12 X9 X9 X9 X9 X9 X9 X9 X9
-+#define X14 X12 X12 X12 X12
-+#define TRAILER "%%%%%%%%%%%%%%%%%%%%%%%%%%"
-+#define TRAILER2 TRAILER TRAILER
-+  size_t length = instances * strlen (item) + strlen (TRAILER) + 1;
-+
-+  char *buf = malloc (length + 1);
-+  snprintf (buf, length + 1,
-+	    X14 TRAILER2 "\n",
-+	    "a", "b", "c", "d", 5);
-+
-+  const char *p = buf;
-+  size_t i;
-+  for (i = 0; i < instances; ++i)
-+    {
-+      const char *expected;
-+      for (expected = item; *expected; ++expected)
-+	{
-+	  if (*p != *expected)
-+	    {
-+	      printf ("mismatch at offset %zu (%zu): expected %d, got %d\n",
-+		      (size_t) (p - buf), i, *expected & 0xFF, *p & 0xFF);
-+	      return 1;
-+	    }
-+	  ++p;
-+	}
-+    }
-+  if (strcmp (p, TRAILER "\n") != 0)
-+    {
-+      printf ("mismatch at trailer: [%s]\n", p);
-+      return 1;
-+    }
-+  free (buf);
-+  return 0;
-+}
-+#define TEST_FUNCTION do_test ()
-+#include "../test-skeleton.c"
-diff --git a/stdio-common/bug23-4.c b/stdio-common/bug23-4.c
-new file mode 100644
-index 0000000..a478564
---- /dev/null
-+++ b/stdio-common/bug23-4.c
-@@ -0,0 +1,31 @@
-+#include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <sys/resource.h>
-+
-+#define LIMIT 1000000
-+
-+int
-+main (void)
-+{
-+  struct rlimit lim;
-+  getrlimit (RLIMIT_STACK, &lim);
-+  lim.rlim_cur = 1048576;
-+  setrlimit (RLIMIT_STACK, &lim);
-+  char *fmtstr = malloc (4 * LIMIT + 1);
-+  if (fmtstr == NULL)
-+    abort ();
-+  char *output = malloc (LIMIT + 1);
-+  if (output == NULL)
-+    abort ();
-+  for (size_t i = 0; i < LIMIT; i++)
-+    memcpy (fmtstr + 4 * i, "%1$d", 4);
-+  fmtstr[4 * LIMIT] = '\0';
-+  int ret = snprintf (output, LIMIT + 1, fmtstr, 0);
-+  if (ret != LIMIT)
-+    abort ();
-+  for (size_t i = 0; i < LIMIT; i++)
-+    if (output[i] != '0')
-+      abort ();
-+  return 0;
-+}
-diff --git a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
-index c4ff833..429a3d1 100644
---- a/stdio-common/vfprintf.c
-+++ b/stdio-common/vfprintf.c
-@@ -263,6 +263,12 @@ vfprintf (FILE *s, const CHAR_T *format, va_list ap)
-   /* For the argument descriptions, which may be allocated on the heap.  */
-   void *args_malloced = NULL;
- 
-+  /* For positional argument handling.  */
-+  struct printf_spec *specs;
-+
-+  /* Track if we malloced the SPECS array and thus must free it.  */
-+  bool specs_malloced = false;
-+
-   /* This table maps a character into a number representing a
-      class.  In each step there is a destination label for each
-      class.  */
-@@ -1679,8 +1685,8 @@ do_positional:
-     size_t nspecs = 0;
-     /* A more or less arbitrary start value.  */
-     size_t nspecs_size = 32 * sizeof (struct printf_spec);
--    struct printf_spec *specs = alloca (nspecs_size);
- 
-+    specs = alloca (nspecs_size);
-     /* The number of arguments the format string requests.  This will
-        determine the size of the array needed to store the argument
-        attributes.  */
-@@ -1721,11 +1727,39 @@ do_positional:
- 	if (nspecs * sizeof (*specs) >= nspecs_size)
- 	  {
- 	    /* Extend the array of format specifiers.  */
-+	    if (nspecs_size * 2 < nspecs_size)
-+	      {
-+		__set_errno (ENOMEM);
-+		done = -1;
-+		goto all_done;
-+	      }
- 	    struct printf_spec *old = specs;
--	    specs = extend_alloca (specs, nspecs_size, 2 * nspecs_size);
-+	    if (__libc_use_alloca (2 * nspecs_size))
-+	      specs = extend_alloca (specs, nspecs_size, 2 * nspecs_size);
-+	    else
-+	      {
-+		nspecs_size *= 2;
-+		specs = malloc (nspecs_size);
-+		if (specs == NULL)
-+		  {
-+		    __set_errno (ENOMEM);
-+		    specs = old;
-+		    done = -1;
-+		    goto all_done;
-+		  }
-+	      }
- 
- 	    /* Copy the old array's elements to the new space.  */
- 	    memmove (specs, old, nspecs * sizeof (*specs));
-+
-+	    /* If we had previously malloc'd space for SPECS, then
-+	       release it after the copy is complete.  */
-+	    if (specs_malloced)
-+	      free (old);
-+
-+	    /* Now set SPECS_MALLOCED if needed.  */
-+	    if (!__libc_use_alloca (nspecs_size))
-+	      specs_malloced = true;
- 	  }
- 
- 	/* Parse the format specifier.  */
-@@ -2046,6 +2080,8 @@ do_positional:
-   }
- 
- all_done:
-+  if (specs_malloced)
-+    free (specs);
-   if (__glibc_unlikely (args_malloced != NULL))
-     free (args_malloced);
-   if (__glibc_unlikely (workstart != NULL))