summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch b/gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch
new file mode 100644
index 0000000000..6a16b07497
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch
@@ -0,0 +1,41 @@
+From 544bc596ac085ee1adc0b3d7ea793bc37d747ce2 Mon Sep 17 00:00:00 2001
+From: Carsten Book <cbook@mozilla.com>
+Date: Mon, 19 Oct 2015 08:49:46 +0200
+Subject: [PATCH] Bug 1213979 - h2 paket formats. r=hurley, a=al
+
+--HG--
+extra : source : 551a28778624d4aff67b698952b1b3e011fc21f7
+extra : intermediate-source : ed67ac61d1c0e4a23888abe3abd3f4636757e038
+---
+ netwerk/protocol/http/Http2Stream.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/netwerk/protocol/http/Http2Stream.cpp b/netwerk/protocol/http/Http2Stream.cpp
+index 38fc025..340eccf 100644
+--- a/netwerk/protocol/http/Http2Stream.cpp
++++ b/netwerk/protocol/http/Http2Stream.cpp
+@@ -629,9 +629,9 @@ Http2Stream::AdjustInitialWindow()
+     return;
+   }
+ 
+-  uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
+   EnsureBuffer(mTxInlineFrame, mTxInlineFrameUsed + Http2Session::kFrameHeaderBytes + 4,
+                mTxInlineFrameUsed, mTxInlineFrameSize);
++  uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
+   mTxInlineFrameUsed += Http2Session::kFrameHeaderBytes + 4;
+ 
+   mSession->CreateFrameHeader(packet, 4,
+@@ -661,9 +661,9 @@ Http2Stream::AdjustPushedPriority()
+   if (mPushSource->RecvdFin() || mPushSource->RecvdReset())
+     return;
+ 
+-  uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
+   EnsureBuffer(mTxInlineFrame, mTxInlineFrameUsed + Http2Session::kFrameHeaderBytes + 5,
+                mTxInlineFrameUsed, mTxInlineFrameSize);
++  uint8_t *packet = mTxInlineFrame.get() + mTxInlineFrameUsed;
+   mTxInlineFrameUsed += Http2Session::kFrameHeaderBytes + 5;
+ 
+   mSession->CreateFrameHeader(packet, 5,
+-- 
+2.5.0
+