summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch b/gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch
deleted file mode 100644
index fa1804eb82..0000000000
--- a/gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/fc78180165a8
-Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2016-01/
-Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1223670
-
-# HG changeset patch
-# User Karl Tomlinson <karlt+@karlt.net>
-# Date 1449117514 -46800
-# Node ID fc78180165a8262c80bbb722ed99b2e0c27b02d0
-# Parent  925215cae26f9c0ccff07ef403a5b3194a4c45c4
-bug 1223670 assert that connected streams have the same graph r=padenot a=abillings
-
-diff --git a/dom/media/MediaStreamGraph.cpp b/dom/media/MediaStreamGraph.cpp
---- a/dom/media/MediaStreamGraph.cpp
-+++ b/dom/media/MediaStreamGraph.cpp
-@@ -2696,16 +2696,17 @@ ProcessedMediaStream::AllocateInputPort(
-       unused << mPort.forget();
-     }
-     virtual void RunDuringShutdown()
-     {
-       Run();
-     }
-     nsRefPtr<MediaInputPort> mPort;
-   };
-+  MOZ_ASSERT(aStream->GraphImpl() == GraphImpl());
-   nsRefPtr<MediaInputPort> port = new MediaInputPort(aStream, this, aFlags,
-                                                      aInputNumber, aOutputNumber);
-   port->SetGraphImpl(GraphImpl());
-   GraphImpl()->AppendMessage(new Message(port));
-   return port.forget();
- }
- 
- void
-