summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch b/gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch
new file mode 100644
index 0000000000..3e62c9c5f1
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch
@@ -0,0 +1,51 @@
+Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/4f6e81673f69
+Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2016-01/
+Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1223670
+
+# HG changeset patch
+# User Karl Tomlinson <karlt+@karlt.net>
+# Date 1449145091 -46800
+# Node ID 4f6e81673f6938719c86516606f2fda493e8c23c
+# Parent  6d43ff33bd552b8f7a34e4105cf5bcc0a8c8ea8c
+bug 1223670 make SetMozAudioChannelType() private because the type will not change after construction r=baku a=abillings
+
+diff --git a/dom/media/webaudio/AudioDestinationNode.h b/dom/media/webaudio/AudioDestinationNode.h
+--- a/dom/media/webaudio/AudioDestinationNode.h
++++ b/dom/media/webaudio/AudioDestinationNode.h
+@@ -57,17 +57,16 @@ public:
+   void StartRendering(Promise* aPromise);
+ 
+   void OfflineShutdown();
+ 
+   // nsIDOMEventListener - by proxy
+   NS_IMETHOD HandleEvent(nsIDOMEvent* aEvent) override;
+ 
+   AudioChannel MozAudioChannelType() const;
+-  void SetMozAudioChannelType(AudioChannel aValue, ErrorResult& aRv);
+ 
+   virtual void NotifyMainThreadStateChanged() override;
+   void FireOfflineCompletionEvent();
+ 
+   // An amount that should be added to the MediaStream's current time to
+   // get the AudioContext.currentTime.
+   double ExtraCurrentTime();
+ 
+@@ -86,16 +85,17 @@ public:
+ 
+   void InputMuted(bool aInputMuted);
+   void ResolvePromise(AudioBuffer* aRenderedBuffer);
+ 
+ protected:
+   virtual ~AudioDestinationNode();
+ 
+ private:
++  void SetMozAudioChannelType(AudioChannel aValue, ErrorResult& aRv);
+   bool CheckAudioChannelPermissions(AudioChannel aValue);
+ 
+   void SetCanPlay(bool aCanPlay);
+ 
+   void NotifyStableState();
+   void ScheduleStableStateNotification();
+ 
+   SelfReference<AudioDestinationNode> mOfflineRenderingRef;
+