summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch b/gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch
new file mode 100644
index 0000000000..fab003158c
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch
@@ -0,0 +1,18 @@
+  changeset:   312051:9ec3d076fbee
+  parents:     312049:e0a272d5e162 
+  user:        Eric Faust <efaustbmo@gmail.com>
+  Date:        Wed May 04 15:54:43 2016 -0700
+  summary:     Bug 1269729 - Handle another OOM case on ARM. (r=jolesen) a=ritu
+
+diff -r e0a272d5e162 -r 9ec3d076fbee js/src/jit/arm/CodeGenerator-arm.cpp
+--- a/js/src/jit/arm/CodeGenerator-arm.cpp	Tue May 17 08:26:37 2016 -0400
++++ b/js/src/jit/arm/CodeGenerator-arm.cpp	Wed May 04 15:54:43 2016 -0700
+@@ -1116,7 +1116,7 @@
+     for (int32_t i = 0; i < cases; i++) {
+         CodeLabel cl;
+         masm.writeCodePointer(cl.dest());
+-        ool->addCodeLabel(cl);
++        masm.propagateOOM(ool->addCodeLabel(cl));
+     }
+     addOutOfLineCode(ool, mir);
+ }