summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch b/gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch
new file mode 100644
index 0000000000..143b02fa58
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch
@@ -0,0 +1,17 @@
+  changeset:   312067:380ddd689680
+  user:        Timothy Nikkel <tnikkel@gmail.com>
+  Date:        Tue May 10 22:58:26 2016 -0500
+  summary:     Bug 1261752. Part 1. r=mats a=ritu
+
+diff -r 02df988a56ae -r 380ddd689680 view/nsViewManager.cpp
+--- a/view/nsViewManager.cpp	Thu May 26 10:06:15 2016 -0700
++++ b/view/nsViewManager.cpp	Tue May 10 22:58:26 2016 -0500
+@@ -416,7 +416,7 @@
+   if (aWidget->NeedsPaint()) {
+     // If an ancestor widget was hidden and then shown, we could
+     // have a delayed resize to handle.
+-    for (nsViewManager *vm = this; vm;
++    for (RefPtr<nsViewManager> vm = this; vm;
+          vm = vm->mRootView->GetParent()
+            ? vm->mRootView->GetParent()->GetViewManager()
+            : nullptr) {