summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2016-2821.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2016-2821.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2016-2821.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2016-2821.patch b/gnu/packages/patches/icecat-CVE-2016-2821.patch
new file mode 100644
index 0000000000..8255d60009
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2016-2821.patch
@@ -0,0 +1,16 @@
+  changeset:   312045:7aea44059251
+  user:        Olli Pettay <Olli.Pettay@helsinki.fi>
+  Date:        Fri May 13 20:10:22 2016 +0300
+  summary:     Bug 1271460, don't leak editor created element objects, r=ehsan a=ritu
+
+diff -r 09418166fd77 -r 7aea44059251 editor/libeditor/nsHTMLInlineTableEditor.cpp
+--- a/editor/libeditor/nsHTMLInlineTableEditor.cpp	Wed May 11 10:14:45 2016 +0100
++++ b/editor/libeditor/nsHTMLInlineTableEditor.cpp	Fri May 13 20:10:22 2016 +0300
+@@ -109,7 +109,6 @@
+ 
+   // get the root content node.
+   nsCOMPtr<nsIContent> bodyContent = GetRoot();
+-  NS_ENSURE_TRUE(bodyContent, NS_ERROR_FAILURE);
+ 
+   DeleteRefToAnonymousNode(mAddColumnBeforeButton, bodyContent, ps);
+   mAddColumnBeforeButton = nullptr;