summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-bug-1146335-pt2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-bug-1146335-pt2.patch')
-rw-r--r--gnu/packages/patches/icecat-bug-1146335-pt2.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/patches/icecat-bug-1146335-pt2.patch b/gnu/packages/patches/icecat-bug-1146335-pt2.patch
deleted file mode 100644
index 240e0cfc66..0000000000
--- a/gnu/packages/patches/icecat-bug-1146335-pt2.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/8bfaa27698ca
-Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1146335
-
-# HG changeset patch
-# User Seth Fowler <mark.seth.fowler@gmail.com>
-# Date 1428627143 25200
-# Node ID 8bfaa27698ca0720d5c9f3910ab7148b38db0625
-# Parent  9d14787bd10e6f3013263a2cae0bcc78bebde1db
-Bug 1146335 (Part 2) - Fix an off-by-one error in image::Downscaler. r=tn a=lizzard
-
-diff --git a/image/src/Downscaler.cpp b/image/src/Downscaler.cpp
---- a/image/src/Downscaler.cpp
-+++ b/image/src/Downscaler.cpp
-@@ -160,20 +160,26 @@ Downscaler::CommitRow()
-   int32_t inLineToRead = filterOffset + mLinesInBuffer;
-   MOZ_ASSERT(mCurrentInLine <= inLineToRead, "Reading past end of input");
-   if (mCurrentInLine == inLineToRead) {
-     skia::ConvolveHorizontally(mRowBuffer.get(), *mXFilter,
-                                mWindow[mLinesInBuffer++], mHasAlpha,
-                                /* use_sse2 = */ true);
-   }
- 
--  while (mLinesInBuffer == filterLength &&
--         mCurrentOutLine < mTargetSize.height) {
-+  MOZ_ASSERT(mCurrentOutLine < mTargetSize.height,
-+             "Writing past end of output");
-+
-+  while (mLinesInBuffer == filterLength) {
-     DownscaleInputLine();
- 
-+    if (mCurrentOutLine == mTargetSize.height) {
-+      break;  // We're done.
-+    }
-+
-     GetFilterOffsetAndLength(mYFilter, mCurrentOutLine,
-                              &filterOffset, &filterLength);
-   }
- 
-   mCurrentInLine += 1;
- }
- 
- bool
-