summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch')
-rw-r--r--gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch b/gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch
index 94c211b797..776b5f3d9a 100644
--- a/gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch
+++ b/gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch
@@ -4,8 +4,8 @@ Based on:
   https://svnweb.freebsd.org/ports/head/www/firefox-esr/files/patch-bug847568?revision=472833&view=co
 Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
 
---- icecat-60.2.0/config/system-headers.mozbuild
-+++ icecat-60.2.0/config/system-headers.mozbuild
+--- icecat-60.5.0/config/system-headers.mozbuild
++++ icecat-60.5.0/config/system-headers.mozbuild
 @@ -1311,6 +1311,19 @@
          'pixman.h',
      ]
@@ -26,8 +26,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  if CONFIG['MOZ_SYSTEM_LIBVPX']:
      system_headers += [
          'vpx_mem/vpx_mem.h',
---- icecat-60.2.0/dom/base/moz.build
-+++ icecat-60.2.0/dom/base/moz.build
+--- icecat-60.5.0/dom/base/moz.build
++++ icecat-60.5.0/dom/base/moz.build
 @@ -474,6 +474,9 @@
  if CONFIG['MOZ_X11']:
      CXXFLAGS += CONFIG['TK_CFLAGS']
@@ -38,8 +38,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  GENERATED_FILES += [
      'PropertyUseCounterMap.inc',
      'UseCounterList.h',
---- icecat-60.2.0/gfx/graphite2/moz-gr-update.sh
-+++ icecat-60.2.0/gfx/graphite2/moz-gr-update.sh
+--- icecat-60.5.0/gfx/graphite2/moz-gr-update.sh
++++ icecat-60.5.0/gfx/graphite2/moz-gr-update.sh
 @@ -1,6 +1,7 @@
  #!/bin/bash
  
@@ -66,8 +66,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  
  echo
  echo If gfx/graphite2/src/files.mk has changed, please make corresponding
---- icecat-60.2.0/gfx/moz.build
-+++ icecat-60.2.0/gfx/moz.build
+--- icecat-60.5.0/gfx/moz.build
++++ icecat-60.5.0/gfx/moz.build
 @@ -10,6 +10,12 @@ with Files('**'):
  if CONFIG['MOZ_TREE_CAIRO']:
      DIRS += ['cairo']
@@ -90,8 +90,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
      'ots/src',
      'thebes',
      'ipc',
---- icecat-60.2.0/gfx/skia/generate_mozbuild.py
-+++ icecat-60.2.0/gfx/skia/generate_mozbuild.py
+--- icecat-60.5.0/gfx/skia/generate_mozbuild.py
++++ icecat-60.5.0/gfx/skia/generate_mozbuild.py
 @@ -148,6 +148,9 @@
          '-Wno-unused-private-field',
      ]
@@ -102,8 +102,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('gtk3', 'android'):
      CXXFLAGS += CONFIG['MOZ_CAIRO_CFLAGS']
      CXXFLAGS += CONFIG['CAIRO_FT_CFLAGS']
---- icecat-60.2.0/gfx/skia/moz.build
-+++ icecat-60.2.0/gfx/skia/moz.build
+--- icecat-60.5.0/gfx/skia/moz.build
++++ icecat-60.5.0/gfx/skia/moz.build
 @@ -822,6 +822,9 @@
          '-Wno-unused-private-field',
      ]
@@ -114,8 +114,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('gtk3', 'android'):
      CXXFLAGS += CONFIG['MOZ_CAIRO_CFLAGS']
      CXXFLAGS += CONFIG['CAIRO_FT_CFLAGS']
---- icecat-60.2.0/gfx/thebes/moz.build
-+++ icecat-60.2.0/gfx/thebes/moz.build
+--- icecat-60.5.0/gfx/thebes/moz.build
++++ icecat-60.5.0/gfx/thebes/moz.build
 @@ -272,7 +272,13 @@
  
  LOCAL_INCLUDES += CONFIG['SKIA_INCLUDES']
@@ -131,8 +131,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  
  if CONFIG['CC_TYPE'] == 'clang':
      # Suppress warnings from Skia header files.
---- icecat-60.2.0/intl/unicharutil/util/moz.build
-+++ icecat-60.2.0/intl/unicharutil/util/moz.build
+--- icecat-60.5.0/intl/unicharutil/util/moz.build
++++ icecat-60.5.0/intl/unicharutil/util/moz.build
 @@ -25,4 +25,7 @@ UNIFIED_SOURCES += [
      'nsUnicodeProperties.cpp',
  ]
@@ -141,8 +141,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
 +    CXXFLAGS += CONFIG['MOZ_HARFBUZZ_CFLAGS']
 +
  FINAL_LIBRARY = 'xul'
---- icecat-60.2.0/netwerk/dns/moz.build
-+++ icecat-60.2.0/netwerk/dns/moz.build
+--- icecat-60.5.0/netwerk/dns/moz.build
++++ icecat-60.5.0/netwerk/dns/moz.build
 @@ -76,3 +76,6 @@
  
  if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
@@ -150,9 +150,9 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
 +
 +if CONFIG['MOZ_SYSTEM_HARFBUZZ']:
 +    CXXFLAGS += CONFIG['MOZ_HARFBUZZ_CFLAGS']
---- icecat-60.2.0/old-configure.in
-+++ icecat-60.2.0/old-configure.in
-@@ -3995,6 +3995,27 @@
+--- icecat-60.5.0/old-configure.in
++++ icecat-60.5.0/old-configure.in
+@@ -3971,6 +3971,27 @@
  AC_SUBST(MOZ_LINUX_32_SSE2_STARTUP_ERROR)
  
  dnl ========================================================
@@ -180,8 +180,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  dnl Check for pixman and cairo
  dnl ========================================================
  
---- icecat-60.2.0/toolkit/library/moz.build
-+++ icecat-60.2.0/toolkit/library/moz.build
+--- icecat-60.5.0/toolkit/library/moz.build
++++ icecat-60.5.0/toolkit/library/moz.build
 @@ -235,6 +235,12 @@
  if CONFIG['MOZ_SYSTEM_PNG']:
      OS_LIBS += CONFIG['MOZ_PNG_LIBS']
@@ -195,8 +195,8 @@ Modified for use with patch -p1, and to apply cleanly to GNU IceCat.
  if CONFIG['MOZ_SYSTEM_HUNSPELL']:
      OS_LIBS += CONFIG['MOZ_HUNSPELL_LIBS']
  
---- icecat-60.2.0/toolkit/moz.configure
-+++ icecat-60.2.0/toolkit/moz.configure
+--- icecat-60.5.0/toolkit/moz.configure
++++ icecat-60.5.0/toolkit/moz.configure
 @@ -1051,6 +1051,26 @@
  add_old_configure_assignment('FT2_CFLAGS',
                               ft2_info.cflags)