summary refs log tree commit diff
path: root/gnu/packages/patches/jami-unbundle-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/jami-unbundle-dependencies.patch')
-rw-r--r--gnu/packages/patches/jami-unbundle-dependencies.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/patches/jami-unbundle-dependencies.patch b/gnu/packages/patches/jami-unbundle-dependencies.patch
index dab82b26cb..2732087daf 100644
--- a/gnu/packages/patches/jami-unbundle-dependencies.patch
+++ b/gnu/packages/patches/jami-unbundle-dependencies.patch
@@ -16,13 +16,14 @@ Change-Id: I637959fefce6a21b0ee73a793acb6c3c42dcdce0
  1 file changed, 25 insertions(+), 11 deletions(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 38e7a4e2..3f1bd599 100644
+index e802357f..6d2dccfb 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -545,19 +545,33 @@ add_subdirectory(3rdparty/SortFilterProxyModel)
+@@ -600,20 +600,34 @@ add_subdirectory(3rdparty/SortFilterProxyModel)
  set(SFPM_OBJECTS $<TARGET_OBJECTS:SortFilterProxyModel>)
  
  # md4c
+-set(BUILD_MD2HTML_EXECUTABLE OFF CACHE BOOL "Don't build md2html executable" FORCE)
 -set(BUILD_SHARED_LIBS OFF CACHE BOOL "Don't build shared md4c library" FORCE)
 -add_subdirectory(3rdparty/md4c EXCLUDE_FROM_ALL)
 -list(APPEND CLIENT_LINK_DIRS ${MD4C_BINARY_DIR}/src)
@@ -34,6 +35,7 @@ index 38e7a4e2..3f1bd599 100644
 +  list(APPEND CLIENT_LIBS md4c::md4c-html)
 +else()
 +  message("Using bundled md4c-html library")
++  set(BUILD_MD2HTML_EXECUTABLE OFF CACHE BOOL "Don't build md2html executable" FORCE)
 +  set(BUILD_SHARED_LIBS OFF CACHE BOOL "Don't build shared md4c library" FORCE)
 +  add_subdirectory(3rdparty/md4c EXCLUDE_FROM_ALL)
 +  list(APPEND CLIENT_LINK_DIRS ${MD4C_BINARY_DIR}/src)