summary refs log tree commit diff
path: root/gnu/packages/patches/libjxr-fix-typos.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libjxr-fix-typos.patch')
-rw-r--r--gnu/packages/patches/libjxr-fix-typos.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/libjxr-fix-typos.patch b/gnu/packages/patches/libjxr-fix-typos.patch
new file mode 100644
index 0000000000..819db34900
--- /dev/null
+++ b/gnu/packages/patches/libjxr-fix-typos.patch
@@ -0,0 +1,29 @@
+Description: Fix typos and remove some warnings

+Author: Mathieu Malaterre <malat@debian.org>

+

+Index: jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c

+===================================================================

+--- jxrlib-1.1.orig/jxrencoderdecoder/JxrEncApp.c

++++ jxrlib-1.1/jxrencoderdecoder/JxrEncApp.c

+@@ -578,7 +578,7 @@ main(int argc, char* argv[])

+ 

+     //================================

+     Call(PKCreateCodecFactory(&pCodecFactory, WMP_SDK_VERSION));

+-    Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, &pEncoder));

++    Call(pCodecFactory->CreateCodec(&IID_PKImageWmpEncode, (void**)&pEncoder));

+ 

+     //----------------------------------------------------------------

+     Call(PKCreateTestFactory(&pTestFactory, WMP_SDK_VERSION));

+Index: jxrlib-1.1/jxrgluelib/JXRMeta.h

+===================================================================

+--- jxrlib-1.1.orig/jxrgluelib/JXRMeta.h

++++ jxrlib-1.1/jxrgluelib/JXRMeta.h

+@@ -34,7 +34,7 @@

+ 

+ #ifndef UNREFERENCED_PARAMETER

+ #define UNREFERENCED_PARAMETER(P) { (P) = (P); }

+-#endif UNREFERENCED_PARAMETER

++#endif /*UNREFERENCED_PARAMETER*/

+ 

+ //================================================================

+ // Container