summary refs log tree commit diff
path: root/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch')
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch b/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
deleted file mode 100644
index 2c64d06fbe..0000000000
--- a/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Avoid ordered comparison of pointer with integer to prevent compile error
-with GCC 11.
-
-diff --git a/src/hotspot/os/linux/os_linux.cpp b/src/hotspot/os/linux/os_linux.cpp
---- a/src/hotspot/os/linux/os_linux.cpp
-+++ b/src/hotspot/os/linux/os_linux.cpp
-@@ -2155,7 +2155,7 @@ void os::Linux::print_container_info(outputStream* st) {
-     }
- 
-     p = OSContainer::cpu_cpuset_memory_nodes();
--    if (p < 0)
-+    if (p == NULL)
-       st->print("cpu_memory_nodes() failed\n");
-     else {
-       st->print("cpu_memory_nodes: %s\n", p);