summary refs log tree commit diff
path: root/gnu/packages/patches/owncloud-disable-updatecheck.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/owncloud-disable-updatecheck.patch')
-rw-r--r--gnu/packages/patches/owncloud-disable-updatecheck.patch38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/patches/owncloud-disable-updatecheck.patch b/gnu/packages/patches/owncloud-disable-updatecheck.patch
index 69a984a104..3469398eb4 100644
--- a/gnu/packages/patches/owncloud-disable-updatecheck.patch
+++ b/gnu/packages/patches/owncloud-disable-updatecheck.patch
@@ -10,14 +10,14 @@ Last-Update: 2014-02-17
 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
 --- a/src/libsync/configfile.cpp
 +++ b/src/libsync/configfile.cpp
-@@ -417,11 +417,14 @@ bool ConfigFile::skipUpdateCheck( const
-     QString con( connection );
-     if( connection.isEmpty() ) con = defaultConnection();
-
+@@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q
+     if (connection.isEmpty())
+         con = defaultConnection();
+ 
 -    QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
 +    QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
      fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
-
+ 
      QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
 -    return value.toBool();
 +    if ( !value.toBool() )
@@ -25,25 +25,25 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
 +
 +    return true;
  }
-
- void ConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
+ 
+ void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)
 --- a/src/gui/generalsettings.cpp
 +++ b/src/gui/generalsettings.cpp
-@@ -124,6 +124,7 @@ void GeneralSettings::loadMiscSettings()
-
+@@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings()
+ 
  void GeneralSettings::slotUpdateInfo()
  {
 +    /* Guix doesn't want an autoupdater
-     // Note: the sparkle-updater is not an OCUpdater
-     OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
-     if (ConfigFile().skipUpdateCheck()) {
-@@ -140,6 +141,9 @@ void GeneralSettings::slotUpdateInfo()
-         // can't have those infos from sparkle currently
-         _ui->updatesGroupBox->setVisible(false);
-     }
+     if (ConfigFile().skipUpdateCheck() || !Updater::instance()) {
+         // updater disabled on compile
+         _ui->updaterWidget->setVisible(false);
+@@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo()
+     _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0);
+     connect(_ui->updateChannel, static_cast<void (QComboBox::*)(int)>(&QComboBox::currentIndexChanged),
+         this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection);
 +    */
 +    //hide the update group box for Guix.
-+    _ui->updatesGroupBox->setVisible(false);
++    _ui->updaterWidget->setVisible(false);
  }
-
- void GeneralSettings::saveMiscSettings()
+ 
+ void GeneralSettings::slotUpdateChannelChanged(int index)