summary refs log tree commit diff
path: root/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python2-subprocess32-disable-input-test.patch')
-rw-r--r--gnu/packages/patches/python2-subprocess32-disable-input-test.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch b/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
deleted file mode 100644
index 05b4eef1ba..0000000000
--- a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This test tries to send a KeyboardInterrupt, which does
-not work in the build environment.
-
---- a/test_subprocess32.py	2017-03-06 22:21:49.334045485 +0100
-+++ b/test_subprocess32.py	2017-03-06 22:22:02.490439949 +0100
-@@ -1299,12 +1299,6 @@
-         getattr(p, method)(*args)
-         return p
- 
--    def test_send_signal(self):
--        p = self._kill_process('send_signal', signal.SIGINT)
--        _, stderr = p.communicate()
--        self.assertIn('KeyboardInterrupt', stderr)
--        self.assertNotEqual(p.wait(), 0)
--
-     def test_kill(self):
-         p = self._kill_process('kill')
-         _, stderr = p.communicate()