summary refs log tree commit diff
path: root/gnu/packages/patches/scotch-test-threading.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/scotch-test-threading.patch')
-rw-r--r--gnu/packages/patches/scotch-test-threading.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/patches/scotch-test-threading.patch b/gnu/packages/patches/scotch-test-threading.patch
deleted file mode 100644
index de8cc49c41..0000000000
--- a/gnu/packages/patches/scotch-test-threading.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix this test so that it succeeds when the library is not compiled with
-SCOTCH_PTHREAD.
-
---- scotch_6.0.4/src/check/test_common_thread.c	2014-09-28 11:39:59.000000000 -0500
-+++ scotch_6.0.4/src/check/test_common_thread.c	2015-01-10 00:52:00.076229542 -0600
-@@ -175,14 +175,14 @@
- char *              argv[])
- {
-   TestThreadGroup       groudat;
--#if ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD))
-+#if ((defined COMMON_PTHREAD) && (defined SCOTCH_PTHREAD))
-   TestThread * restrict thrdtab;
-   int                   thrdnbr;
- #endif /* ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD)) */
- 
-   SCOTCH_errorProg (argv[0]);
- 
--#if ((defined COMMON_PTHREAD) || (defined SCOTCH_PTHREAD))
-+#if ((defined COMMON_PTHREAD) && (defined SCOTCH_PTHREAD))
-   thrdnbr = SCOTCH_PTHREAD_NUMBER;
- 
-   groudat.redusum = COMPVAL (thrdnbr);