summary refs log tree commit diff
path: root/gnu/packages/patches/sdl-pango-fillrect_crash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/sdl-pango-fillrect_crash.patch')
-rw-r--r--gnu/packages/patches/sdl-pango-fillrect_crash.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/sdl-pango-fillrect_crash.patch b/gnu/packages/patches/sdl-pango-fillrect_crash.patch
new file mode 100644
index 0000000000..7a41bbf2fe
--- /dev/null
+++ b/gnu/packages/patches/sdl-pango-fillrect_crash.patch
@@ -0,0 +1,15 @@
+Index: SDL_Pango-0.1.2/src/SDL_Pango.c
+===================================================================
+--- SDL_Pango-0.1.2.orig/src/SDL_Pango.c	2007-09-18 15:56:12.406223540 +0200
++++ SDL_Pango-0.1.2/src/SDL_Pango.c	2007-09-18 15:57:27.986530616 +0200
+@@ -932,7 +932,9 @@
+     width = PANGO_PIXELS (logical_rect.width);

+     height = PANGO_PIXELS (logical_rect.height);

+ 

+-    SDL_FillRect(surface, NULL, SDL_MapRGBA(surface->format, 0, 0, 0, 0));

++    if (width && height) {

++        SDL_FillRect(surface, NULL, SDL_MapRGBA(surface->format, 0, 0, 0, 0));

++    }

+ 

+     if((! context->tmp_ftbitmap) || context->tmp_ftbitmap->width < width

+ 	|| context->tmp_ftbitmap->rows < height)