summary refs log tree commit diff
path: root/gnu/packages/patches/unzip-symlink.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/unzip-symlink.patch')
-rw-r--r--gnu/packages/patches/unzip-symlink.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/unzip-symlink.patch b/gnu/packages/patches/unzip-symlink.patch
new file mode 100644
index 0000000000..d7eaf160b4
--- /dev/null
+++ b/gnu/packages/patches/unzip-symlink.patch
@@ -0,0 +1,17 @@
+diff --git a/process.c b/process.c
+index 1e9a1e1..905732b 100644
+--- a/process.c
++++ b/process.c
+@@ -1751,6 +1751,12 @@ int process_cdir_file_hdr(__G)    /* return PK-type error code */
+         = (G.crec.general_purpose_bit_flag & (1 << 11)) == (1 << 11);
+ #endif
+ 
++#ifdef SYMLINKS
++    /* Initialize the symlink flag, may be set by the platform-specific
++       mapattr function.  */
++    G.pInfo->symlink = 0;
++#endif
++
+     return PK_COOL;
+ 
+ } /* end function process_cdir_file_hdr() */