summary refs log tree commit diff
path: root/gnu/packages/patches/wicd-template-instantiation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/wicd-template-instantiation.patch')
-rw-r--r--gnu/packages/patches/wicd-template-instantiation.patch29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/patches/wicd-template-instantiation.patch b/gnu/packages/patches/wicd-template-instantiation.patch
deleted file mode 100644
index 16d8fa6e1d..0000000000
--- a/gnu/packages/patches/wicd-template-instantiation.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Wicd 1.7.3 fails to instantiate template lines that have several
-variable references.  For instance, the line:
-
-  wep_key$_KEY_INDEX=$_KEY
-
-which is found in in the 'wep-hex' template, expands to these two
-lines:
-
-  wep_key0=$_KEY
-  wep_key0=123456789ab
-
-This patch fixes that by only emitting the fully substituted line.
-
-Patch by Ludovic Courtès <ludo@gnu.org>.
-
---- a/wicd/misc.py	2012-11-17 00:07:08 +0000
-+++ b/wicd/misc.py	2015-05-09 11:22:37 +0000
-@@ -321,11 +321,11 @@ def ParseEncryption(network):
-                                 rep_val = '0'
-                         if rep_val:
-                             line = line.replace("$_%s" % cur_val, str(rep_val))
--                            config_file = ''.join([config_file, line])
-                         else:
-                             print "Ignoring template line: '%s'" % line
-                     else:
-                         print "Weird parsing error occurred"
-+                config_file = ''.join([config_file, line])
-             else:  # Just a regular entry.
-                 config_file = ''.join([config_file, line])