summary refs log tree commit diff
path: root/gnu/packages/patches/zlib-cc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/zlib-cc.patch')
-rw-r--r--gnu/packages/patches/zlib-cc.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/zlib-cc.patch b/gnu/packages/patches/zlib-cc.patch
new file mode 100644
index 0000000000..6b9666f5b4
--- /dev/null
+++ b/gnu/packages/patches/zlib-cc.patch
@@ -0,0 +1,21 @@
+Fix configure issue that discarded provided CC definition.
+
+Taken from upstream:
+
+  https://github.com/madler/zlib/commit/05796d3d8d5546cf1b4dfe2cd72ab746afae505d
+
+diff --git a/configure b/configure
+index 52ff4a04e..3fa3e8618 100755
+--- a/configure
++++ b/configure
+@@ -174,7 +174,10 @@ if test -z "$CC"; then
+   else
+     cc=${CROSS_PREFIX}cc
+   fi
++else
++  cc=${CC}
+ fi
++
+ cflags=${CFLAGS-"-O3"}
+ # to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
+ case "$cc" in