summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ganeti-haskell-compat.patch18
-rw-r--r--gnu/packages/patches/ganeti-sphinx-compat.patch24
2 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/patches/ganeti-haskell-compat.patch b/gnu/packages/patches/ganeti-haskell-compat.patch
deleted file mode 100644
index 931c50e116..0000000000
--- a/gnu/packages/patches/ganeti-haskell-compat.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Adjust to type change of TupE in Template Haskell 2.16.
-
-diff --git a/src/Ganeti/THH/Types.hs b/src/Ganeti/THH/Types.hs
---- a/src/Ganeti/THH/Types.hs
-+++ b/src/Ganeti/THH/Types.hs
-@@ -123,4 +123,11 @@ curryN n = do
-   f <- newName "f"
-   ps <- replicateM n (newName "x")
-   return $ LamE (VarP f : map VarP ps)
--             (AppE (VarE f) (TupE $ map VarE ps))
-+             (AppE (VarE f) (nonUnaryTupE $ map VarE ps))
-+  where
-+    nonUnaryTupE :: [Exp] -> Exp
-+    nonUnaryTupE es = TupE $
-+#if MIN_VERSION_template_haskell(2,16,0)
-+                            map Just
-+#endif
-+                            es
diff --git a/gnu/packages/patches/ganeti-sphinx-compat.patch b/gnu/packages/patches/ganeti-sphinx-compat.patch
deleted file mode 100644
index 4e84abbf37..0000000000
--- a/gnu/packages/patches/ganeti-sphinx-compat.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Adjust documentation for Sphinx 4.0.
-
-Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
-
-diff --git a/doc/index.rst b/doc/index.rst
---- a/doc/index.rst
-+++ b/doc/index.rst
-@@ -119,7 +119,6 @@ Draft designs
-    design-hotplug.rst
-    design-internal-shutdown.rst
-    design-kvmd.rst
--   design-location.rst
-    design-linuxha.rst
-    design-location.rst
-    design-lu-generated-jobs.rst
-diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
---- a/lib/build/shell_example_lexer.py
-+++ b/lib/build/shell_example_lexer.py
-@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
- 
- 
- def setup(app):
--  app.add_lexer("shell-example", ShellExampleLexer())
-+  app.add_lexer("shell-example", ShellExampleLexer)