summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/date-output-pkg-config-files.patch60
-rw-r--r--gnu/packages/patches/ffmpeg-prefer-dav1d.patch43
-rw-r--r--gnu/packages/patches/foobillard++-pkg-config.patch34
-rw-r--r--gnu/packages/patches/hash-extender-test-suite.patch13
-rw-r--r--gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch42
-rw-r--r--gnu/packages/patches/kdiagram-Fix-missing-link-libraries.patch23
-rw-r--r--gnu/packages/patches/kmail-Fix-missing-link-libraries.patch41
-rw-r--r--gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch59
-rw-r--r--gnu/packages/patches/python-faker-fix-build-32bit.patch36
9 files changed, 315 insertions, 36 deletions
diff --git a/gnu/packages/patches/date-output-pkg-config-files.patch b/gnu/packages/patches/date-output-pkg-config-files.patch
new file mode 100644
index 0000000000..3fd1d54b36
--- /dev/null
+++ b/gnu/packages/patches/date-output-pkg-config-files.patch
@@ -0,0 +1,60 @@
+From e56b2dce7e89a92e1b9b35caa13b3e938c4cedea Mon Sep 17 00:00:00 2001
+From: Cole Mickens <cole.mickens@gmail.com>
+Date: Sun, 26 Jan 2020 01:27:08 -0800
+Subject: [PATCH] CMakeLists.txt: output date.pc for pkg-config
+
+---
+ CMakeLists.txt | 15 +++++++++++++++
+ date.pc.in     | 10 ++++++++++
+ 2 files changed, 25 insertions(+)
+ create mode 100644 date.pc.in
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f30c473..fe778e8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -128,6 +128,15 @@ if( BUILD_TZ_LIB )
+     endif( )
+ endif( )
+ 
++if ( BUILD_TZ_LIB )
++  # Cflags: -I${includedir} @TZ_COMPILE_DEFINITIONS@
++  set( TZ_COMPILE_DEFINITIONS "$<IF:$<TARGET_EXISTS:tz>,-D$<JOIN:$<TARGET_PROPERTY:tz,INTERFACE_COMPILE_DEFINITIONS>, -D>,>" )
++  configure_file(date.pc.in date.pc.cf @ONLY)
++  file( GENERATE OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/date.pc"
++    INPUT "${CMAKE_CURRENT_BINARY_DIR}/date.pc.cf" )
++
++endif( )
++
+ #[===================================================================[
+    installation
+ #]===================================================================]
+@@ -171,6 +180,12 @@ install (
+   FILES cmake/dateConfig.cmake "${version_config}"
+   DESTINATION ${CONFIG_LOC})
+ 
++if ( BUILD_TZ_LIB )
++  install(
++    FILES ${CMAKE_BINARY_DIR}/date.pc
++    DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
++endif( )
++
+ #[===================================================================[
+    testing
+ #]===================================================================]
+diff --git a/date.pc.in b/date.pc.in
+new file mode 100644
+index 0000000..b9c4623
+--- /dev/null
++++ b/date.pc.in
+@@ -0,0 +1,10 @@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=@CMAKE_INSTALL_BINDIR@
++libdir=@CMAKE_INSTALL_LIB@
++includedir=@CMAKE_INSTALL_INCLUDE@
++
++Name: date
++Description: A date and time library based on the C++11/14/17 <chrono> header
++Version: @PACKAGE_VERSION@
++Libs: -L${libdir} -ltz
++Cflags: -I${includedir} @TZ_COMPILE_DEFINITIONS@
diff --git a/gnu/packages/patches/ffmpeg-prefer-dav1d.patch b/gnu/packages/patches/ffmpeg-prefer-dav1d.patch
new file mode 100644
index 0000000000..95e3712a7f
--- /dev/null
+++ b/gnu/packages/patches/ffmpeg-prefer-dav1d.patch
@@ -0,0 +1,43 @@
+When decoding AV1 files, prefer dav1d over libaom for performance
+reasons.
+
+Patch copied from upstream source repository:
+
+<https://git.videolan.org/gitweb.cgi/ffmpeg.git/?p=ffmpeg.git;a=commitdiff;h=dc0806dd25882f41f6085c8356712f95fded56c7>
+
+From dc0806dd25882f41f6085c8356712f95fded56c7 Mon Sep 17 00:00:00 2001
+From: James Almer <jamrial@gmail.com>
+Date: Sun, 15 Sep 2019 11:29:56 -0300
+Subject: [PATCH] avcodec/allcodecs: make libdav1d the preferred AV1 decoder
+
+It's considerably faster than libaom in most systems.
+
+Reviewed-by: BBB
+Signed-off-by: James Almer <jamrial@gmail.com>
+---
+ libavcodec/allcodecs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libavcodec/allcodecs.c b/libavcodec/allcodecs.c
+index 5130fca026..d5dfba1877 100644
+--- a/libavcodec/allcodecs.c
++++ b/libavcodec/allcodecs.c
+@@ -680,7 +680,6 @@ extern AVCodec ff_pcm_mulaw_at_encoder;
+ extern AVCodec ff_pcm_mulaw_at_decoder;
+ extern AVCodec ff_qdmc_at_decoder;
+ extern AVCodec ff_qdm2_at_decoder;
+-extern AVCodec ff_libaom_av1_decoder;
+ extern AVCodec ff_libaom_av1_encoder;
+ extern AVCodec ff_libaribb24_decoder;
+ extern AVCodec ff_libcelt_decoder;
+@@ -738,6 +737,7 @@ extern AVCodec ff_idf_decoder;
+ /* external libraries, that shouldn't be used by default if one of the
+  * above is available */
+ extern AVCodec ff_h263_v4l2m2m_encoder;
++extern AVCodec ff_libaom_av1_decoder;
+ extern AVCodec ff_libopenh264_encoder;
+ extern AVCodec ff_libopenh264_decoder;
+ extern AVCodec ff_h264_amf_encoder;
+-- 
+2.20.1
+
diff --git a/gnu/packages/patches/foobillard++-pkg-config.patch b/gnu/packages/patches/foobillard++-pkg-config.patch
new file mode 100644
index 0000000000..7cc40a4777
--- /dev/null
+++ b/gnu/packages/patches/foobillard++-pkg-config.patch
@@ -0,0 +1,34 @@
+From: Markus Koschany <apo@debian.org>
+Date: Thu, 8 Mar 2018 17:49:24 +0100
+Subject: pkg-config
+
+Use pkg-config instead of the deprecated freetype-config command.
+
+Bug-Debian: https://bugs.debian.org/892338
+Forwarded: no
+---
+ src/Makefile.am | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3b7d0fe..0f5a5dd 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -158,8 +158,8 @@ endif
+ SDL_CFLAGS = `sdl-config --cflags`

+ SDL_LIBS   = `sdl-config --libs`

+ 

+-FREETYPE_CFLAGS = `freetype-config --cflags`

+-FREETYPE_LIBS   = `freetype-config --libs`

++FREETYPE_CFLAGS = `pkg-config --cflags freetype2`

++FREETYPE_LIBS   = `pkg-config --libs freetype2`

+ 

+ if USE_MATHSINGLE

+ MATH_CFLAGS = -DVMATH_SINGLE_PRECISION

+@@ -233,4 +233,4 @@ AM_CFLAGS = -Wall ${FREETYPE_CFLAGS} ${SDL_CFLAGS} ${NVIDIA_CFLAGS} ${SOUND_CFLA
+             ${OPTIMIZATION_CFLAGS} ${USESSE_CFLAGS} ${USEWIN_CFLAGS} ${FASTMATH_CFLAGS} ${DEBIAN_CFLAGS} -lm

+ 

+ AM_LDFLAGS = ${all_libraries} ${FREETYPE_LIBS} ${SDL_LIBS}

+-LDADD = ${LDADD_FLAGS}
+\ No newline at end of file
++LDADD = ${LDADD_FLAGS}

diff --git a/gnu/packages/patches/hash-extender-test-suite.patch b/gnu/packages/patches/hash-extender-test-suite.patch
new file mode 100644
index 0000000000..59de52dad4
--- /dev/null
+++ b/gnu/packages/patches/hash-extender-test-suite.patch
@@ -0,0 +1,13 @@
+Make the test suite exit with a non-zero exit code if some tests failed.
+Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
+--- a/test.c
++++ b/test.c
+@@ -79,5 +79,9 @@ void test_report(void)
+     printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
+     printf("--------------------------------------------------------------------------------\n");
+   }
++
++  if (tests_passed != tests_run) {
++      exit(1);
++  }
+ }
diff --git a/gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch b/gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch
new file mode 100644
index 0000000000..13345c0038
--- /dev/null
+++ b/gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch
@@ -0,0 +1,42 @@
+From b84c4ba97cecf7304e99cafdd8a9c5866ce27050 Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Tue, 21 Jan 2020 23:33:50 +0100
+Subject: [PATCH] Fix missing link libraries.
+
+See <https://phabricator.kde.org/D26819>
+
+These are only actually missing if the libraries reside in different
+prefixes, as it is the case in Guix or Nix.
+---
+ resources/ews/test/CMakeLists.txt | 1 +
+ resources/facebook/CMakeLists.txt | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/resources/ews/test/CMakeLists.txt b/resources/ews/test/CMakeLists.txt
+index b20eddcb8..6355eb994 100644
+--- a/resources/ews/test/CMakeLists.txt
++++ b/resources/ews/test/CMakeLists.txt
+@@ -35,6 +35,7 @@ qt5_add_resources(isolatestestcommon_RSRCS isolatedtestcommon.qrc)
+ add_library(isolatedtestcommon STATIC ${isolatestestcommon_SRCS})
+ target_link_libraries(isolatedtestcommon
+   KF5::AkonadiCore
++  KF5::AkonadiMime
+   Qt5::Core
+   Qt5::Network
+   Qt5::Test
+diff --git a/resources/facebook/CMakeLists.txt b/resources/facebook/CMakeLists.txt
+index bdd5eeaa7..27a9c83c1 100644
+--- a/resources/facebook/CMakeLists.txt
++++ b/resources/facebook/CMakeLists.txt
+@@ -21,7 +21,8 @@ add_library(facebookresourcelib STATIC ${fbresource_SRCS})
+ 
+ target_link_libraries(facebookresourcelib
+     KF5::KIOWidgets
++    KF5::AkonadiCore
+     KF5::IconThemes
+     KF5::I18n
+     KF5::ConfigGui
+     KF5::CalendarCore
+-- 
+2.21.1
+
diff --git a/gnu/packages/patches/kdiagram-Fix-missing-link-libraries.patch b/gnu/packages/patches/kdiagram-Fix-missing-link-libraries.patch
new file mode 100644
index 0000000000..cdfb608d9b
--- /dev/null
+++ b/gnu/packages/patches/kdiagram-Fix-missing-link-libraries.patch
@@ -0,0 +1,23 @@
+From c59acf1f54a2cd760e55082a01593a31a690d786 Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Wed, 22 Jan 2020 00:56:27 +0100
+Subject: [PATCH] Fix missing link libraries.
+
+These are only actually missing if the libraries reside in different
+prefixes, as it is the case in Guix or Nix.
+---
+ examples/Bars/Simple/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/Bars/Simple/CMakeLists.txt b/examples/Bars/Simple/CMakeLists.txt
+index be2a6fc..b13befb 100644
+--- a/examples/Bars/Simple/CMakeLists.txt
++++ b/examples/Bars/Simple/CMakeLists.txt
+@@ -1,3 +1,3 @@
+ add_executable(BarsSimple  main.cpp)
+ 
+-target_link_libraries(BarsSimple KChart Qt5::Widgets)
++target_link_libraries(BarsSimple KChart Qt5::Widgets Qt5::Svg)
+-- 
+2.21.1
+
diff --git a/gnu/packages/patches/kmail-Fix-missing-link-libraries.patch b/gnu/packages/patches/kmail-Fix-missing-link-libraries.patch
new file mode 100644
index 0000000000..fc784d63dd
--- /dev/null
+++ b/gnu/packages/patches/kmail-Fix-missing-link-libraries.patch
@@ -0,0 +1,41 @@
+From 6b0a3a60870499b20ce9ae2ea07cbc5ee53cbdd2 Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Tue, 21 Jan 2020 23:23:38 +0100
+Subject: [PATCH] Fix missing link libraries.
+
+See <https://phabricator.kde.org/D26821>
+
+These are only actually missing if the libraries reside in different
+prefixes, as it is the case in Guix or Nix.
+---
+ agents/archivemailagent/CMakeLists.txt      | 1 +
+ agents/followupreminderagent/CMakeLists.txt | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/agents/archivemailagent/CMakeLists.txt b/agents/archivemailagent/CMakeLists.txt
+index 95c6249de..d0ddcd475 100644
+--- a/agents/archivemailagent/CMakeLists.txt
++++ b/agents/archivemailagent/CMakeLists.txt
+@@ -22,6 +22,7 @@ ki18n_wrap_ui(libarchivemailagent_SRCS ui/archivemailwidget.ui )
+ add_library(archivemailagent STATIC ${libarchivemailagent_SRCS})
+ target_link_libraries(archivemailagent
+     KF5::MailCommon
++    KF5::Libkdepim
+     KF5::I18n
+     KF5::Notifications
+     KF5::KIOWidgets
+diff --git a/agents/followupreminderagent/CMakeLists.txt b/agents/followupreminderagent/CMakeLists.txt
+index 9ae7eaa29..527044807 100644
+--- a/agents/followupreminderagent/CMakeLists.txt
++++ b/agents/followupreminderagent/CMakeLists.txt
+@@ -27,6 +27,7 @@ target_link_libraries(followupreminderagent
+     KF5::AkonadiMime
+     KF5::AkonadiAgentBase
+     KF5::DBusAddons
++    KF5::FollowupReminder
+     KF5::XmlGui
+     KF5::KIOWidgets
+     KF5::Notifications
+-- 
+2.21.1
+
diff --git a/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch b/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch
new file mode 100644
index 0000000000..238c4ec46c
--- /dev/null
+++ b/gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch
@@ -0,0 +1,59 @@
+From 732861dda9c466841a09329a0b2c992f2b78c40a Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Tue, 21 Jan 2020 23:15:23 +0100
+Subject: [PATCH] Fix missing link libraries.
+
+See <https://phabricator.kde.org/D26818>
+
+These are only actually missing if the libraries reside in different
+prefixes, as it is the case in Guix or Nix.
+---
+ src/ksieveui/autocreatescripts/tests/CMakeLists.txt  | 2 ++
+ src/ksieveui/scriptsparsing/autotests/CMakeLists.txt | 2 +-
+ src/ksieveui/scriptsparsing/tests/CMakeLists.txt     | 8 ++++++--
+ 3 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
+index 8a482b4..c43216c 100644
+--- a/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
++++ b/src/ksieveui/autocreatescripts/tests/CMakeLists.txt
+@@ -15,6 +16,7 @@ set(parsingscript_gui_SRCS parsingscript_gui.cpp ../../tests/capability.cpp)
+ add_executable(parsingscript_gui ${parsingscript_gui_SRCS})
+ target_link_libraries(parsingscript_gui
+   KF5::KIOCore
++  KF5::SyntaxHighlighting
+   KF5::KSieveUi
+   KF5::KSieve
+   KF5::PimCommon
+diff --git a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
+index e41a74e..31703ef 100644
+--- a/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
++++ b/src/ksieveui/scriptsparsing/autotests/CMakeLists.txt
+@@ -5,7 +5,7 @@ macro(add_sieveeditor_xmlprintingscriptbuilding _source _extrasource)
+     ecm_add_test(${_test}
+         TEST_NAME ${_name}
+         NAME_PREFIX "sieveeditor-xmlprintingscriptbuilding-"
+-        LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi
++        LINK_LIBRARIES Qt5::Test KF5::I18n KF5::KSieveUi KF5::SyntaxHighlighting
+         )
+ endmacro()
+ add_sieveeditor_xmlprintingscriptbuilding(xmlprintingscriptbuildertest.cpp "" "")
+diff --git a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
+index a252039..99a1aaa 100644
+--- a/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
++++ b/src/ksieveui/scriptsparsing/tests/CMakeLists.txt
+@@ -9,5 +9,9 @@ set(xmlsieveparsing_SRCS
+ )
+ 
+ add_executable(xmlsieveparsing ${xmlsieveparsing_SRCS} )
+-target_link_libraries(xmlsieveparsing   KF5::KSieveUi KF5::KSieve KF5::I18n)
+-
++target_link_libraries(xmlsieveparsing
++  KF5::KSieveUi
++  KF5::SyntaxHighlighting
++  KF5::KSieve
++  KF5::I18n
++)
+-- 
+2.21.1
+
diff --git a/gnu/packages/patches/python-faker-fix-build-32bit.patch b/gnu/packages/patches/python-faker-fix-build-32bit.patch
deleted file mode 100644
index 466b289012..0000000000
--- a/gnu/packages/patches/python-faker-fix-build-32bit.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-These tests fail on 32-bit due to an overflow.
-
-Upstream bug URL: https://github.com/joke2k/faker/issues/408
-
-diff --git a/tests/__init__.py b/tests/__init__.py
-index 6026772..58b6b83 100644
---- a/tests/__init__.py
-+++ b/tests/__init__.py
-@@ -384,7 +384,6 @@ class FactoryTestCase(unittest.TestCase):
-         provider = Provider
-         # test century
-         self.assertTrue(self._datetime_to_time(provider.date_time_this_century(after_now=False)) <= self._datetime_to_time(datetime.datetime.now()))
--        self.assertTrue(self._datetime_to_time(provider.date_time_this_century(before_now=False, after_now=True)) >= self._datetime_to_time(datetime.datetime.now()))
-         # test decade
-         self.assertTrue(self._datetime_to_time(provider.date_time_this_decade(after_now=False)) <= self._datetime_to_time(datetime.datetime.now()))
-         self.assertTrue(self._datetime_to_time(provider.date_time_this_decade(before_now=False, after_now=True)) >= self._datetime_to_time(datetime.datetime.now()))
-@@ -413,8 +412,6 @@ class FactoryTestCase(unittest.TestCase):
- 
-         # ensure all methods provide timezone aware datetimes
-         with self.assertRaises(TypeError):
--            provider.date_time_this_century(before_now=False, after_now=True, tzinfo=utc) >= datetime.datetime.now()
--        with self.assertRaises(TypeError):
-             provider.date_time_this_decade(after_now=False, tzinfo=utc) <= datetime.datetime.now()
-         with self.assertRaises(TypeError):
-             provider.date_time_this_year(after_now=False, tzinfo=utc) <= datetime.datetime.now()
-@@ -423,7 +420,6 @@ class FactoryTestCase(unittest.TestCase):
- 
-         # test century
-         self.assertTrue(provider.date_time_this_century(after_now=False, tzinfo=utc) <= datetime.datetime.now(utc))
--        self.assertTrue(provider.date_time_this_century(before_now=False, after_now=True, tzinfo=utc) >= datetime.datetime.now(utc))
-         # test decade
-         self.assertTrue(provider.date_time_this_decade(after_now=False, tzinfo=utc) <= datetime.datetime.now(utc))
-         self.assertTrue(provider.date_time_this_decade(before_now=False, after_now=True, tzinfo=utc) >= datetime.datetime.now(utc))
--- 
-2.11.1
-