summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/jami-sipaccount-segfault.patch30
-rw-r--r--gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch5
-rw-r--r--gnu/packages/patches/julia-allow-parallel-build.patch32
-rw-r--r--gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch40
-rw-r--r--gnu/packages/patches/python-seaborn-2690.patch268
-rw-r--r--gnu/packages/patches/python-seaborn-kde-test.patch36
-rw-r--r--gnu/packages/patches/u-boot-allow-disabling-openssl.patch66
7 files changed, 99 insertions, 378 deletions
diff --git a/gnu/packages/patches/jami-sipaccount-segfault.patch b/gnu/packages/patches/jami-sipaccount-segfault.patch
new file mode 100644
index 0000000000..1cef512124
--- /dev/null
+++ b/gnu/packages/patches/jami-sipaccount-segfault.patch
@@ -0,0 +1,30 @@
+From e5a449d60abc667d85dacd75ad6e31d4ddca5853 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9bastien=20Blin?=
+ <sebastien.blin@savoirfairelinux.com>
+Date: Thu, 17 Nov 2022 12:02:20 -0500
+Subject: [PATCH] sipaccount: fix potential null dereference
+
+Detected by sonarqube
+
+Change-Id: I606f9cf2458dda07471d0a67af8915c7ca13d410
+---
+ src/sip/sipaccount.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/daemon/src/sip/sipaccount.cpp b/daemon/src/sip/sipaccount.cpp
+index 695b71839..e544ac31a 100644
+--- a/daemon/src/sip/sipaccount.cpp
++++ b/daemon/src/sip/sipaccount.cpp
+@@ -789,7 +789,8 @@ SIPAccount::sendRegister()
+     if (pjsip_regc_set_transport(regc, &tp_sel) != PJ_SUCCESS)
+         throw VoipLinkException("Unable to set transport");
+ 
+-    setUpTransmissionData(tdata, tp_sel.u.transport->key.type);
++    if (tp_sel.u.transport)
++        setUpTransmissionData(tdata, tp_sel.u.transport->key.type);
+ 
+     // pjsip_regc_send increment the transport ref count by one,
+     if ((status = pjsip_regc_send(regc, tdata)) != PJ_SUCCESS) {
+-- 
+GitLab
+
diff --git a/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
index b60f284923..c6ca48fff0 100644
--- a/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
+++ b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
@@ -8,15 +8,16 @@ Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.
 
 --- a/base/loading.jl
 +++ b/base/loading.jl
-@@ -807,7 +807,10 @@
-         path = normpath(joinpath(dirname(prev), _path))
+@@ -1131,7 +1131,10 @@ function _include_dependency(mod::Module, _path::AbstractString)
      end
      if _track_dependencies[]
+         @lock require_lock begin
 -        push!(_require_dependencies, (mod, path, mtime(path)))
 +          push!(_require_dependencies,
 +                (mod, path,
 +                 haskey(ENV, "SOURCE_DATE_EPOCH") ?
 +                 parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
+         end
      end
      return path, prev
  end
diff --git a/gnu/packages/patches/julia-allow-parallel-build.patch b/gnu/packages/patches/julia-allow-parallel-build.patch
deleted file mode 100644
index cc1d42fee4..0000000000
--- a/gnu/packages/patches/julia-allow-parallel-build.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Allow parallel tests with isolated environment.
-
-See https://github.com/JuliaLang/julia/issues/43205 and
-https://github.com/JuliaLang/julia/pull/43211.
-
-diff --git a/test/runtests.jl b/test/runtests.jl
-index 2f9cd058bb..150395e78c 100644
---- a/test/runtests.jl
-+++ b/test/runtests.jl
-@@ -4,7 +4,7 @@ using Test
- using Distributed
- using Dates
- import REPL
--using Printf: @sprintf
-+using Printf: @sprintf, @printf
- using Base: Experimental
- 
- include("choosetests.jl")
-@@ -83,11 +83,12 @@ prepend!(tests, linalg_tests)
- import LinearAlgebra
- cd(@__DIR__) do
-     n = 1
--    if net_on
-+    if net_on || haskey(ENV, "JULIA_CPU_THREADS")
-         n = min(Sys.CPU_THREADS, length(tests))
-         n > 1 && addprocs_with_testenv(n)
-         LinearAlgebra.BLAS.set_num_threads(1)
-     end
-+    @printf("Number of threads: %i\n", n)
-     skipped = 0
- 
-     @everywhere include("testdefs.jl")
diff --git a/gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch b/gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch
deleted file mode 100644
index 8ef4b111e4..0000000000
--- a/gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix compilation with -fno-common.
-
-Borrowed from upstream 29e17d8d2ccbca07c423e3089a6d5ae8a1c9cb6e.
-Author:     Yichao Yu <yyc1992@gmail.com>
-AuthorDate: Tue Mar 31 00:43:32 2020 -0400
-Commit:     Dave Watson <dade.watson@gmail.com>
-CommitDate: Tue Mar 31 08:06:29 2020 -0700
-
-diff --git a/src/x86/Ginit.c b/src/x86/Ginit.c
-index f6b8dc2..9550efa 100644
---- a/src/x86/Ginit.c
-+++ b/src/x86/Ginit.c
-@@ -54,13 +54,6 @@ tdep_uc_addr (ucontext_t *uc, int reg)
- 
- # endif /* UNW_LOCAL_ONLY */
- 
--HIDDEN unw_dyn_info_list_t _U_dyn_info_list;
--
--/* XXX fix me: there is currently no way to locate the dyn-info list
--       by a remote unwinder.  On ia64, this is done via a special
--       unwind-table entry.  Perhaps something similar can be done with
--       DWARF2 unwind info.  */
--
- static void
- put_unwind_info (unw_addr_space_t as, unw_proc_info_t *proc_info, void *arg)
- {
-@@ -71,7 +64,12 @@ static int
- get_dyn_info_list_addr (unw_addr_space_t as, unw_word_t *dyn_info_list_addr,
-                         void *arg)
- {
--  *dyn_info_list_addr = (unw_word_t) &_U_dyn_info_list;
-+#ifndef UNW_LOCAL_ONLY
-+# pragma weak _U_dyn_info_list_addr
-+  if (!_U_dyn_info_list_addr)
-+    return -UNW_ENOINFO;
-+#endif
-+  *dyn_info_list_addr = _U_dyn_info_list_addr ();
-   return 0;
- }
- 
diff --git a/gnu/packages/patches/python-seaborn-2690.patch b/gnu/packages/patches/python-seaborn-2690.patch
deleted file mode 100644
index 4662d19c2d..0000000000
--- a/gnu/packages/patches/python-seaborn-2690.patch
+++ /dev/null
@@ -1,268 +0,0 @@
-This patch was adapted from the upstream pull request 2690.
-
-From ebd6812d48f5b8ed1ebb7d79bda0b2a7b9ae2812 Mon Sep 17 00:00:00 2001
-From: Michael Waskom <mwaskom@gmail.com>
-Date: Sun, 31 Oct 2021 15:09:27 -0400
-Subject: [PATCH 1/4] Update boxplot tests for mpl3.5 compatability
-
----
- seaborn/tests/test_categorical.py | 30 +++++++++++++++++++-----------
- 1 file changed, 19 insertions(+), 11 deletions(-)
-
-diff --git a/seaborn/tests/test_categorical.py b/seaborn/tests/test_categorical.py
-index d4e09b703..488fad2d6 100644
---- a/seaborn/tests/test_categorical.py
-+++ b/seaborn/tests/test_categorical.py
-@@ -110,6 +110,11 @@ class CategoricalFixture:
-     df = pd.DataFrame(dict(y=y, g=g, h=h, u=u))
-     x_df["W"] = g
- 
-+    def get_box_artists(self, ax):
-+
-+        # Exclude labeled patches, which are for the legend
-+        return [p for p in ax.patches if not p.get_label()]
-+
- 
- class TestCategoricalPlotter(CategoricalFixture):
- 
-@@ -855,12 +863,12 @@ def test_hue_offsets(self):
-     def test_axes_data(self):
- 
-         ax = cat.boxplot(x="g", y="y", data=self.df)
--        assert len(ax.artists) == 3
-+        assert len(self.get_box_artists(ax)) == 3
- 
-         plt.close("all")
- 
-         ax = cat.boxplot(x="g", y="y", hue="h", data=self.df)
--        assert len(ax.artists) == 6
-+        assert len(self.get_box_artists(ax)) == 6
- 
-         plt.close("all")
- 
-@@ -868,14 +876,14 @@ def test_box_colors(self):
- 
-         ax = cat.boxplot(x="g", y="y", data=self.df, saturation=1)
-         pal = palettes.color_palette(n_colors=3)
--        for patch, color in zip(ax.artists, pal):
-+        for patch, color in zip(self.get_box_artists(ax), pal):
-             assert patch.get_facecolor()[:3] == color
- 
-         plt.close("all")
- 
-         ax = cat.boxplot(x="g", y="y", hue="h", data=self.df, saturation=1)
-         pal = palettes.color_palette(n_colors=2)
--        for patch, color in zip(ax.artists, pal * 2):
-+        for patch, color in zip(self.get_box_artists(ax), pal * 2):
-             assert patch.get_facecolor()[:3] == color
- 
-         plt.close("all")
-@@ -884,7 +892,7 @@ def test_draw_missing_boxes(self):
- 
-         ax = cat.boxplot(x="g", y="y", data=self.df,
-                          order=["a", "b", "c", "d"])
--        assert len(ax.artists) == 3
-+        assert len(self.get_box_artists(ax)) == 3
- 
-     def test_missing_data(self):
- 
-@@ -894,13 +902,13 @@ def test_missing_data(self):
-         y[-2:] = np.nan
- 
-         ax = cat.boxplot(x=x, y=y)
--        assert len(ax.artists) == 3
-+        assert len(self.get_box_artists(ax)) == 3
- 
-         plt.close("all")
- 
-         y[-1] = 0
-         ax = cat.boxplot(x=x, y=y, hue=h)
--        assert len(ax.artists) == 7
-+        assert len(self.get_box_artists(ax)) == 7
- 
-         plt.close("all")
- 
-@@ -2766,11 +2774,11 @@ def test_plot_elements(self):
- 
-         g = cat.catplot(x="g", y="y", data=self.df, kind="box")
-         want_artists = self.g.unique().size
--        assert len(g.ax.artists) == want_artists
-+        assert len(self.get_box_artists(g.ax)) == want_artists
- 
-         g = cat.catplot(x="g", y="y", hue="h", data=self.df, kind="box")
-         want_artists = self.g.unique().size * self.h.unique().size
--        assert len(g.ax.artists) == want_artists
-+        assert len(self.get_box_artists(g.ax)) == want_artists
- 
-         g = cat.catplot(x="g", y="y", data=self.df,
-                         kind="violin", inner=None)
-@@ -3137,14 +3145,14 @@ def test_box_colors(self):
- 
-         ax = cat.boxenplot(x="g", y="y", data=self.df, saturation=1)
-         pal = palettes.color_palette(n_colors=3)
--        for patch, color in zip(ax.artists, pal):
-+        for patch, color in zip(self.get_box_artists(ax), pal):
-             assert patch.get_facecolor()[:3] == color
- 
-         plt.close("all")
- 
-         ax = cat.boxenplot(x="g", y="y", hue="h", data=self.df, saturation=1)
-         pal = palettes.color_palette(n_colors=2)
--        for patch, color in zip(ax.artists, pal * 2):
-+        for patch, color in zip(self.get_box_artists(ax), pal * 2):
-             assert patch.get_facecolor()[:3] == color
- 
-         plt.close("all")
-
-From ff78ed38817a346e760194ab3b03b28d7ea3ba1b Mon Sep 17 00:00:00 2001
-From: Michael Waskom <mwaskom@gmail.com>
-Date: Sun, 31 Oct 2021 15:50:54 -0400
-Subject: [PATCH 2/4] Update kdeplot tests for mpl3.5 compatability
-
----
- seaborn/tests/test_distributions.py | 53 ++++++++++++++++++++---------
- 1 file changed, 37 insertions(+), 16 deletions(-)
-
-diff --git a/seaborn/tests/test_distributions.py b/seaborn/tests/test_distributions.py
-index d241fd978..466efb69e 100644
---- a/seaborn/tests/test_distributions.py
-+++ b/seaborn/tests/test_distributions.py
-@@ -39,6 +39,27 @@
- )
- 
- 
-+def get_contour_coords(c):
-+    """Provide compatability for change in contour artist type in mpl3.5."""
-+    # See https://github.com/matplotlib/matplotlib/issues/20906
-+    if isinstance(c, mpl.collections.LineCollection):
-+        return c.get_segments()
-+    elif isinstance(c, mpl.collections.PathCollection):
-+        return [p.vertices[:np.argmax(p.codes) + 1] for p in c.get_paths()]
-+
-+
-+def get_contour_color(c):
-+    """Provide compatability for change in contour artist type in mpl3.5."""
-+    # See https://github.com/matplotlib/matplotlib/issues/20906
-+    if isinstance(c, mpl.collections.LineCollection):
-+        return c.get_color()
-+    elif isinstance(c, mpl.collections.PathCollection):
-+        if c.get_facecolor().size:
-+            return c.get_facecolor()
-+        else:
-+            return c.get_edgecolor()
-+
-+
- class TestDistPlot(object):
- 
-     rs = np.random.RandomState(0)
-@@ -902,7 +923,7 @@ def test_fill_artists(self, long_df):
-             f, ax = plt.subplots()
-             kdeplot(data=long_df, x="x", y="y", hue="c", fill=fill)
-             for c in ax.collections:
--                if fill:
-+                if fill or Version(mpl.__version__) >= Version("3.5.0b0"):
-                     assert isinstance(c, mpl.collections.PathCollection)
-                 else:
-                     assert isinstance(c, mpl.collections.LineCollection)
-@@ -918,8 +939,8 @@ def test_common_norm(self, rng):
-         kdeplot(x=x, y=y, hue=hue, common_norm=True, ax=ax1)
-         kdeplot(x=x, y=y, hue=hue, common_norm=False, ax=ax2)
- 
--        n_seg_1 = sum([len(c.get_segments()) > 0 for c in ax1.collections])
--        n_seg_2 = sum([len(c.get_segments()) > 0 for c in ax2.collections])
-+        n_seg_1 = sum([len(get_contour_coords(c)) > 0 for c in ax1.collections])
-+        n_seg_2 = sum([len(get_contour_coords(c)) > 0 for c in ax2.collections])
-         assert n_seg_2 > n_seg_1
- 
-     def test_log_scale(self, rng):
-@@ -946,7 +967,7 @@ def test_log_scale(self, rng):
-         ax2.contour(10 ** xx, yy, density, levels=levels)
- 
-         for c1, c2 in zip(ax1.collections, ax2.collections):
--            assert_array_equal(c1.get_segments(), c2.get_segments())
-+            assert_array_equal(get_contour_coords(c1), get_contour_coords(c2))
- 
-     def test_bandwidth(self, rng):
- 
-@@ -959,7 +980,7 @@ def test_bandwidth(self, rng):
-         kdeplot(x=x, y=y, bw_adjust=2, ax=ax2)
- 
-         for c1, c2 in zip(ax1.collections, ax2.collections):
--            seg1, seg2 = c1.get_segments(), c2.get_segments()
-+            seg1, seg2 = get_contour_coords(c1), get_contour_coords(c2)
-             if seg1 + seg2:
-                 x1 = seg1[0][:, 0]
-                 x2 = seg2[0][:, 0]
-@@ -980,9 +1001,9 @@ def test_weights(self, rng):
-         kdeplot(x=x, y=y, hue=hue, weights=weights, ax=ax2)
- 
-         for c1, c2 in zip(ax1.collections, ax2.collections):
--            if c1.get_segments() and c2.get_segments():
--                seg1 = np.concatenate(c1.get_segments(), axis=0)
--                seg2 = np.concatenate(c2.get_segments(), axis=0)
-+            if get_contour_coords(c1) and get_contour_coords(c2):
-+                seg1 = np.concatenate(get_contour_coords(c1), axis=0)
-+                seg2 = np.concatenate(get_contour_coords(c2), axis=0)
-                 assert not np.array_equal(seg1, seg2)
- 
-     def test_hue_ignores_cmap(self, long_df):
-@@ -1030,7 +1051,7 @@ def test_levels_and_thresh(self, long_df):
-         kdeplot(**plot_kws, levels=np.linspace(thresh, 1, n), ax=ax2)
- 
-         for c1, c2 in zip(ax1.collections, ax2.collections):
--            assert_array_equal(c1.get_segments(), c2.get_segments())
-+            assert_array_equal(get_contour_coords(c1), get_contour_coords(c2))
- 
-         with pytest.raises(ValueError):
-             kdeplot(**plot_kws, levels=[0, 1, 2])
-@@ -1042,7 +1063,7 @@ def test_levels_and_thresh(self, long_df):
-         kdeplot(**plot_kws, levels=n, thresh=0, ax=ax2)
- 
-         for c1, c2 in zip(ax1.collections, ax2.collections):
--            assert_array_equal(c1.get_segments(), c2.get_segments())
-+            assert_array_equal(get_contour_coords(c1), get_contour_coords(c2))
-         for c1, c2 in zip(ax1.collections, ax2.collections):
-             assert_array_equal(c1.get_facecolors(), c2.get_facecolors())
- 
-@@ -2322,13 +2343,13 @@ def test_bivariate_kde_norm(self, rng):
-         z = [0] * 80 + [1] * 20
- 
-         g = displot(x=x, y=y, col=z, kind="kde", levels=10)
--        l1 = sum(bool(c.get_segments()) for c in g.axes.flat[0].collections)
--        l2 = sum(bool(c.get_segments()) for c in g.axes.flat[1].collections)
-+        l1 = sum(bool(get_contour_coords(c)) for c in g.axes.flat[0].collections)
-+        l2 = sum(bool(get_contour_coords(c)) for c in g.axes.flat[1].collections)
-         assert l1 > l2
- 
-         g = displot(x=x, y=y, col=z, kind="kde", levels=10, common_norm=False)
--        l1 = sum(bool(c.get_segments()) for c in g.axes.flat[0].collections)
--        l2 = sum(bool(c.get_segments()) for c in g.axes.flat[1].collections)
-+        l1 = sum(bool(get_contour_coords(c)) for c in g.axes.flat[0].collections)
-+        l2 = sum(bool(get_contour_coords(c)) for c in g.axes.flat[1].collections)
-         assert l1 == l2
- 
-     def test_bivariate_hist_norm(self, rng):
-
-From a20ce3fabeb23c97b5827d9fb0c6a96ac109ea64 Mon Sep 17 00:00:00 2001
-From: Michael Waskom <mwaskom@gmail.com>
-Date: Sun, 31 Oct 2021 16:10:47 -0400
-Subject: [PATCH 3/4] Update legend tests for mpl3.5 compatability
-
----
- seaborn/tests/test_distributions.py | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/seaborn/tests/test_distributions.py b/seaborn/tests/test_distributions.py
-index 466efb69e..024fe7541 100644
---- a/seaborn/tests/test_distributions.py
-+++ b/seaborn/tests/test_distributions.py
-@@ -872,7 +872,7 @@ def test_legend(self, long_df):
-         for label, level in zip(legend_labels, order):
-             assert label.get_text() == level
- 
--        legend_artists = ax.legend_.findobj(mpl.lines.Line2D)[::2]
-+        legend_artists = ax.legend_.findobj(mpl.lines.Line2D)
-         palette = color_palette()
-         for artist, color in zip(legend_artists, palette):
-             assert_colors_equal(artist.get_color(), color)
-
diff --git a/gnu/packages/patches/python-seaborn-kde-test.patch b/gnu/packages/patches/python-seaborn-kde-test.patch
deleted file mode 100644
index f300dffc6f..0000000000
--- a/gnu/packages/patches/python-seaborn-kde-test.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-This patch is an excerpt of this upstream commit:
-
-  commit 0a24478a550132f1882e5be5f5dbc0fc446a8a6c
-  Author: Michael Waskom <mwaskom@users.noreply.github.com>
-  Date:   Mon Dec 21 18:44:58 2020 -0500
-
-      Raise minimal supported Python to 3.7 and bump requirements (#2396)
-
-It fixes the failure of 'test_weights'.
-
---- a/seaborn/tests/test_distributions.py
-+++ b/seaborn/tests/test_distributions.py
-@@ -709,21 +708,17 @@ class TestKDEPlotUnivariate:
-         integral = integrate.trapz(ydata, np.log10(xdata))
-         assert integral == pytest.approx(1)
- 
--    @pytest.mark.skipif(
--        LooseVersion(scipy.__version__) < "1.2.0",
--        reason="Weights require scipy >= 1.2.0"
--    )
-     def test_weights(self):
- 
-         x = [1, 2]
-         weights = [2, 1]
- 
--        ax = kdeplot(x=x, weights=weights)
-+        ax = kdeplot(x=x, weights=weights, bw_method=.1)
- 
-         xdata, ydata = ax.lines[0].get_xydata().T
- 
--        y1 = ydata[np.argwhere(np.abs(xdata - 1).min())]
--        y2 = ydata[np.argwhere(np.abs(xdata - 2).min())]
-+        y1 = ydata[np.abs(xdata - 1).argmin()]
-+        y2 = ydata[np.abs(xdata - 2).argmin()]
- 
-         assert y1 == pytest.approx(2 * y2)
diff --git a/gnu/packages/patches/u-boot-allow-disabling-openssl.patch b/gnu/packages/patches/u-boot-allow-disabling-openssl.patch
index 73e5878546..5f2856dbb4 100644
--- a/gnu/packages/patches/u-boot-allow-disabling-openssl.patch
+++ b/gnu/packages/patches/u-boot-allow-disabling-openssl.patch
@@ -5,6 +5,9 @@ Subject: [PATCH] Revert "tools: kwbimage: Do not hide usage of secure header
 
 This reverts commit b4f3cc2c42d97967a3a3c8796c340f6b07ecccac.
 
+Addendum 2022-12-08, Ricardo Wurmus: This patch has been updated to introduce
+CONFIG_FIT_PRELOAD to remove fit_pre_load_data, which depends on openssl.
+
 diff --git a/tools/kwbimage.c b/tools/kwbimage.c
 index 94b7685392..eec599b0ee 100644
 --- a/tools/kwbimage.c
@@ -137,3 +140,66 @@ index 94b7685392..eec599b0ee 100644
  
  	*imagesz = headersz;
  
+--- a/tools/image-host.c
++++ b/tools/image-host.c
+@@ -14,10 +14,12 @@
+ #include <image.h>
+ #include <version.h>
+ 
++#ifdef CONFIG_FIT_PRELOAD
+ #include <openssl/pem.h>
+ #include <openssl/evp.h>
+ 
+ #define IMAGE_PRE_LOAD_PATH                             "/image/pre-load/sig"
++#endif
+ 
+ /**
+  * fit_set_hash_value - set hash value in requested has node
+@@ -1116,6 +1118,7 @@
+ 	return 0;
+ }
+ 
++#ifdef CONFIG_FIT_PRELOAD
+ /*
+  * 0) open file (open)
+  * 1) read certificate (PEM_read_X509)
+@@ -1224,6 +1227,7 @@
+  out:
+ 	return ret;
+ }
++#endif
+ 
+ int fit_cipher_data(const char *keydir, void *keydest, void *fit,
+ 		    const char *comment, int require_keys,
+--- a/tools/fit_image.c
++++ b/tools/fit_image.c
+@@ -59,9 +59,10 @@
+ 		ret = fit_set_timestamp(ptr, 0, time);
+ 	}
+ 
++#ifdef CONFIG_FIT_PRELOAD
+ 	if (!ret)
+ 		ret = fit_pre_load_data(params->keydir, dest_blob, ptr);
+-
++#endif
+ 	if (!ret) {
+ 		ret = fit_cipher_data(params->keydir, dest_blob, ptr,
+ 				      params->comment,
+--- a/include/image.h
++++ b/include/image.h
+@@ -1090,6 +1090,7 @@
+ 
+ int fit_set_timestamp(void *fit, int noffset, time_t timestamp);
+ 
++#ifdef CONFIG_FIT_PRELOAD
+ /**
+  * fit_pre_load_data() - add public key to fdt blob
+  *
+@@ -1104,6 +1105,7 @@
+  *	< 0, on failure
+  */
+ int fit_pre_load_data(const char *keydir, void *keydest, void *fit);
++#endif
+ 
+ int fit_cipher_data(const char *keydir, void *keydest, void *fit,
+ 		    const char *comment, int require_keys,