summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/cssc-gets-undeclared.patch17
-rw-r--r--gnu/packages/patches/cssc-missing-include.patch12
2 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/patches/cssc-gets-undeclared.patch b/gnu/packages/patches/cssc-gets-undeclared.patch
deleted file mode 100644
index 68c607cf58..0000000000
--- a/gnu/packages/patches/cssc-gets-undeclared.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-CSSC uses a gets in a couple of places.  For security reasons, modern gnulib
-does not allow this.  This patch allows it again.
---- CSSC-1.3.0/gl/lib/stdio.in.h	2010-05-15 00:15:35.000000000 +0200
-+++ CSSC-1.3.0/gl/lib/stdio.in.h	2014-02-03 21:27:10.000000000 +0100
-@@ -135,12 +135,6 @@
-                  "use gnulib module fflush for portable POSIX compliance");
- #endif
- 
--/* It is very rare that the developer ever has full control of stdin,
--   so any use of gets warrants an unconditional warning.  Assume it is
--   always declared, since it is required by C89.  */
--#undef gets
--_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
--
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
- #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
diff --git a/gnu/packages/patches/cssc-missing-include.patch b/gnu/packages/patches/cssc-missing-include.patch
deleted file mode 100644
index 3cef9c15f1..0000000000
--- a/gnu/packages/patches/cssc-missing-include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Added a missing include file (necessary for gid_t and others).
-So far as I am aware, this has not been added upstream yet.
---- CSSC-1.3.0/src/file.h	2010-05-16 19:31:33.000000000 +0200
-+++ CSSC-1.3.0/src/file.h	2014-02-03 21:48:30.000000000 +0100
-@@ -30,6 +30,7 @@
- #ifndef CSSC__FILE_H__
- #define CSSC__FILE_H__
- 
-+#include <sys/types.h>
- #include "filelock.h"
- 
- enum create_mode {