summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch86
-rw-r--r--gnu/packages/patches/ffmpeg-prefer-dav1d.patch43
-rw-r--r--gnu/packages/patches/iputils-libcap-compat.patch37
-rw-r--r--gnu/packages/patches/lib2geom-fix-tests.patch172
-rw-r--r--gnu/packages/patches/lib2geom-link-tests-against-glib.patch34
-rw-r--r--gnu/packages/patches/lib2geom-use-system-googletest.patch94
-rw-r--r--gnu/packages/patches/python-memcached-syntax-warnings.patch24
-rw-r--r--gnu/packages/patches/quassel-qt-514-compat.patch130
-rw-r--r--gnu/packages/patches/tup-unbundle-dependencies.patch66
-rw-r--r--gnu/packages/patches/xmoto-remove-glext.patch23
-rw-r--r--gnu/packages/patches/xmoto-reproducible.patch24
-rw-r--r--gnu/packages/patches/xmoto-utf8.patch16
12 files changed, 515 insertions, 234 deletions
diff --git a/gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch b/gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch
new file mode 100644
index 0000000000..ab66e1b389
--- /dev/null
+++ b/gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch
@@ -0,0 +1,86 @@
+From 6d5c587ec719e3309077c7d637b03b13db65c047 Mon Sep 17 00:00:00 2001
+From: Joseph LaFreniere <joseph@lafreniere.xyz>
+Date: Fri, 12 Jul 2019 12:43:46 -0500
+Subject: [PATCH] Move definition of hyperbole-toggle-messaging to hsettings
+
+---
+ hsettings.el | 25 +++++++++++++++++++++++++
+ hyperbole.el | 26 --------------------------
+ 2 files changed, 25 insertions(+), 26 deletions(-)
+
+diff --git a/hsettings.el b/hsettings.el
+index 6cdd1b8..9632067 100644
+--- a/hsettings.el
++++ b/hsettings.el
+@@ -163,6 +163,31 @@ package to display search results."
+ 			      search-term)))
+       (user-error "(Hyperbole): Invalid web search service `%s'" service-name))))
+ 
++;;;###autoload
++(defun hyperbole-toggle-messaging (&optional arg)
++  "Toggle Hyperbole support for explicit buttons in mail and news buffers.
++Toggles the boolean variable `inhibit-hyperbole-messaging’ and either
++adds hooks (nil value) or removes them (t value).
++
++With optional prefix ARG > 0, enables support.  If ARG <= 0,
++disables/inhibits support."
++  (interactive "P")
++  (setq inhibit-hyperbole-messaging (if (null arg)
++					(not inhibit-hyperbole-messaging)
++				      (<= (prefix-numeric-value arg) 0)))
++  (if inhibit-hyperbole-messaging
++      (var:remove-all)
++    (var:append-all)
++    ;; Add any hooks that were skipped when inhibit-hyperbole-messaging
++    ;; was nil.
++    (cond ((boundp 'hyperbole-loading))
++	  ((not after-init-time)
++	   (add-hook 'after-init-hook (lambda () (load "hyperbole"))))
++	  (t (load "hyperbole"))))
++  (if (called-interactively-p 'interactive)
++      (message "Hyperbole messaging button support is %s"
++	       (if inhibit-hyperbole-messaging "disabled" "enabled"))))
++
+ (defcustom inhibit-hyperbole-messaging t
+   "*Determines whether Hyperbole supports explicit buttons in mail and news buffers.
+ The default of t means disable such support (work remains to
+diff --git a/hyperbole.el b/hyperbole.el
+index 4aa427d..872dbaf 100644
+--- a/hyperbole.el
++++ b/hyperbole.el
+@@ -121,32 +121,6 @@
+ 			    t)))
+     (error "(Hyperbole): Startup failure: `hyperb:dir' must be manually added to `load-path' to fix.")))
+ 
+-;; This must be defined before the defcustom `inhbit-hyperbole-messaging'.
+-;;;###autoload
+-(defun hyperbole-toggle-messaging (&optional arg)
+-  "Toggle Hyperbole support for explicit buttons in mail and news buffers.
+-Toggles the boolean variable `inhibit-hyperbole-messaging’ and either
+-adds hooks (nil value) or removes them (t value).
+-
+-With optional prefix ARG > 0, enables support.  If ARG <= 0,
+-disables/inhibits support."
+-  (interactive "P")
+-  (setq inhibit-hyperbole-messaging (if (null arg)
+-					(not inhibit-hyperbole-messaging)
+-				      (<= (prefix-numeric-value arg) 0)))
+-  (if inhibit-hyperbole-messaging
+-      (var:remove-all)
+-    (var:append-all)
+-    ;; Add any hooks that were skipped when inhibit-hyperbole-messaging
+-    ;; was nil.
+-    (cond ((boundp 'hyperbole-loading))
+-	  ((not after-init-time)
+-	   (add-hook 'after-init-hook (lambda () (load "hyperbole"))))
+-	  (t (load "hyperbole"))))
+-  (if (called-interactively-p 'interactive)
+-      (message "Hyperbole messaging button support is %s"
+-	       (if inhibit-hyperbole-messaging "disabled" "enabled"))))
+-
+ (defgroup hyperbole-koutliner nil
+   "Hyperbole multi-level autonumbered outliner customizations."
+   :group 'hyperbole)
+-- 
+2.22.0
+
diff --git a/gnu/packages/patches/ffmpeg-prefer-dav1d.patch b/gnu/packages/patches/ffmpeg-prefer-dav1d.patch
deleted file mode 100644
index 95e3712a7f..0000000000
--- a/gnu/packages/patches/ffmpeg-prefer-dav1d.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-When decoding AV1 files, prefer dav1d over libaom for performance
-reasons.
-
-Patch copied from upstream source repository:
-
-<https://git.videolan.org/gitweb.cgi/ffmpeg.git/?p=ffmpeg.git;a=commitdiff;h=dc0806dd25882f41f6085c8356712f95fded56c7>
-
-From dc0806dd25882f41f6085c8356712f95fded56c7 Mon Sep 17 00:00:00 2001
-From: James Almer <jamrial@gmail.com>
-Date: Sun, 15 Sep 2019 11:29:56 -0300
-Subject: [PATCH] avcodec/allcodecs: make libdav1d the preferred AV1 decoder
-
-It's considerably faster than libaom in most systems.
-
-Reviewed-by: BBB
-Signed-off-by: James Almer <jamrial@gmail.com>
----
- libavcodec/allcodecs.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libavcodec/allcodecs.c b/libavcodec/allcodecs.c
-index 5130fca026..d5dfba1877 100644
---- a/libavcodec/allcodecs.c
-+++ b/libavcodec/allcodecs.c
-@@ -680,7 +680,6 @@ extern AVCodec ff_pcm_mulaw_at_encoder;
- extern AVCodec ff_pcm_mulaw_at_decoder;
- extern AVCodec ff_qdmc_at_decoder;
- extern AVCodec ff_qdm2_at_decoder;
--extern AVCodec ff_libaom_av1_decoder;
- extern AVCodec ff_libaom_av1_encoder;
- extern AVCodec ff_libaribb24_decoder;
- extern AVCodec ff_libcelt_decoder;
-@@ -738,6 +737,7 @@ extern AVCodec ff_idf_decoder;
- /* external libraries, that shouldn't be used by default if one of the
-  * above is available */
- extern AVCodec ff_h263_v4l2m2m_encoder;
-+extern AVCodec ff_libaom_av1_decoder;
- extern AVCodec ff_libopenh264_encoder;
- extern AVCodec ff_libopenh264_decoder;
- extern AVCodec ff_h264_amf_encoder;
--- 
-2.20.1
-
diff --git a/gnu/packages/patches/iputils-libcap-compat.patch b/gnu/packages/patches/iputils-libcap-compat.patch
new file mode 100644
index 0000000000..dc6da310ce
--- /dev/null
+++ b/gnu/packages/patches/iputils-libcap-compat.patch
@@ -0,0 +1,37 @@
+Fix name clash with libcap 2.29.
+
+Taken from upstream:
+https://github.com/iputils/iputils/commit/18f9a84e0e702841d6cc4d5f593de4fbd1348e83
+
+diff --git a/ninfod/ninfod.c b/ninfod/ninfod.c
+--- a/ninfod/ninfod.c
++++ b/ninfod/ninfod.c
+@@ -455,7 +455,7 @@ static void do_daemonize(void)
+ /* --------- */
+ #ifdef HAVE_LIBCAP
+ static const cap_value_t cap_net_raw = CAP_NET_RAW;
+-static const cap_value_t cap_setuid =  CAP_SETUID; 
++static const cap_value_t cap_setuserid = CAP_SETUID;
+ static cap_flag_value_t cap_ok;
+ #else
+ static uid_t euid;
+@@ -487,7 +487,7 @@ static void limit_capabilities(void)
+ 
+ 	cap_get_flag(cap_cur_p, CAP_SETUID, CAP_PERMITTED, &cap_ok);
+ 	if (cap_ok != CAP_CLEAR)
+-		cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuid, CAP_SET);
++		cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuserid, CAP_SET);
+ 
+ 	if (cap_set_proc(cap_p) < 0) {
+ 		DEBUG(LOG_ERR, "cap_set_proc: %s\n", strerror(errno));
+@@ -520,8 +520,8 @@ static void drop_capabilities(void)
+ 
+ 	/* setuid / setuid */
+ 	if (cap_ok != CAP_CLEAR) {
+-		cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuid, CAP_SET);
+-		cap_set_flag(cap_p, CAP_EFFECTIVE, 1, &cap_setuid, CAP_SET);
++		cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuserid, CAP_SET);
++		cap_set_flag(cap_p, CAP_EFFECTIVE, 1, &cap_setuserid, CAP_SET);
+ 
+ 		if (cap_set_proc(cap_p) < 0) {
+ 			DEBUG(LOG_ERR, "cap_set_proc: %s\n", strerror(errno));
diff --git a/gnu/packages/patches/lib2geom-fix-tests.patch b/gnu/packages/patches/lib2geom-fix-tests.patch
new file mode 100644
index 0000000000..9118658e49
--- /dev/null
+++ b/gnu/packages/patches/lib2geom-fix-tests.patch
@@ -0,0 +1,172 @@
+From 488edbf84e918e0353e7a8f438abbf6eeca3767e Mon Sep 17 00:00:00 2001
+From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
+Date: Wed, 17 Jun 2020 23:20:53 -0400
+Subject: [PATCH] tests: Fix tests on non-x86_64 platforms.
+
+On platform other than x86_64 such as aarch64-linux or i686-linux,
+some double comparison would fail.
+
+See <http://issues.guix.gnu.org/41827>.
+
+* tests/bezier-test.cpp: (Casteljau): Replace EXPECT_EQ by
+EXPECT_near.
+(Subdivide): Replace EXPECT_EQ by EXPECT_DOUBLE_EQ.
+(Portion): Replace EXPECT_EQ by EXPECT_near.
+* tests/ellipse-test.cpp (BezierIntersection): Lower error tolerance
+from 6e-13 to 6e-12.
+* tests/line-test.cpp (Reflection): Replace EXPECT_FLOAT_EQ BY
+EXPECT_near.
+(Coefficients): Skip test.
+* tests/parallelogram-test.cpp (area): Replace EXPECT_EQ by
+EXPECT_DOUBLE_EQ.
+---
+ tests/bezier-test.cpp        | 31 +++++++++++++++++--------------
+ tests/ellipse-test.cpp       |  2 +-
+ tests/line-test.cpp          | 11 +++++++----
+ tests/parallelogram-test.cpp |  8 ++++----
+ 4 files changed, 29 insertions(+), 23 deletions(-)
+
+diff --git a/tests/bezier-test.cpp b/tests/bezier-test.cpp
+index 4054a65..46209f4 100644
+--- a/tests/bezier-test.cpp
++++ b/tests/bezier-test.cpp
+@@ -152,11 +152,13 @@ TEST_F(BezierTest, Casteljau) {
+         EXPECT_vector_equal(right2, right);
+ 
+         double vnone = casteljau_subdivision<double>(t, &wiggle[0], NULL, NULL, wiggle.order());
+-        EXPECT_EQ(vnone, vok);
++        EXPECT_near(vnone, vok, 1e-12);
+     }
+ }
+ 
+ TEST_F(BezierTest, Portion) {
++    constexpr Coord eps{1e-12};
++
+     for (unsigned i = 0; i < 10000; ++i) {
+         double from = g_random_double_range(0, 1);
+         double to = g_random_double_range(0, 1);
+@@ -165,8 +167,8 @@ TEST_F(BezierTest, Portion) {
+             Bezier result = portion(input, from, to);
+ 
+             // the endpoints must correspond exactly
+-            EXPECT_EQ(result.at0(), input.valueAt(from));
+-            EXPECT_EQ(result.at1(), input.valueAt(to));
++            EXPECT_near(result.at0(), input.valueAt(from), eps);
++            EXPECT_near(result.at1(), input.valueAt(to), eps);
+         }
+     }
+ }
+@@ -181,16 +183,16 @@ TEST_F(BezierTest, Subdivide) {
+ 
+             // the endpoints must correspond exactly
+             // moreover, the subdivision point must be exactly equal to valueAt(t)
+-            EXPECT_EQ(result.first.at0(), input.at0());
+-            EXPECT_EQ(result.first.at1(), result.second.at0());
+-            EXPECT_EQ(result.second.at0(), input.valueAt(t));
+-            EXPECT_EQ(result.second.at1(), input.at1());
++            EXPECT_DOUBLE_EQ(result.first.at0(), input.at0());
++            EXPECT_DOUBLE_EQ(result.first.at1(), result.second.at0());
++            EXPECT_DOUBLE_EQ(result.second.at0(), input.valueAt(t));
++            EXPECT_DOUBLE_EQ(result.second.at1(), input.at1());
+ 
+             // ditto for valueAt
+-            EXPECT_EQ(result.first.valueAt(0), input.valueAt(0));
+-            EXPECT_EQ(result.first.valueAt(1), result.second.valueAt(0));
+-            EXPECT_EQ(result.second.valueAt(0), input.valueAt(t));
+-            EXPECT_EQ(result.second.valueAt(1), input.valueAt(1));
++            EXPECT_DOUBLE_EQ(result.first.valueAt(0), input.valueAt(0));
++            EXPECT_DOUBLE_EQ(result.first.valueAt(1), result.second.valueAt(0));
++            EXPECT_DOUBLE_EQ(result.second.valueAt(0), input.valueAt(t));
++            EXPECT_DOUBLE_EQ(result.second.valueAt(1), input.valueAt(1));
+ 
+             if (result.first.at1() != result.second.at0()) {
+                 errors.push_back(std::pair<Bezier,double>(input, t));
+@@ -271,9 +273,10 @@ TEST_F(BezierTest, Deflate) {
+     EXPECT_FLOAT_EQ(0, b.at0());
+     b = b.deflate();
+     const double rootposition = (0.5-0.25) / (1-0.25);
+-    EXPECT_FLOAT_EQ(0, b.valueAt(rootposition));
++    constexpr Coord eps{1e-12};
++    EXPECT_near(0.0, b.valueAt(rootposition), eps);
+     b = b.subdivide(rootposition).second;
+-    EXPECT_FLOAT_EQ(0, b.at0());
++    EXPECT_near(0.0, b.at0(), eps);
+ }
+ 
+ TEST_F(BezierTest, Roots) {
+@@ -364,7 +367,7 @@ TEST_F(BezierTest, Operators) {
+         for(int i = 0; i <= 16; i++) {
+             double t = i/16.0;
+             double b = B.valueAt(t);
+-            EXPECT_FLOAT_EQ(b*b, product.valueAt(t));
++            EXPECT_near(b*b, product.valueAt(t), 1e-12);
+         }
+     }
+ }
+diff --git a/tests/ellipse-test.cpp b/tests/ellipse-test.cpp
+index 561c285..d6e65d8 100644
+--- a/tests/ellipse-test.cpp
++++ b/tests/ellipse-test.cpp
+@@ -199,7 +199,7 @@ TEST(EllipseTest, BezierIntersection) {
+     std::vector<ShapeIntersection> xs = e.intersect(b);
+ 
+     EXPECT_EQ(xs.size(), 2ul);
+-    EXPECT_intersections_valid(e, b, xs, 6e-13);
++    EXPECT_intersections_valid(e, b, xs, 6e-12);
+ }
+ 
+ TEST(EllipseTest, Coefficients) {
+diff --git a/tests/line-test.cpp b/tests/line-test.cpp
+index 99546dd..2399130 100644
+--- a/tests/line-test.cpp
++++ b/tests/line-test.cpp
+@@ -91,10 +91,12 @@ TEST(LineTest, Reflection) {
+ 
+     Point testra = pa * reflecta;
+     Point testrb = pb * reflectb;
+-    EXPECT_FLOAT_EQ(testra[X], ra[X]);
+-    EXPECT_FLOAT_EQ(testra[Y], ra[Y]);
+-    EXPECT_FLOAT_EQ(testrb[X], rb[X]);
+-    EXPECT_FLOAT_EQ(testrb[Y], rb[Y]);
++
++    constexpr Coord eps{1e-12};
++    EXPECT_near(testra[X], ra[X], eps);
++    EXPECT_near(testra[Y], ra[Y], eps);
++    EXPECT_near(testrb[X], rb[X], eps);
++    EXPECT_near(testrb[Y], rb[Y], eps);
+ }
+ 
+ TEST(LineTest, RotationToZero) {
+@@ -115,6 +117,7 @@ TEST(LineTest, RotationToZero) {
+ }
+ 
+ TEST(LineTest, Coefficients) {
++    GTEST_SKIP() << "This test fails on i686-linux and aarch64-linux";
+     std::vector<Line> lines;
+     lines.push_back(Line(Point(1e9,1e9), Point(1,1)));
+     //the case below will never work without normalizing the line
+diff --git a/tests/parallelogram-test.cpp b/tests/parallelogram-test.cpp
+index 8109ead..70ccea1 100644
+--- a/tests/parallelogram-test.cpp
++++ b/tests/parallelogram-test.cpp
+@@ -106,13 +106,13 @@ TEST(ParallelogramTest, area)
+ {
+     Rect r(2, 4, 7, 8);
+     Parallelogram p(r);
+-    EXPECT_EQ(p.area(), r.area());
++    EXPECT_DOUBLE_EQ(p.area(), r.area());
+     p *= Rotate(M_PI / 4.0); // 45°
+-    EXPECT_EQ(p.area(), r.area());
++    EXPECT_DOUBLE_EQ(p.area(), r.area());
+     p *= HShear(2);
+-    EXPECT_EQ(p.area(), r.area());
++    EXPECT_DOUBLE_EQ(p.area(), r.area());
+     p *= Scale(2);
+-    EXPECT_EQ(p.area(), r.area() * 4);
++    EXPECT_DOUBLE_EQ(p.area(), r.area() * 4);
+ }
+ 
+ class ParallelogramTest
+-- 
+2.26.2
+
diff --git a/gnu/packages/patches/lib2geom-link-tests-against-glib.patch b/gnu/packages/patches/lib2geom-link-tests-against-glib.patch
deleted file mode 100644
index 2b4f7ca6bf..0000000000
--- a/gnu/packages/patches/lib2geom-link-tests-against-glib.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From f95925afef451755fc1449e57fbfdc2e7277f4b4 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-Date: Sat, 11 Jan 2020 00:44:55 -0500
-Subject: [PATCH 1/3] tests: Link against GLib.
-
-This resolves an error about not finding <glib.h> when linking the
-tests that make use of GLib.
-
-* src/tests/CMakeLists.txt[2GEOM_GTESTS_SRC]: Add the glib library to
-the link target libraries.
----
- src/tests/CMakeLists.txt | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
-index 5ddf7f9c..626cfd87 100644
---- a/src/tests/CMakeLists.txt
-+++ b/src/tests/CMakeLists.txt
-@@ -32,8 +32,10 @@ sbasis-test
- 
- foreach(source ${2GEOM_GTESTS_SRC})
- 	add_executable(${source} ${source}.cpp)
--	target_include_directories(${source} PRIVATE ${GSL_INCLUDE_DIRS} ${GTK3_INCLUDE_DIRS})
--	target_link_libraries(${source} 2geom gtest_main gtest ${GSL_LIBRARIES} ${GTK3_LIBRARIES})
-+	target_include_directories(${source} PRIVATE ${GSL_INCLUDE_DIRS}
-+	  ${GTK3_INCLUDE_DIRS} ${GLIB_INCLUDE_DIRS})
-+	target_link_libraries(${source} 2geom gtest_main gtest ${GSL_LIBRARIES}
-+	  ${GTK3_LIBRARIES} ${GLIB_LIBRARIES})
- 	add_test(NAME ${source} COMMAND ${source})
- endforeach()
- 
--- 
-2.24.1
-
diff --git a/gnu/packages/patches/lib2geom-use-system-googletest.patch b/gnu/packages/patches/lib2geom-use-system-googletest.patch
deleted file mode 100644
index 16cce1799f..0000000000
--- a/gnu/packages/patches/lib2geom-use-system-googletest.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 6693b9c8ff1ae1ec02c9002c0a8f5f416f0c88f0 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-Date: Sun, 12 Jan 2020 23:23:33 -0500
-Subject: [PATCH 3/3] build: Prefer googletest from the system.
-
-Fixes issue #4.
-
-The build system now look for a system installed googletest or falls
-back to the bundled copy of googletest otherwise.
-
-* CMakeLists.txt: Add call to find_package(GTest).
-(include_directories): Remove "src/googletest/googletest/include" from
-arg.
-* src/CMakeLists.txt[NOT GTEST_FOUND]: Define the gtest and gtest_main
-libraries when GTEST_FOUND is false.  Globally include the googletest
-headers here.  Define aliases for the gtest and gtest_main libraries
-that match those defined by the FindGTest module.
-* src/tests/CMakeLists.txt: Replace references to gtest_main and gtest
-by GTest::Main and GTest::GTest, respectively.
----
- CMakeLists.txt           |  3 ++-
- src/CMakeLists.txt       | 15 +++++++++++----
- src/tests/CMakeLists.txt |  6 +++---
- 3 files changed, 16 insertions(+), 8 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bfeb8f03..96fbd58c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -25,13 +25,14 @@ find_package(DoubleConversion REQUIRED)
- find_package(PkgConfig REQUIRED)
- find_package(Cython)
- find_package(Threads)
-+find_package(GTest)
- pkg_check_modules(GTK3 gtk+-3.0)
- pkg_check_modules(GLIB glib-2.0)
- pkg_check_modules(CAIRO cairo)
- pkg_check_modules(GSL gsl)
- 
- # Add global include and link directories
--include_directories(src src/googletest/googletest/include ${CMAKE_CURRENT_BINARY_DIR})
-+include_directories(src ${CMAKE_CURRENT_BINARY_DIR})
- link_directories(${CMAKE_CURRENT_SOURCE_DIR}/src/2geom)
- 
- check_cxx_source_compiles("#include <math.h>\nint main() { double a=0.5,b=0.5,c=0.5; sincos(a, &b, &c); return 0; }" HAVE_SINCOS)
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index eefb3ac5..941dc4c7 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -1,7 +1,14 @@
--add_library(gtest SHARED googletest/googletest/src/gtest-all.cc)
--target_include_directories(gtest PRIVATE googletest/googletest)
--target_link_libraries(gtest Threads::Threads)
--add_library(gtest_main STATIC googletest/googletest/src/gtest_main.cc)
-+if(NOT GTEST_FOUND)
-+  message("No system googletest library: using bundled copy.")
-+  add_library(gtest SHARED googletest/googletest/src/gtest-all.cc)
-+  add_library(gtest_main STATIC googletest/googletest/src/gtest_main.cc)
-+  target_include_directories(gtest PRIVATE googletest/googletest)
-+  target_link_libraries(gtest Threads::Threads)
-+  include_directories(SYSTEM googletest/googletest/include)
-+  # Aliases to share the same nomenclature with FindGTest.
-+  add_library(GTest::GTest ALIAS gtest)
-+  add_library(GTest::Main ALIAS gtest_main)
-+endif()
- 
- add_subdirectory(2geom)
- add_subdirectory(tests)
-diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
-index 626cfd87..3538f8cf 100644
---- a/src/tests/CMakeLists.txt
-+++ b/src/tests/CMakeLists.txt
-@@ -34,15 +34,15 @@ foreach(source ${2GEOM_GTESTS_SRC})
- 	add_executable(${source} ${source}.cpp)
- 	target_include_directories(${source} PRIVATE ${GSL_INCLUDE_DIRS}
- 	  ${GTK3_INCLUDE_DIRS} ${GLIB_INCLUDE_DIRS})
--	target_link_libraries(${source} 2geom gtest_main gtest ${GSL_LIBRARIES}
--	  ${GTK3_LIBRARIES} ${GLIB_LIBRARIES})
-+	target_link_libraries(${source} 2geom GTest::Main GTest::GTest
-+	  ${GSL_LIBRARIES} ${GTK3_LIBRARIES} ${GLIB_LIBRARIES})
- 	add_test(NAME ${source} COMMAND ${source})
- endforeach()
- 
- foreach(source ${2GEOM_TESTS_SRC})
-     add_executable(${source} ${source}.cpp)
-     target_include_directories(${source} PRIVATE ${GSL_INCLUDE_DIRS} ${GTK3_INCLUDE_DIRS})
--    target_link_libraries(${source} 2geom gtest ${GSL_LIBRARIES} ${GTK3_LIBRARIES})
-+    target_link_libraries(${source} 2geom GTest::GTest ${GSL_LIBRARIES} ${GTK3_LIBRARIES})
-     add_test(NAME ${source} COMMAND ${source})
- endforeach(source)
- 
--- 
-2.24.1
-
diff --git a/gnu/packages/patches/python-memcached-syntax-warnings.patch b/gnu/packages/patches/python-memcached-syntax-warnings.patch
new file mode 100644
index 0000000000..f8690677c0
--- /dev/null
+++ b/gnu/packages/patches/python-memcached-syntax-warnings.patch
@@ -0,0 +1,24 @@
+Problem reported upstream:
+https://github.com/linsomniac/python-memcached/issues/176
+
+---
+ memcache.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/memcache.py b/memcache.py
+index 05b6657..b935681 100644
+--- a/memcache.py
++++ b/memcache.py
+@@ -1300,8 +1300,8 @@ class Client(threading.local):
+             key = key[1]
+         if key is None:
+             raise Client.MemcachedKeyNoneError("Key is None")
+-        if key is '':
+-            if key_extra_len is 0:
++        if key == '':
++            if key_extra_len == 0:
+                 raise Client.MemcachedKeyNoneError("Key is empty")
+
+             #  key is empty but there is some other component to key
+--
+2.26.2
diff --git a/gnu/packages/patches/quassel-qt-514-compat.patch b/gnu/packages/patches/quassel-qt-514-compat.patch
new file mode 100644
index 0000000000..7a0c42e8aa
--- /dev/null
+++ b/gnu/packages/patches/quassel-qt-514-compat.patch
@@ -0,0 +1,130 @@
+https://github.com/quassel/quassel/commit/579e559a6322209df7cd51c34801fecff5fe734b.patch
+
+Based on the above patch, with some changes due to how the code has changed
+in the time since 0.13.1 was released.
+
+https://git.archlinux.org/svntogit/community.git/plain/trunk/quassel-0.13.1-qt5.14.patch?h=packages/quassel
+
+From 579e559a6322209df7cd51c34801fecff5fe734b Mon Sep 17 00:00:00 2001
+From: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Tue, 7 Jan 2020 18:34:54 +0100
+Subject: [PATCH] common: Disable enum type stream operators for Qt >= 5.14
+
+Starting from version 5.14, Qt provides stream operators for enum
+types, which collide with the ones we ship in types.h. Disable
+Quassel's stream operators when compiling against Qt 5.14 or later.
+
+Add a unit test that ensures that enum serialization honors the width
+of the underlying type.
+---
+ src/common/types.h          |  2 +
+ tests/common/CMakeLists.txt |  2 +
+ tests/common/typestest.cpp  | 79 +++++++++++++++++++++++++++++++++++++
+ 3 files changed, 83 insertions(+)
+ create mode 100644 tests/common/typestest.cpp
+
+diff --git a/src/common/types.h b/src/common/types.h
+index d3742b788..e2a9aab5e 100644
+--- a/src/common/types.h
++++ b/src/common/types.h
+@@ -140,6 +140,7 @@ Q_DECLARE_METATYPE(QHostAddress)
+ typedef QList<MsgId> MsgIdList;
+ typedef QList<BufferId> BufferIdList;
+
++#if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+ /**
+   * Catch-all stream serialization operator for enum types.
+   *
+@@ -169,6 +170,7 @@ QDataStream &operator>>(QDataStream &in, T &value) {
+     value = static_cast<T>(v);
+     return in;
+ }
++#endif
+
+ // Exceptions
+
+diff --git a/tests/common/typestest.cpp b/tests/common/typestest.cpp
+new file mode 100644
+index 000000000..04031c299
+--- /dev/null
++++ b/tests/common/typestest.cpp
+@@ -0,0 +1,79 @@
++/***************************************************************************
++ *   Copyright (C) 2005-2020 by the Quassel Project                        *
++ *   devel@quassel-irc.org                                                 *
++ *                                                                         *
++ *   This program is free software; you can redistribute it and/or modify  *
++ *   it under the terms of the GNU General Public License as published by  *
++ *   the Free Software Foundation; either version 2 of the License, or     *
++ *   (at your option) version 3.                                           *
++ *                                                                         *
++ *   This program is distributed in the hope that it will be useful,       *
++ *   but WITHOUT ANY WARRANTY; without even the implied warranty of        *
++ *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the         *
++ *   GNU General Public License for more details.                          *
++ *                                                                         *
++ *   You should have received a copy of the GNU General Public License     *
++ *   along with this program; if not, write to the                         *
++ *   Free Software Foundation, Inc.,                                       *
++ *   51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.         *
++ ***************************************************************************/
++
++#include <cstdint>
++
++#include <QByteArray>
++#include <QDataStream>
++#include <QObject>
++
++#include "testglobal.h"
++#include "types.h"
++
++using namespace ::testing;
++
++class EnumHolder
++{
++    Q_GADGET
++
++public:
++    enum class Enum16 : uint16_t {};
++    enum class Enum32 : uint32_t {};
++
++    enum class EnumQt16 : uint16_t {};
++    Q_ENUM(EnumQt16)
++    enum class EnumQt32 : uint32_t {};
++    Q_ENUM(EnumQt32)
++};
++
++// Verify that enums are (de)serialized as their underlying type
++TEST(TypesTest, enumSerialization)
++{
++    QByteArray data;
++    QDataStream out(&data, QIODevice::WriteOnly);
++
++    // Serialize
++    out << EnumHolder::Enum16(0xabcd);
++    ASSERT_THAT(data.size(), Eq(2));
++    out << EnumHolder::Enum32(0x123456);
++    ASSERT_THAT(data.size(), Eq(6));
++    out << EnumHolder::EnumQt16(0x4321);
++    ASSERT_THAT(data.size(), Eq(8));
++    out << EnumHolder::Enum32(0xfedcba);
++    ASSERT_THAT(data.size(), Eq(12));
++    ASSERT_THAT(out.status(), Eq(QDataStream::Status::Ok));
++
++    // Deserialize
++    QDataStream in(data);
++    EnumHolder::Enum16 enum16;
++    EnumHolder::Enum32 enum32;
++    EnumHolder::EnumQt16 enumQt16;
++    EnumHolder::EnumQt32 enumQt32;
++    in >> enum16  >> enum32 >> enumQt16 >> enumQt32;
++    ASSERT_THAT(in.status(), Eq(QDataStream::Status::Ok));
++    EXPECT_TRUE(in.atEnd());
++
++    EXPECT_THAT((int)enum16, Eq(0xabcd));
++    EXPECT_THAT((int)enum32, Eq(0x123456));
++    EXPECT_THAT((int)enumQt16, Eq(0x4321));
++    EXPECT_THAT((int)enumQt32, Eq(0xfedcba));
++}
++
++#include "typestest.moc"
diff --git a/gnu/packages/patches/tup-unbundle-dependencies.patch b/gnu/packages/patches/tup-unbundle-dependencies.patch
new file mode 100644
index 0000000000..6409522bd3
--- /dev/null
+++ b/gnu/packages/patches/tup-unbundle-dependencies.patch
@@ -0,0 +1,66 @@
+Allow building tup after removing some bundled sources from the source
+tree.
+
+diff --git a/build.sh b/build.sh
+index 2937116d..eab650f7 100755
+--- a/build.sh
++++ b/build.sh
+@@ -16,7 +16,7 @@ else
+ 	echo "Error: invalid TUP_SERVER \"$server\"" 1>&2
+ 	exit 1
+ fi
+-LDFLAGS="$LDFLAGS -lm"
++LDFLAGS="$LDFLAGS -lm -lsqlite3 `pcre-config --libs`"
+ : ${CC:=gcc}
+ case "$os" in
+ 	Linux)
+@@ -65,17 +65,15 @@ mkdir luabuiltin
+ 
+ CFLAGS="$CFLAGS -DTUP_SERVER=\"$server\""
+ CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
++CFLAGS="$CFLAGS `pcre-config --cflags`"
+ 
+-for i in ../src/tup/*.c ../src/tup/tup/main.c ../src/tup/monitor/null.c ../src/tup/flock/fcntl.c ../src/inih/ini.c ../src/pcre/*.c $plat_files; do
++for i in ../src/tup/*.c ../src/tup/tup/main.c ../src/tup/monitor/null.c ../src/tup/flock/fcntl.c ../src/inih/ini.c $plat_files; do
+ 	echo "  bootstrap CC $CFLAGS $i"
+ 	# Put -I. first so we find our new luabuiltin.h file, not one built
+ 	# by a previous 'tup upd'.
+-	$CC $CFLAGS -c $i -I. -I../src -I../src/pcre $plat_cflags
++	$CC $CFLAGS -c $i -I. -I../src $plat_cflags
+ done
+ 
+-echo "  bootstrap CC $CFLAGS ../src/sqlite3/sqlite3.c"
+-$CC $CFLAGS -c ../src/sqlite3/sqlite3.c -DSQLITE_TEMP_STORE=2 -DSQLITE_THREADSAFE=0 -DSQLITE_OMIT_LOAD_EXTENSION $plat_cflags
+-
+ echo "  bootstrap LD tup $LDFLAGS"
+ echo "const char *tup_version(void) {return \"$label\";}" | $CC -x c -c - -o tup_version.o
+ $CC *.o -o tup -lpthread $plat_ldflags $LDFLAGS
+diff --git a/src/tup/db.c b/src/tup/db.c
+index 55ee3edd..9bdf7a80 100644
+--- a/src/tup/db.c
++++ b/src/tup/db.c
+@@ -46,7 +46,7 @@
+ #include <errno.h>
+ #include <ctype.h>
+ #include <sys/stat.h>
+-#include "sqlite3/sqlite3.h"
++#include <sqlite3.h>
+ 
+ #define DB_VERSION 17
+ #define PARSER_VERSION 12
+diff --git a/src/tup/tupid.h b/src/tup/tupid.h
+index 7b36ae46..19aed438 100644
+--- a/src/tup/tupid.h
++++ b/src/tup/tupid.h
+@@ -21,7 +21,7 @@
+ #ifndef tup_tupid_h
+ #define tup_tupid_h
+ 
+-#include "sqlite3/sqlite3.h"
++#include <sqlite3.h>
+ 
+ typedef sqlite3_int64 tupid_t;
+ 
+-- 
+2.26.2
+
diff --git a/gnu/packages/patches/xmoto-remove-glext.patch b/gnu/packages/patches/xmoto-remove-glext.patch
deleted file mode 100644
index ad0c848d1d..0000000000
--- a/gnu/packages/patches/xmoto-remove-glext.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Description: Allow building without upstream-supplied glext.h
-Author: Stephen Kitt <steve@sk2.org>
-Bug: http://todo.xmoto.tuxfamily.org/index.php?do=details&task_id=803
-
---- xmoto-0.5.9+dfsg.orig/src/include/xm_OpenGL.h
-+++ xmoto-0.5.9+dfsg/src/include/xm_OpenGL.h
-@@ -1,7 +1,6 @@
- #ifdef ENABLE_OPENGL
- /* Pull in OpenGL headers */
- /* following scissored from SDL_opengl.h */
--#define __glext_h_  /* Don't let gl.h include glext.h */
- #ifdef HAVE_APPLE_OPENGL_FRAMEWORK
- #include <OpenGL/gl.h>	/* Header File For The OpenGL Library */
- #include <OpenGL/glu.h>	/* Header File For The GLU Library */
-@@ -12,8 +11,5 @@
- #include <GL/gl.h>	/* Header File For The OpenGL Library */
- #include <GL/glu.h>	/* Header File For The GLU Library */
- #endif
--#undef __glext_h_
--
--#include "../glext.h"
- 
- #endif
diff --git a/gnu/packages/patches/xmoto-reproducible.patch b/gnu/packages/patches/xmoto-reproducible.patch
deleted file mode 100644
index 606f4ec714..0000000000
--- a/gnu/packages/patches/xmoto-reproducible.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Description: Avoid __DATE__ and __TIME__ to build reproducibly
-Author: Stephen Kitt <skitt@debian.org>
-
---- a/src/GameInit.cpp
-+++ b/src/GameInit.cpp
-@@ -248,7 +248,6 @@
-   Logger::setActiv(XMSession::instance()->noLog() == false); /* apply log activ mode */
- 
-   LogInfo(std::string("X-Moto " + XMBuild::getVersionString(true)).c_str());
--  LogInfo("compiled at "__DATE__" "__TIME__);
-   if(SwapEndian::bigendien) {
-     LogInfo("Systeme is bigendien");
-   } else {
---- a/src/states/StateOptions.cpp
-+++ b/src/states/StateOptions.cpp
-@@ -1233,8 +1233,6 @@
-   int p=25;
-   makeWindowOptions_infos_line(v_window, "Version", "X-Moto " + XMBuild::getVersionString(true), p);
-   p+=20;
--  makeWindowOptions_infos_line(v_window, "Compilation date", __DATE__ " " __TIME__, p);
--  p+=20;
-   makeWindowOptions_infos_line(v_window, "User data directory", XMFS::getUserDir(FDT_DATA), p);
-   p+=20;
-   makeWindowOptions_infos_line(v_window, "User config directory", XMFS::getUserDir(FDT_CONFIG), p);
diff --git a/gnu/packages/patches/xmoto-utf8.patch b/gnu/packages/patches/xmoto-utf8.patch
deleted file mode 100644
index e5d0dfb2a4..0000000000
--- a/gnu/packages/patches/xmoto-utf8.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Build with g++'s new utf8.h
-Author: Stephen Kitt <skitt@debian.org>
-
---- a/src/helpers/utf8.h
-+++ b/src/helpers/utf8.h
-@@ -18,8 +18,8 @@
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
- =============================================================================*/
- 
--#ifndef __UTF8_H__
--#define __UTF8_H__
-+#ifndef __XMOTO_UTF8_H__
-+#define __XMOTO_UTF8_H__
- 
- #include <vector>
- #include <string>