summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/qemu-multiple-smb-shares.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/qemu-multiple-smb-shares.patch b/gnu/packages/patches/qemu-multiple-smb-shares.patch
new file mode 100644
index 0000000000..c20066cbfe
--- /dev/null
+++ b/gnu/packages/patches/qemu-multiple-smb-shares.patch
@@ -0,0 +1,20 @@
+This file extends `-smb' to add a share for the Nix store, and changes
+the name of the default share.
+
+--- a/net/slirp.c
++++ b/net/slirp.c
+@@ -515,8 +515,12 @@ static int slirp_smb(SlirpState* s, const char *exported_dir,
+             "log file=%s/log.smbd\n"
+             "smb passwd file=%s/smbpasswd\n"
+             "security = share\n"
+-            "[qemu]\n"
+-            "path=%s\n"
++            "[store]\n"
++            "path=/nix/store\n"
++            "read only=yes\n"
++            "guest ok=yes\n"
++            "[xchg]\n"
++            "path=%s/xchg\n"
+             "read only=no\n"
+             "guest ok=yes\n",
+             s->smb_dir,