summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/duplicity-piped-password.patch20
-rw-r--r--gnu/packages/patches/duplicity-test_selection-tmp.patch18
2 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/duplicity-piped-password.patch b/gnu/packages/patches/duplicity-piped-password.patch
new file mode 100644
index 0000000000..db50f5df32
--- /dev/null
+++ b/gnu/packages/patches/duplicity-piped-password.patch
@@ -0,0 +1,20 @@
+This test, on three occasions, is failing with the error:
+
+  EOF: End Of File (EOF) in read_nonblocking(). Braindead platform.
+
+--- duplicity-0.6.24/testing/functional/test_final.py	2014-09-28 13:14:52.146001614 -0500
++++ duplicity-0.6.24/testing/functional/test_final.py	2014-09-28 13:13:20.333546342 -0500
+@@ -156,13 +156,6 @@
+         self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
+         self.assertEqual(self.get_backend_files(), second_chain)
+ 
+-    def test_piped_password(self):
+-        """Make sure that prompting for a password works"""
+-        self.set_environ("PASSPHRASE", None)
+-        self.backup("full", "testfiles/empty_dir",
+-                    passphrase_input=[self.sign_passphrase, self.sign_passphrase])
+-        self.restore(passphrase_input=[self.sign_passphrase])
+-
+ 
+ class OldFilenamesFinalTest(FinalTest):
+ 
diff --git a/gnu/packages/patches/duplicity-test_selection-tmp.patch b/gnu/packages/patches/duplicity-test_selection-tmp.patch
new file mode 100644
index 0000000000..8f66be4dcc
--- /dev/null
+++ b/gnu/packages/patches/duplicity-test_selection-tmp.patch
@@ -0,0 +1,18 @@
+Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
+
+--- duplicity-0.6.24/testing/unit/test_selection.py	2014-05-09 08:27:40.000000000 -0500
++++ duplicity-0.6.24/testing/unit/test_selection.py	2014-09-28 12:28:53.932324380 -0500
+@@ -431,10 +431,10 @@
+                        [(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
+ 
+         self.root = Path("/")
+-        self.ParseTest([("--exclude", "/home/*"),
+-                        ("--include", "/home"),
++        self.ParseTest([("--exclude", "/tmp/*"),
++                        ("--include", "/tmp"),
+                         ("--exclude", "/")],
+-                       [(), ("home",)])
++                       [(), ("tmp",)])
+ 
+ if __name__ == "__main__":
+     unittest.main()