summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bcftools-regidx-unsigned-char.patch16
-rw-r--r--gnu/packages/patches/ceph-skip-collect-sys-info-test.patch11
-rw-r--r--gnu/packages/patches/freeimage-unbundle.patch18
-rw-r--r--gnu/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch81
-rw-r--r--gnu/packages/patches/pcmanfm-CVE-2017-8934.patch56
-rw-r--r--gnu/packages/patches/pt-scotch-build-parallelism.patch13
-rw-r--r--gnu/packages/patches/qemu-CVE-2018-7550.patch66
-rw-r--r--gnu/packages/patches/quassel-fix-tls-check.patch25
-rw-r--r--gnu/packages/patches/scotch-build-parallelism.patch39
-rw-r--r--gnu/packages/patches/scotch-graph-diam-64.patch27
-rw-r--r--gnu/packages/patches/scotch-graph-induce-type-64.patch19
-rw-r--r--gnu/packages/patches/zsh-CVE-2018-7548.patch48
-rw-r--r--gnu/packages/patches/zsh-CVE-2018-7549.patch56
13 files changed, 172 insertions, 303 deletions
diff --git a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
deleted file mode 100644
index af5bc160f5..0000000000
--- a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Fix test-regidx argument parsing on archs with unsigned char
- On architectures where char is unsigned "c >= 0" was always true.
-Author: Adrian Bunk <bunk@debian.org>
-Bug-Debian: https://bugs.debian.org/865060
-
---- a/test/test-regidx.c
-+++ b/test/test-regidx.c
-@@ -336,7 +336,7 @@
-         {"seed",1,0,'s'},
-         {0,0,0,0}
-     };
--    char c;
-+    int c;
-     int seed = (int)time(NULL);
-     while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0) 
-     {
diff --git a/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
index f210799254..429087c661 100644
--- a/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
+++ b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
@@ -1,14 +1,13 @@
 This test fails because /etc/os-release is not available.
 
 diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
-index 288dd37db1..95b6cd4b30 100644
+index 64eace923c..6daf4aa514 100644
 --- a/src/test/common/test_util.cc
 +++ b/src/test/common/test_util.cc
-@@ -31,19 +31,3 @@ TEST(util, unit_to_bytesize)
- 
+@@ -32,17 +32,3 @@ TEST(util, unit_to_bytesize)
    ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
  }
--
+ 
 -#if defined(__linux__)
 -TEST(util, collect_sys_info)
 -{
@@ -18,12 +17,8 @@ index 288dd37db1..95b6cd4b30 100644
 -  collect_sys_info(&sys_info, cct);
 -
 -  ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
--  ASSERT_TRUE(sys_info.find("distro_version") != sys_info.end());
 -  ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
 -
 -  cct->put();
 -}
 -#endif
--- 
-2.11.1
-
diff --git a/gnu/packages/patches/freeimage-unbundle.patch b/gnu/packages/patches/freeimage-unbundle.patch
index 2727d9fbda..ca907d3276 100644
--- a/gnu/packages/patches/freeimage-unbundle.patch
+++ b/gnu/packages/patches/freeimage-unbundle.patch
@@ -25,7 +25,7 @@ diff -rupN FreeImage/gensrclist.sh FreeImage-new/gensrclist.sh
  #!/bin/sh
  
 -DIRLIST=". Source Source/Metadata Source/FreeImageToolkit Source/LibJPEG Source/LibPNG Source/LibTIFF4 Source/ZLib Source/LibOpenJPEG Source/OpenEXR Source/OpenEXR/Half Source/OpenEXR/Iex Source/OpenEXR/IlmImf Source/OpenEXR/IlmThread Source/OpenEXR/Imath Source/OpenEXR/IexMath Source/LibRawLite Source/LibRawLite/dcraw Source/LibRawLite/internal Source/LibRawLite/libraw Source/LibRawLite/src Source/LibWebP Source/LibJXR Source/LibJXR/common/include Source/LibJXR/image/sys Source/LibJXR/jxrgluelib"
-+DIRLIST=". Source Source/Metadata Source/FreeImageToolkit"
++DIRLIST=". Source Source/Metadata Source/FreeImageToolkit Source/LibJXR Source/LibJXR/common/include Source/LibJXR/image/sys Source/LibJXR/jxrgluelib"
  
  echo "VER_MAJOR = 3" > Makefile.srcs
  echo "VER_MINOR = 17.0" >> Makefile.srcs
@@ -90,8 +90,8 @@ diff -rupN FreeImage/Makefile.gnu FreeImage-new/Makefile.gnu
 -# LibJXR
 -CXXFLAGS += -D__ANSI__
 -CXXFLAGS += $(INCLUDE)
-+override CFLAGS += $(INCLUDE) -D__ANSI__ -I/usr/include/jxrlib $(shell pkg-config --cflags OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
-+override LDFLAGS += -ljpeg -ljpegxr -ljxrglue $(shell pkg-config --libs OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
++override CFLAGS += $(INCLUDE) -D__ANSI__ $(shell pkg-config --cflags OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
++override LDFLAGS += -ljpeg $(shell pkg-config --libs OpenEXR libopenjp2 libraw libpng libtiff-4 libwebp libwebpmux zlib)
  
  ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
 -	CFLAGS += -fPIC
@@ -215,18 +215,6 @@ diff -rupN FreeImage/Source/FreeImage/PluginJPEG.cpp FreeImage-new/Source/FreeIm
  }
  
  #include "FreeImage.h"
-diff -rupN FreeImage/Source/FreeImage/PluginJXR.cpp FreeImage-new/Source/FreeImage/PluginJXR.cpp
---- FreeImage/Source/FreeImage/PluginJXR.cpp	2015-03-02 02:07:08.000000000 +0100
-+++ FreeImage-new/Source/FreeImage/PluginJXR.cpp	2015-09-05 02:13:52.043353343 +0200
-@@ -23,7 +23,7 @@
- #include "Utilities.h"
- #include "../Metadata/FreeImageTag.h"
- 
--#include "../LibJXR/jxrgluelib/JXRGlue.h"
-+#include <JXRGlue.h>
- 
- // ==========================================================
- // Plugin Interface
 diff -rupN FreeImage/Source/FreeImage/PluginPNG.cpp FreeImage-new/Source/FreeImage/PluginPNG.cpp
 --- FreeImage/Source/FreeImage/PluginPNG.cpp	2015-03-10 20:16:12.000000000 +0100
 +++ FreeImage-new/Source/FreeImage/PluginPNG.cpp	2015-09-05 02:13:52.044353363 +0200
diff --git a/gnu/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch b/gnu/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch
new file mode 100644
index 0000000000..506de833dd
--- /dev/null
+++ b/gnu/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch
@@ -0,0 +1,81 @@
+From 29055a825af5405e44ffcd59a776f8952bdc7203 Mon Sep 17 00:00:00 2001
+From: Julien Lepiller <julien@lepiller.eu>
+Date: Fri, 15 Dec 2017 16:03:23 +0100
+Subject: [PATCH] Port to latest bouncycastle.
+
+---
+ .../bouncycastle/OpenPGPSignatureGenerator.java    | 34 ++++++++++------------
+ 1 file changed, 16 insertions(+), 18 deletions(-)
+
+diff --git a/src/java/org/apache/ivy/plugins/signer/bouncycastle/OpenPGPSignatureGenerator.java b/src/java/org/apache/ivy/plugins/signer/bouncycastle/OpenPGPSignatureGenerator.java
+index af7beae..34c204f 100644
+--- a/src/java/org/apache/ivy/plugins/signer/bouncycastle/OpenPGPSignatureGenerator.java
++++ b/src/java/org/apache/ivy/plugins/signer/bouncycastle/OpenPGPSignatureGenerator.java
+@@ -41,6 +41,11 @@ import org.bouncycastle.openpgp.PGPSecretKeyRingCollection;
+ import org.bouncycastle.openpgp.PGPSignature;
+ import org.bouncycastle.openpgp.PGPSignatureGenerator;
+ import org.bouncycastle.openpgp.PGPUtil;
++import org.bouncycastle.openpgp.operator.PBESecretKeyDecryptor;
++import org.bouncycastle.openpgp.operator.bc.BcPBESecretKeyDecryptorBuilder;
++import org.bouncycastle.openpgp.operator.bc.BcPGPDigestCalculatorProvider;
++import org.bouncycastle.openpgp.operator.bc.BcPGPContentSignerBuilder;
++import org.bouncycastle.openpgp.operator.bc.BcKeyFingerprintCalculator;
+ 
+ public class OpenPGPSignatureGenerator implements SignatureGenerator {
+ 
+@@ -101,11 +106,15 @@ public class OpenPGPSignatureGenerator implements SignatureGenerator {
+                 pgpSec = readSecretKey(keyIn);
+             }
+ 
+-            PGPPrivateKey pgpPrivKey = pgpSec.extractPrivateKey(password.toCharArray(),
+-                BouncyCastleProvider.PROVIDER_NAME);
+-            PGPSignatureGenerator sGen = new PGPSignatureGenerator(pgpSec.getPublicKey()
+-                    .getAlgorithm(), PGPUtil.SHA1, BouncyCastleProvider.PROVIDER_NAME);
+-            sGen.initSign(PGPSignature.BINARY_DOCUMENT, pgpPrivKey);
++            PBESecretKeyDecryptor decryptor =
++                    new BcPBESecretKeyDecryptorBuilder(new BcPGPDigestCalculatorProvider())
++                    .build(password.toCharArray());
++            PGPPrivateKey pgpPrivKey = pgpSec.extractPrivateKey(decryptor);
++            BcPGPContentSignerBuilder builder = new BcPGPContentSignerBuilder(
++                            pgpSec.getPublicKey().getAlgorithm(), PGPUtil.SHA1);
++
++            PGPSignatureGenerator sGen = new PGPSignatureGenerator(builder);
++            sGen.init(PGPSignature.BINARY_DOCUMENT, pgpPrivKey);
+ 
+             in = new FileInputStream(src);
+             out = new BCPGOutputStream(new ArmoredOutputStream(new FileOutputStream(dest)));
+@@ -116,22 +125,10 @@ public class OpenPGPSignatureGenerator implements SignatureGenerator {
+             }
+ 
+             sGen.generate().encode(out);
+-        } catch (SignatureException e) {
+-            IOException ioexc = new IOException();
+-            ioexc.initCause(e);
+-            throw ioexc;
+         } catch (PGPException e) {
+             IOException ioexc = new IOException();
+             ioexc.initCause(e);
+             throw ioexc;
+-        } catch (NoSuchAlgorithmException e) {
+-            IOException ioexc = new IOException();
+-            ioexc.initCause(e);
+-            throw ioexc;
+-        } catch (NoSuchProviderException e) {
+-            IOException ioexc = new IOException();
+-            ioexc.initCause(e);
+-            throw ioexc;
+         } finally {
+             if (out != null) {
+                 try {
+@@ -156,7 +153,8 @@ public class OpenPGPSignatureGenerator implements SignatureGenerator {
+ 
+     private PGPSecretKey readSecretKey(InputStream in) throws IOException, PGPException {
+         in = PGPUtil.getDecoderStream(in);
+-        PGPSecretKeyRingCollection pgpSec = new PGPSecretKeyRingCollection(in);
++        PGPSecretKeyRingCollection pgpSec = new PGPSecretKeyRingCollection(in,
++                        new BcKeyFingerprintCalculator());
+ 
+         PGPSecretKey key = null;
+         for (Iterator it = pgpSec.getKeyRings(); key == null && it.hasNext();) {
+-- 
+2.15.1
diff --git a/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch b/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch
deleted file mode 100644
index 489d22c83b..0000000000
--- a/gnu/packages/patches/pcmanfm-CVE-2017-8934.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From bc8c3d871e9ecc67c47ff002b68cf049793faf08 Mon Sep 17 00:00:00 2001
-From: Andriy Grytsenko <andrej@rep.kiev.ua>
-Date: Sun, 14 May 2017 21:35:40 +0300
-Subject: [PATCH] Fix potential access violation, use runtime user dir instead
- of tmp dir.
-
----
- NEWS              | 4 ++++
- src/single-inst.c | 7 ++++++-
- 2 files changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/NEWS b/NEWS
-index 8c2049a..876f7f3 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,3 +1,7 @@
-+* Fixed potential access violation, use runtime user dir instead of tmp dir
-+    for single instance socket.
-+
-+
- Changes on 1.2.5 since 1.2.4:
- 
- * Removed options to Cut, Remove and Rename from context menu on mounted
-diff --git a/src/single-inst.c b/src/single-inst.c
-index 62c37b3..aaf84ab 100644
---- a/src/single-inst.c
-+++ b/src/single-inst.c
-@@ -2,7 +2,7 @@
-  *      single-inst.c: simple IPC mechanism for single instance app
-  *
-  *      Copyright 2010 Hong Jen Yee (PCMan) <pcman.tw@gmail.com>
-- *      Copyright 2012 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
-+ *      Copyright 2012-2017 Andriy Grytsenko (LStranger) <andrej@rep.kiev.ua>
-  *
-  *      This program is free software; you can redistribute it and/or modify
-  *      it under the terms of the GNU General Public License as published by
-@@ -404,11 +404,16 @@ static void get_socket_name(SingleInstData* data, char* buf, int len)
-     }
-     else
-         dpynum = 0;
-+#if GLIB_CHECK_VERSION(2, 28, 0)
-+    g_snprintf(buf, len, "%s/%s-socket-%s-%d", g_get_user_runtime_dir(),
-+               data->prog_name, host ? host : "", dpynum);
-+#else
-     g_snprintf(buf, len, "%s/.%s-socket-%s-%d-%s",
-                 g_get_tmp_dir(),
-                 data->prog_name,
-                 host ? host : "",
-                 dpynum,
-                 g_get_user_name());
-+#endif
- }
- 
--- 
-2.1.4
-
diff --git a/gnu/packages/patches/pt-scotch-build-parallelism.patch b/gnu/packages/patches/pt-scotch-build-parallelism.patch
deleted file mode 100644
index 2ac5f27f52..0000000000
--- a/gnu/packages/patches/pt-scotch-build-parallelism.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Building with -j may cause the esmumps_main target to fail with a "no rule for
-dependency libptesmumps.a" error.  Fix the dependency name.
-
---- scotch_6.0.4/src/esmumps/Makefile	2012-12-01 08:29:29.000000000 -0600
-+++ scotch_6.0.4/src/esmumps/Makefile	2015-06-15 17:29:23.279605734 -0500
-@@ -160,6 +160,6 @@
- 					order.h					\
- 					symbol.h				\
- 					esmumps.h				\
--					lib$(ESMUMPSLIB)$(LIB)			\
-+					libesmumps$(LIB)			\
- 					$(libdir)/lib$(SCOTCHLIB)$(LIB)		\
- 					$(libdir)/lib$(SCOTCHLIB)errexit$(LIB)
diff --git a/gnu/packages/patches/qemu-CVE-2018-7550.patch b/gnu/packages/patches/qemu-CVE-2018-7550.patch
deleted file mode 100644
index 43f111e206..0000000000
--- a/gnu/packages/patches/qemu-CVE-2018-7550.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-Fix CVE-2018-7550:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7550
-
-Patch copied from upstream source repository:
-
-https://git.qemu.org/?p=qemu.git;a=patch;h=2a8fcd119eb7c6bb3837fc3669eb1b2dfb31daf8
-
-From 2a8fcd119eb7c6bb3837fc3669eb1b2dfb31daf8 Mon Sep 17 00:00:00 2001
-From: Jack Schwartz <jack.schwartz@oracle.com>
-Date: Thu, 21 Dec 2017 09:25:15 -0800
-Subject: [PATCH] multiboot: bss_end_addr can be zero
-
-The multiboot spec (https://www.gnu.org/software/grub/manual/multiboot/),
-section 3.1.3, allows for bss_end_addr to be zero.
-
-A zero bss_end_addr signifies there is no .bss section.
-
-Suggested-by: Daniel Kiper <daniel.kiper@oracle.com>
-Signed-off-by: Jack Schwartz <jack.schwartz@oracle.com>
-Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
-Reviewed-by: Prasad J Pandit <pjp@fedoraproject.org>
-Signed-off-by: Kevin Wolf <kwolf@redhat.com>
----
- hw/i386/multiboot.c | 18 ++++++++++--------
- 1 file changed, 10 insertions(+), 8 deletions(-)
-
-diff --git a/hw/i386/multiboot.c b/hw/i386/multiboot.c
-index 46d9c68bf5..bb8d8e4629 100644
---- a/hw/i386/multiboot.c
-+++ b/hw/i386/multiboot.c
-@@ -233,12 +233,6 @@ int load_multiboot(FWCfgState *fw_cfg,
-         mh_entry_addr = ldl_p(header+i+28);
- 
-         if (mh_load_end_addr) {
--            if (mh_bss_end_addr < mh_load_addr) {
--                fprintf(stderr, "invalid mh_bss_end_addr address\n");
--                exit(1);
--            }
--            mb_kernel_size = mh_bss_end_addr - mh_load_addr;
--
-             if (mh_load_end_addr < mh_load_addr) {
-                 fprintf(stderr, "invalid mh_load_end_addr address\n");
-                 exit(1);
-@@ -249,8 +243,16 @@ int load_multiboot(FWCfgState *fw_cfg,
-                 fprintf(stderr, "invalid kernel_file_size\n");
-                 exit(1);
-             }
--            mb_kernel_size = kernel_file_size - mb_kernel_text_offset;
--            mb_load_size = mb_kernel_size;
-+            mb_load_size = kernel_file_size - mb_kernel_text_offset;
-+        }
-+        if (mh_bss_end_addr) {
-+            if (mh_bss_end_addr < (mh_load_addr + mb_load_size)) {
-+                fprintf(stderr, "invalid mh_bss_end_addr address\n");
-+                exit(1);
-+            }
-+            mb_kernel_size = mh_bss_end_addr - mh_load_addr;
-+        } else {
-+            mb_kernel_size = mb_load_size;
-         }
- 
-         /* Valid if mh_flags sets MULTIBOOT_HEADER_HAS_VBE.
--- 
-2.17.0
-
diff --git a/gnu/packages/patches/quassel-fix-tls-check.patch b/gnu/packages/patches/quassel-fix-tls-check.patch
deleted file mode 100644
index 057bc02a14..0000000000
--- a/gnu/packages/patches/quassel-fix-tls-check.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-This allows quasselclient to connect to SSL-enabled quasselcore instances.
-
-The check in qglobal.h requires -fPIC (not -fPIE as it is now). When this check
-fails SSL / TLS is disabled.
-
-This patch comes from the upstream source repository [0] and can be
-removed when the next version is packaged.
-
-[0] https://github.com/quassel/quassel/commit/4768c9e99f99b581d4e32e797db91d0182391696
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -428,6 +428,11 @@ endif()
- cmake_push_check_state(RESET)
- set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-+
-+if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
-+    set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
-+endif()
-+
- check_cxx_source_compiles("
-     #include \"qglobal.h\"
-     #if defined QT_NO_SSL
-
diff --git a/gnu/packages/patches/scotch-build-parallelism.patch b/gnu/packages/patches/scotch-build-parallelism.patch
new file mode 100644
index 0000000000..a669f1dbeb
--- /dev/null
+++ b/gnu/packages/patches/scotch-build-parallelism.patch
@@ -0,0 +1,39 @@
+Fixes make with -j, otherwise scotch.h may not be generated by the time make
+tries to compile library_graph_diam.o et al.
+
+Reported upstream at
+https://gforge.inria.fr/tracker/index.php?func=detail&aid=21651&group_id=248&atid=1081
+
+diff --git a/src/libscotch/Makefile b/src/libscotch/Makefile
+index 9898894..b0ee14c 100644
+--- a/src/libscotch/Makefile
++++ b/src/libscotch/Makefile
+@@ -2229,6 +2229,28 @@ library_graph_color_f$(OBJ)	:	library_graph_color_f.c			\
+ 					common.h				\
+ 					scotch.h
+ 
++library_graph_diam$(OBJ)	:	library_graph_diam.c			\
++					module.h				\
++					common.h				\
++					graph.h					\
++					scotch.h
++
++library_graph_diam_f$(OBJ)	:	library_graph_diam.c			\
++					module.h				\
++					common.h				\
++					scotch.h
++
++library_graph_induce$(OBJ)	:	library_graph_diam.c			\
++					module.h				\
++					common.h				\
++					graph.h					\
++					scotch.h
++
++library_graph_induce_f$(OBJ)	:	library_graph_diam.c			\
++					module.h				\
++					common.h				\
++					scotch.h
++
+ library_graph_io_chac$(OBJ)	:	library_graph_io_chac.c			\
+ 					module.h				\
+ 					common.h				\
diff --git a/gnu/packages/patches/scotch-graph-diam-64.patch b/gnu/packages/patches/scotch-graph-diam-64.patch
new file mode 100644
index 0000000000..2ae31e3c3b
--- /dev/null
+++ b/gnu/packages/patches/scotch-graph-diam-64.patch
@@ -0,0 +1,27 @@
+Fixes test_scotch_graph_diam test with -DINTSIZE64.
+
+Reported upstream at
+https://gforge.inria.fr/tracker/index.php?func=detail&aid=21650&group_id=248&atid=1081
+
+--- scotch-6.0.5a/src/libscotch/library.h
++++ scotch-6.0.5a/src/libscotch/library.h
+@@ -187,6 +187,7 @@ SCOTCH_Num                  SCOTCH_graphBase    (SCOTCH_Graph * const, const SCO
+ int                         SCOTCH_graphCheck   (const SCOTCH_Graph * const);
+ void                        SCOTCH_graphSize    (const SCOTCH_Graph * const, SCOTCH_Num * const, SCOTCH_Num * const);
+ void                        SCOTCH_graphData    (const SCOTCH_Graph * const, SCOTCH_Num * const, SCOTCH_Num * const, SCOTCH_Num ** const, SCOTCH_Num ** const, SCOTCH_Num ** const, SCOTCH_Num ** const, SCOTCH_Num * const, SCOTCH_Num ** const, SCOTCH_Num ** const);
++SCOTCH_Num                  SCOTCH_graphDiamPV  (SCOTCH_Graph * const);
+ void                        SCOTCH_graphStat    (const SCOTCH_Graph * const, SCOTCH_Num * const, SCOTCH_Num * const, SCOTCH_Num * const, double * const, double * const, SCOTCH_Num * const, SCOTCH_Num * const, double * const, double * const, SCOTCH_Num * const, SCOTCH_Num * const, SCOTCH_Num * const, double * const, double * const);
+ int                         SCOTCH_graphCoarsen (const SCOTCH_Graph * const, const SCOTCH_Num, const double, const SCOTCH_Num, SCOTCH_Graph * const, SCOTCH_Num * const);
+ int                         SCOTCH_graphCoarsenMatch (const SCOTCH_Graph * const, SCOTCH_Num * const, const double, const SCOTCH_Num, SCOTCH_Num * const);
+--- scotch-6.0.5a/src/libscotch/library_graph_diam.c
++++ scotch-6.0.5a/src/libscotch/library_graph_diam.c
+@@ -72,8 +72,7 @@
+ 
+ SCOTCH_Num
+ SCOTCH_graphDiamPV (
+-SCOTCH_Graph * const        grafptr,
+-const SCOTCH_Num            baseval)
++SCOTCH_Graph * const        grafptr)
+ {
+   return ((SCOTCH_Num) graphDiamPV ((Graph * const) grafptr));
+ }
diff --git a/gnu/packages/patches/scotch-graph-induce-type-64.patch b/gnu/packages/patches/scotch-graph-induce-type-64.patch
new file mode 100644
index 0000000000..d2eee52a7b
--- /dev/null
+++ b/gnu/packages/patches/scotch-graph-induce-type-64.patch
@@ -0,0 +1,19 @@
+Fixes return type of SCOTCH_graphInduceList and SCOTCH_graphInducePart
+so that the definition matches with -DINTSIZE64.
+
+Reported upstream at
+https://gforge.inria.fr/tracker/index.php?func=detail&aid=21608&group_id=248&atid=1081
+
+--- scotch_6.0.5a/src/libscotch/library.h.orig	2018-02-11 10:52:38.000000000 -0600
++++ scotch_6.0.5a/src/libscotch/library.h	2018-02-23 16:56:41.000000000 -0600
+@@ -199,8 +199,8 @@
+ int                         SCOTCH_graphGeomSaveChac (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
+ int                         SCOTCH_graphGeomSaveMmkt (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
+ int                         SCOTCH_graphGeomSaveScot (const SCOTCH_Graph * const, const SCOTCH_Geom * const, FILE * const, FILE * const, const char * const);
+-int                         SCOTCH_graphInduceList (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_Num * const, SCOTCH_Graph * const);
+-int                         SCOTCH_graphInducePart (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_GraphPart2 * const, const SCOTCH_GraphPart2, SCOTCH_Graph * const);
++SCOTCH_Num                  SCOTCH_graphInduceList (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_Num * const, SCOTCH_Graph * const);
++SCOTCH_Num                  SCOTCH_graphInducePart (const SCOTCH_Graph * const, const SCOTCH_Num, const SCOTCH_GraphPart2 * const, const SCOTCH_GraphPart2, SCOTCH_Graph * const);
+ 
+ int                         SCOTCH_graphMapInit (const SCOTCH_Graph * const, SCOTCH_Mapping * const, const SCOTCH_Arch * const, SCOTCH_Num * const);
+ void                        SCOTCH_graphMapExit (const SCOTCH_Graph * const, SCOTCH_Mapping * const);
diff --git a/gnu/packages/patches/zsh-CVE-2018-7548.patch b/gnu/packages/patches/zsh-CVE-2018-7548.patch
deleted file mode 100644
index 1ee15fad73..0000000000
--- a/gnu/packages/patches/zsh-CVE-2018-7548.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Fix CVE-2018-7548:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7548
-
-Patch copied from upstream source repository:
-
-https://sourceforge.net/p/zsh/code/ci/110b13e1090bc31ac1352b28adc2d02b6d25a102
-
-From 110b13e1090bc31ac1352b28adc2d02b6d25a102 Mon Sep 17 00:00:00 2001
-From: Joey Pabalinas <joeypabalinas@gmail.com>
-Date: Tue, 23 Jan 2018 22:28:08 -0800
-Subject: [PATCH] 42313: avoid null-pointer deref when using ${(PA)...} on an
- empty array result
-
----
- ChangeLog   | 5 +++++
- Src/subst.c | 2 +-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-#diff --git a/ChangeLog b/ChangeLog
-#index d2ba94afc..3037edda4 100644
-#--- a/ChangeLog
-#+++ b/ChangeLog
-#@@ -1,3 +1,8 @@
-#+2018-01-23  Barton E. Schaefer  <schaefer@zsh.org>
-#+
-#+       * Joey Pabalinas: 42313: Src/subst.c: avoid null-pointer deref
-#+       when using ${(PA)...} on an empty array result
-#+
-# 2018-01-23  Oliver Kiddle  <okiddle@yahoo.co.uk>
-# 
-#        * 42317: Completion/Linux/Command/_cryptsetup,
-diff --git a/Src/subst.c b/Src/subst.c
-index d027e3d83..a265a187e 100644
---- a/Src/subst.c
-+++ b/Src/subst.c
-@@ -2430,7 +2430,7 @@ paramsubst(LinkList l, LinkNode n, char **str, int qt, int pf_flags,
- 		val = aval[0];
- 		isarr = 0;
- 	    }
--	    s = dyncat(val, s);
-+	    s = val ? dyncat(val, s) : dupstring(s);
- 	    /* Now behave po-faced as if it was always like that... */
- 	    subexp = 0;
- 	    /*
--- 
-2.16.2
-
diff --git a/gnu/packages/patches/zsh-CVE-2018-7549.patch b/gnu/packages/patches/zsh-CVE-2018-7549.patch
deleted file mode 100644
index abefcdf2f9..0000000000
--- a/gnu/packages/patches/zsh-CVE-2018-7549.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Fix CVE-2018-7549:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7549
-
-Patch copied from upstream source repository:
-
-https://sourceforge.net/p/zsh/code/ci/c2cc8b0fbefc9868fa83537f5b6d90fc1ec438dd
-
-From c2cc8b0fbefc9868fa83537f5b6d90fc1ec438dd Mon Sep 17 00:00:00 2001
-From: Stephane Chazelas <stephane.chazelas@gmail.com>
-Date: Fri, 22 Dec 2017 22:17:09 +0000
-Subject: [PATCH] Avoid crash copying empty hash table.
-
-Visible with typeset -p.
----
- ChangeLog    |  2 ++
- Src/params.c | 11 +++++++----
- 2 files changed, 9 insertions(+), 4 deletions(-)
-
-#diff --git a/ChangeLog b/ChangeLog
-#index f74c26b88..e3628cfa7 100644
-#--- a/ChangeLog
-#+++ b/ChangeLog
-#@@ -1,5 +1,7 @@
-# 2018-01-04  Peter Stephenson  <p.stephenson@samsung.com>
-# 
-#+       * Stephane: 42159: Src/params.c: avoid crash copying empty hash table.
-#+
-#        * Sebastian: 42188: Src/Modules/system.c: It is necessary to
-#        close the lock descriptor in some failure cases.
-#
-diff --git a/Src/params.c b/Src/params.c
-index 31ff0445b..de7730ae7 100644
---- a/Src/params.c
-+++ b/Src/params.c
-@@ -549,10 +549,13 @@ scancopyparams(HashNode hn, UNUSED(int flags))
- HashTable
- copyparamtable(HashTable ht, char *name)
- {
--    HashTable nht = newparamtable(ht->hsize, name);
--    outtable = nht;
--    scanhashtable(ht, 0, 0, 0, scancopyparams, 0);
--    outtable = NULL;
-+    HashTable nht = 0;
-+    if (ht) {
-+	nht = newparamtable(ht->hsize, name);
-+	outtable = nht;
-+	scanhashtable(ht, 0, 0, 0, scancopyparams, 0);
-+	outtable = NULL;
-+    }
-     return nht;
- }
- 
--- 
-2.16.2
-