summary refs log tree commit diff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7385c78b9f..7ab8174ffa 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -89,13 +89,12 @@ POSIX regular expression API.")
 (define-public pcre2
   (package
     (name "pcre2")
-    (replacement pcre2/fixed)
     (version "10.33")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcre/pcre2/"
                                   version "/pcre2-" version ".tar.bz2"))
-
+              (patches (search-patches "pcre2-fix-jit_match-crash.patch"))
               (sha256
                (base32
                 "1anqi7vpbfzag7imccrc6di1zl5rl63ab7rfpmajpw6d1kzlsl9m"))))
@@ -126,14 +125,3 @@ own native API, as well as a set of wrapper functions that correspond to the
 POSIX regular expression API.")
    (license license:bsd-3)
    (home-page "https://www.pcre.org/")))
-
-(define-public pcre2/fixed
-  ;; PHP >= 7.3.8 requires a fixed version at build time, so make it public
-  ;; and hide it in the UI.
-  (package
-    (inherit pcre2)
-    (source
-     (origin
-       (inherit (package-source pcre2))
-       (patches (search-patches "pcre2-fix-jit_match-crash.patch"))))
-    (properties '((hidden? . #t)))))