summary refs log tree commit diff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 0324a21261..cf8c1fb2b0 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -33,6 +33,7 @@
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public pcre
@@ -62,7 +63,9 @@
                           "--enable-pcre16"
                           "--enable-pcre32"
                           ;; pcretest fails on powerpc32.
-                          ,@(if (target-ppc32?)
+                          ;; riscv64-linux is an unsupported architecture.
+                          ,@(if (or (target-ppc32?)
+                                    (target-riscv64?))
                               '()
                               `("--enable-jit")))
       #:phases (modify-phases %standard-phases