summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 820a879288..2dd3c9e32c 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -79,7 +79,8 @@
             (uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
                                 version ".tar.gz"))
             (sha256 (base32
-                     "1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))))
+                     "1jnfzdqc54wa73lw28kjv0m7120mksb0zkcn81jdlvijyvc67kq2"))
+            (patches (list (search-patch "xpdf-constchar.patch")))))
    (build-system gnu-build-system)
    (inputs `(("freetype" ,freetype)
              ("gs-fonts" ,gs-fonts)
@@ -90,13 +91,9 @@
              ("libxp" ,libxp)
              ("libxpm" ,libxpm)
              ("libxt" ,libxt)
-             ("zlib" ,zlib)
-             ("patch/constchar"
-                 ,(search-patch "xpdf-constchar.patch"))))
+             ("zlib" ,zlib)))
    (arguments
     `(#:tests? #f ; there is no check target
-      #:patches (list (assoc-ref %build-inputs
-                                 "patch/constchar"))
       #:phases
        (alist-replace
         'install