summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index f6db546a88..f75a060a4b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -338,7 +338,16 @@ interaction.")
        ("zlib" ,zlib)))
     (arguments
      `(#:configure-flags '("-DPODOFO_BUILD_SHARED=ON"
-                           "-DPODOFO_BUILD_STATIC=ON")))
+                           "-DPODOFO_BUILD_STATIC=ON")
+       #:phases
+         (alist-cons-before
+         'configure 'patch
+         (lambda* (#:key inputs #:allow-other-keys)
+           (let ((freetype (assoc-ref inputs "freetype")))
+             ;; Look for freetype include files in the correct place.
+             (substitute* "cmake/modules/FindFREETYPE.cmake"
+               (("/usr/local") freetype))))
+         %standard-phases)))
     (home-page "http://podofo.sourceforge.net")
     (synopsis "Tools to work with the PDF file format")
     (description