summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm23
1 files changed, 5 insertions, 18 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 029b299e77..7f3dccc8ba 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -76,14 +76,14 @@
 (define-public poppler
   (package
    (name "poppler")
-   (version "0.50.0")
+   (version "0.52.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://poppler.freedesktop.org/poppler-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0dmwnh59m75vhii6dw63x8l0qa0ha733pb8bdqzr7lw9nwc37jf9"))))
+              "14hrrac2f1phi5j0qn283457w06vsp9gr075yqjrm7w370bnd2sj"))))
    (build-system gnu-build-system)
    ;; FIXME:
    ;;  use libcurl:        no
@@ -484,7 +484,6 @@ extracting content or merging files.")
 (define-public mupdf
   (package
     (name "mupdf")
-    (replacement mupdf/fixed)
     (version "1.10a")
     (source
       (origin
@@ -494,7 +493,9 @@ extracting content or merging files.")
         (sha256
          (base32
           "0dm8wcs8i29aibzkqkrn8kcnk4q0kd1v66pg48h5c3qqp4v1zk5a"))
-        (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"))
+        (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"
+                                 "mupdf-mujs-CVE-2016-10132.patch"
+                                 "mupdf-mujs-CVE-2016-10133.patch"))
         (modules '((guix build utils)))
         (snippet
             ;; Delete all the bundled libraries except for mujs, which is
@@ -543,20 +544,6 @@ line tools for batch rendering (pdfdraw), rewriting files (pdfclean),
 and examining the file structure (pdfshow).")
     (license license:agpl3+)))
 
-(define mupdf/fixed
-  (package
-    (inherit mupdf)
-    (source
-      (origin
-        (inherit (package-source mupdf))
-        (patches
-          (append
-            (origin-patches (package-source mupdf))
-            (search-patches "mupdf-mujs-CVE-2016-10132.patch"
-                            "mupdf-mujs-CVE-2016-10133.patch"
-                            "mupdf-CVE-2017-5896.patch"
-                            "mupdf-CVE-2017-5991.patch")))))))
-
 (define-public qpdf
   (package
    (name "qpdf")